Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 1 of 1
  1. #1
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default Please read before posting Errors, Problems or Bugs

    We're interested in all kinds of feedback, this also includes problems while deploying or running Open-Xchange Server. Before posting, please use the search functionality of this forum or bugzilla to find related postings and reports. To provide you with quick and correct feedback, please gather some information to your posting:

    The Open-Xchange Server version
    • Can be obtained from the user interface "Help" -> "About"

    The operating system and version
    • At the server and, when relevant, at the client

    The client and its version
    • For example the browser, webdav client if its relevant

    The Java vendor and version
    • Can be obtained by executing "java -version" at the server console

    A list of all installed packages
    • Debian: dpkg -l | grep open-xchange

    • SLES/RHEL: rpm -qa | grep open-xchange

    A list of all available bundles and their status
    • /opt/open-xchange/sbin/listbundes

    List of running Open-Xchange Server processes
    • ps axf | grep open-xchange

    The exact error messages including error codes
    • Screenshots, copy&pasted error messages, log files

    Log files
    • Typically available at /var/log/open-xchange/

    Test data
    • For example an E-Mail which triggers a specific behavior


    When posting those information, please make sure that no confidential data is included.

    If you are sure that the problem might be a bug, please use our bugtracker at https://bugs.open-xchange.com/.
    If you have a valid maintenance or support subscription, please contact the support directly.

    Common pitfalls
    • On Debian, "apt-get dist-upgrade" must be used to update to a newer ox version

    • The browser cache needs to be cleared after applying a GUI update of versions earlier than 6.18

    • Never use the script /opt/open-xchange/sbin/open-xchange-groupware directly

    • Always use the script /etc/init.d/open-xchange-groupware to start or stop the service

    • Make sure /opt/open-xchange/etc/groupware/osgi is recursively chown'ed to user 'open-xchange'

    • Open-Xchange Server does not work with GCJ, it requires SUN or IBM Java >1.5

    • Apache Tomcat and Open-Xchange Server 6 use the same TCP Port (8009). Only one of them must run at the same time - or different ports need to be configured. OX6 does not require Tomcat.

    • At the installation, a MySQL 'root' password must not be set, otherwise a user 'openexchange' needs to be created manually


    Please keep in mind that this forum is a community driven support and discussion platform. There are no service level agreements bound to postings, even if the issue is critical to you. Posting all details helps to provide fast help. Please be kind to other users, especially those who do not have much expertise yet. The forum moderators will remove postings and ban users for any kind of unrelated advertising or rude behavior by zero-tolerance.

    Thanks
    Last edited by Carsten Hoeger; 09-01-2010 at 08:29 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •