Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    svschwartz Guest

    Default message header default charset

    Well basically all mail is in utf8 but there are some messages that don't have an encoded headers and therefore not displayed correctly.

    The following subject is displayed correctly
    Subject: =?koi8-r?B?Rlc6INPU0tXL1NXSwSD88/Q=?=
    This one is not, though it is utf8
    Subject: Auto: еще превед
    I've looked at every config in /opt/open-xchange/etc/groupware and for any charset option set UTF-8. Nothing has helped, yet.

    Any ideas ?

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    2.2. Header Fields


    Header fields are lines composed of a field name, followed by a colon
    (":"), followed by a field body, and terminated by CRLF. A field
    name MUST be composed of printable US-ASCII characters (i.e.,
    characters that have values between 33 and 126, inclusive), except
    colon. A field body may be composed of any US-ASCII characters,
    except for CR and LF. However, a field body may contain CRLF when
    used in header "folding" and "unfolding" as described in section
    2.2.3. All field bodies MUST conform to the syntax described in
    sections 3 and 4 of this standard.


    http://tools.ietf.org/html/rfc2822#section-2.2
    OXpedia.org - the answer to almost all questions.

  3. #3
    svschwartz Guest

    Default

    Thank you Carsten!

    Yes. That is rfc violation.

    Unfortunately I don't have control under server that generates this sort of messages so my hope was that maybe there is a workaround

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    If the subject is really encoded in UTF-8, it should work, if the mailer uses UTF-8 per default.

    In /opt/open-xchange/etc/groupware/mail.properties you can set this parameter:

    Code:
    # Define the default MIME charset used for character encoding. This setting will then be
    # accessible through system property "mail.mime.charset". This parameter takes
    # effect for the complete mail module where no charset is given.
    mail.mime.charset=UTF-8
    OXpedia.org - the answer to almost all questions.

  5. #5
    svschwartz Guest

    Default

    Carsten

    It is really utf-8. When I look at message source in OX I can read subject ok and page charset is utf-8 as browser says.

    In /opt/open-xchange/etc/groupware/mail.properties
    mail.mime.charset=UTF-8
    True.

  6. #6
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Sorry, I fear I cannot really help here.
    I don't know why and where the encoding gets broken from imap to the web browser, but I can imagine, that this is something like a double encoding problem.

    You might open a bug in our bugzilla at

    https://bugs.open-xchange.com/
    OXpedia.org - the answer to almost all questions.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •