Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    tcrass Guest

    Question createcontext error [Debian, Lenny]

    When attempting to create a context, I get the following:

    createcontext -A oxadminmaster -P password -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p password -L defaultcontext -e email@domain.com -q 1024 --access-combination-name=all

    context 1 could not be created:
    Server response:
    Error unmarshaling return; nested exception is:
    java.lang.ClassNotFoundException: com.mysql.jdbc.exceptions.MySQLNonTransientConnect ionException (no security manager: RMI class loader disabled)
    I think this is the problem.

    Admin Log Error:
    Caused by: java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
    I am not using openexchange as a user anywhere in my DB setup... where did this come from and how do I change to to my 'real' DB user so it can connect?

    I've read through the prior posts on the forums but haven't been able to find a solution. Thanks!

  2. #2

    Default

    I am not using openexchange as a user anywhere in my DB setup... where did this come from and how do I change to to my 'real' DB user so it can connect?

    I've read through the prior posts on the forums but haven't been able to find a solution. Thanks!
    Like stated in the installation howtos (e.g. http://oxpedia.org/wiki/index.php?ti...for_Debian_5.0) open-xchange needs a database user, which will be created with the /opt/open-xchange/sbin/initconfigdb script. Default is openexchange, but you are also able to give a separate user here.
    Please take it look at the howtos, in general this should help.

    Regards,

    Dennis

  3. #3
    tcrass Guest

    Default

    Quote Originally Posted by Dennis Sieben View Post
    Like stated in the installation howtos (e.g. http://oxpedia.org/wiki/index.php?ti...for_Debian_5.0) open-xchange needs a database user, which will be created with the /opt/open-xchange/sbin/initconfigdb script. Default is openexchange, but you are also able to give a separate user here.
    Please take it look at the howtos, in general this should help.

    Regards,

    Dennis
    I am following that installation guide, as a matter of fact I've had it up since I started the process.

    The command I first ran:
    ./initconfigdb --configdb-user=mydbuser --configdb-pass=password --configdb-host=localhost --configdb-dbname=oxchange
    Then:
    ./oxinstaller --servername=newox --imapserver=mail.mydomain.com --smtpserver=localhost --configdb-user=mydbuser --configdb-pass=password --configdb-dbname=oxchange --master-pass=mpassword --no-license
    Then:
    ./registerserver -n newox -A oxadminmaster -P mpassword
    Then:
    ./registerdatabase -A oxadminmaster -P mpassword -n oxprod -p password -m true
    Then:
    ./createcontext -A oxadminmaster -P mpassword -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p password -L defaultcontext -e email@domain.com -q 1024 --access-combination-name=all
    And that's where I get the error specified. I used and provided appropriate credentials up to this point as far as I can tell. I've checked this multiple times and if I am missing something, I certainly can't seem to find it; unless it's something in my former command set (those above).

    Thanks!

  4. #4

    Default

    Did you restart the admin daemon process after the oxinstaller step?

    Regards,

    Dennis

  5. #5
    tcrass Guest

    Default

    Quote Originally Posted by Dennis Sieben View Post
    Did you restart the admin daemon process after the oxinstaller step?

    Regards,

    Dennis
    Yes, restarted admin and the groupware daemons both just to be sure.

  6. #6
    tcrass Guest

    Default

    Just to be sure about things I ran through the whole process again. I got to the same spot and received the same error.

    What it seems is happening is that I've set the user to the non-default database user (which is what I really want due to how I set my system up) and some script that is getting called by the createcontext command is attempting to throw default values into the db connection rather than actually using the ones I provided...

    Not sure if this truly is the case but so far it is the only explanation I can come up with.

  7. #7
    tcrass Guest

    Default

    After some further troubleshooting and looking at the configdb entries it appears that the biggest problem I'm running into is that the createcontext command is attempting to 'create' a database for me instead of using the database I specify for it.

    If I pre-create the database it's asking for it errors and tells me that the DB already exists and dies.

    I hate to criticize but I feel obligated to say that that's a pretty poor way to script a setup given that I can't easily integrate this system into an existing setup without more or less granting god rights to the whole system... which I didn't want to do. Maybe there's a good reason for this but I'm a bit baffled as to why? Why not let the user create/manage the db information as they see fit.

    Also, with the oxinstaller command, I verified that I was putting in the database user information. However, for some reason it was not putting that information into the DB like it should have so I had to manually edit the database to get the right username there.

  8. #8
    tcrass Guest

    Default

    Well, I guess the good news is that I did manage to get past the error by giving the oxdbuser complete god rights on my MySQL server (definitely not a good practice).

    I managed to get logged into the system. Though straight away ran into more quirks, this time involving mail account setup. If you don't have the absolute perfect values for the defaultcontext already setup it appears that they're not able to be modified once the system is up and running.

    Given what I've been through so far, I'm not surprised. Though, after sinking so much time into this I'm wondering if it really is even worth it. I would have expected such a complex system to at least offer settings flexibility in setup and configuration.

    The deeper into this I get the more I'm finding that if you don't follow the instructions and the 'specific' spec that the software needs to run (which is pretty narrow), you're going to just wind up in problem after problem.

    I have high hopes for this but at the same time... I just don't know with all the fighting I've had to do.

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    there are several reasons why ox manages the database schema itself. You may have noticed, that all groupware databases use the same prefix, the one you specified, plus an incrementing number. You can solve the permission issue by using wildcards on that specific pattern (databasename_%).

    Greetings
    Last edited by Martin Heiland; 03-23-2010 at 09:49 AM.

  10. #10

    Default

    Quote Originally Posted by tcrass View Post
    Well, I guess the good news is that I did manage to get past the error by giving the oxdbuser complete god rights on my MySQL server (definitely not a good practice).

    I managed to get logged into the system. Though straight away ran into more quirks, this time involving mail account setup. If you don't have the absolute perfect values for the defaultcontext already setup it appears that they're not able to be modified once the system is up and running.

    Given what I've been through so far, I'm not surprised. Though, after sinking so much time into this I'm wondering if it really is even worth it. I would have expected such a complex system to at least offer settings flexibility in setup and configuration.

    The deeper into this I get the more I'm finding that if you don't follow the instructions and the 'specific' spec that the software needs to run (which is pretty narrow), you're going to just wind up in problem after problem.

    I have high hopes for this but at the same time... I just don't know with all the fighting I've had to do.
    It's not necessary to give god right's to the database but the right to create databases and tables should be given.
    The rights set by the initconfigdb script are also too much as I saw from a quick review, I already opened a bug for this hee.

    I also took at look at your commands again, and I think I see the culprit.

    ./registerserver -n newox -A oxadminmaster -P mpassword
    In this command the dbuser is missing, and IIRC the default is openexchange. So if you use another one this will lead to the error. And of course the db user you use must have the right to create databases.

    In general you are correct about the complex setup. But this is why we deliver detailed howto descriptions. If someone follows the howtos he will get a nice running system in quite a few steps.
    If you need a special setting, etc. you will sooner or later run into complex setups and as an unexperienced user maybe problems. That's why we offer help for complex setups. But that's also how software works. I can't imagine any software which will not have a complex setup if you want to do complex things with it.

    Regards,

    Dennis

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •