Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1

    Default Problem update 6.14 to 6.16

    Hello!

    Last night I tried to update my open-xchange-server from version 6.14 to version 6.16.

    But every time i got this error:

    Code:
    SEVERE: UPD-0014 Category=8 Message=A SQL problem occurred: Table 'updatetask' already exists. exceptionID=1148779264-14
    UPD-0014 Category=8 Message=A SQL problem occurred: Table 'updatetask' already exists. exceptionID=1148779264-14
    	at com.openexchange.login.internal.LoginPerformer.doLogin(LoginPerformer.java:172)
    	at com.openexchange.ajax.Login.doLogin(Login.java:340)
    	at com.openexchange.ajax.Login.doGet(Login.java:138)
    	at com.openexchange.ajax.Login.doPost(Login.java:318)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:616)
    	at com.openexchange.ajax.AJAXServlet.service(AJAXServlet.java:384)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    	at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.doServletService(AJPv13RequestHandlerImpl.java:504)
    	at com.openexchange.ajp13.AJPv13Request.response(AJPv13Request.java:129)
    	at com.openexchange.ajp13.najp.AJPv13RequestHandlerImpl.createResponse(AJPv13RequestHandlerImpl.java:316)
    	at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.createResponse(AJPv13ConnectionImpl.java:207)
    	at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13Task.java:346)
    	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
    	at java.util.concurrent.FutureTask.run(FutureTask.java:123)
    	at com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.runTask(CustomThreadPoolExecutor.java:737)
    	at com.openexchange.threadpool.internal.CustomThreadPoolExecutor$Worker.run(CustomThreadPoolExecutor.java:763)
    	at java.lang.Thread.run(Thread.java:595)
    Caused by: UPD-0014 Category=8 Message=A SQL problem occurred: Table 'updatetask' already exists. exceptionID=1148779264-13
    	at com.openexchange.groupware.contexts.impl.CachingContextStorage.loadContext(CachingContextStorage.java:163)
    	at com.openexchange.groupware.contexts.impl.ContextStorage.getContext(ContextStorage.java:112)
    	at com.openexchange.login.internal.LoginPerformer.findContext(LoginPerformer.java:190)
    	at com.openexchange.login.internal.LoginPerformer.doLogin(LoginPerformer.java:116)
    	... 16 more
    Caused by: UPD-0014 Category=8 Message=A SQL problem occurred: Table 'updatetask' already exists. exceptionID=1148779264-12
    	at com.openexchange.groupware.update.internal.UpdaterImpl.getSchema(UpdaterImpl.java:124)
    	at com.openexchange.groupware.update.internal.UpdaterImpl.getStatus(UpdaterImpl.java:81)
    	at com.openexchange.groupware.update.Updater.getStatus(Updater.java:78)
    	at com.openexchange.groupware.contexts.impl.CachingContextStorage$1.load(CachingContextStorage.java:143)
    	at com.openexchange.groupware.contexts.impl.CachingContextStorage$1.load(CachingContextStorage.java:150)
    	at com.openexchange.cache.dynamic.impl.Refresher.refresh(Refresher.java:172)
    	at com.openexchange.groupware.contexts.impl.ContextReloader.<init>(ContextReloader.java:78)
    	at com.openexchange.groupware.contexts.impl.CachingContextStorage.loadContext(CachingContextStorage.java:158)
    	... 19 more
    Caused by: UPD-0014 Category=8 Message=A SQL problem occurred: Table 'updatetask' already exists. exceptionID=1148779264-11
    	at com.openexchange.groupware.update.internal.SchemaExceptionFactory.createException(SchemaExceptionFactory.java:75)
    	at com.openexchange.groupware.update.internal.SchemaExceptionFactory.createException(SchemaExceptionFactory.java:61)
    	at com.openexchange.exceptions.Exceptions.create(Exceptions.java:139)
    	at com.openexchange.exceptions.Exceptions.create(Exceptions.java:159)
    	at com.openexchange.groupware.update.internal.SchemaExceptionCodes.create(SchemaExceptionCodes.java:151)
    	at com.openexchange.groupware.update.internal.SchemaStoreImpl.getSchema(SchemaStoreImpl.java:108)
    	at com.openexchange.groupware.update.SchemaStore.getSchema(SchemaStore.java:110)
    	at com.openexchange.groupware.update.internal.UpdaterImpl.getSchema(UpdaterImpl.java:122)
    	... 26 more
    Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'updatetask' already exists
    	at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1026)
    	at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
    	at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3491)
    	at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3423)
    	at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1936)
    	at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2060)
    	at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2536)
    	at com.mysql.jdbc.StatementImpl.executeUpdate(StatementImpl.java:1564)
    	at com.mysql.jdbc.StatementImpl.executeUpdate(StatementImpl.java:1485)
    	at com.openexchange.groupware.update.internal.SchemaStoreImpl.createTable(SchemaStoreImpl.java:133)
    	at com.openexchange.groupware.update.internal.SchemaStoreImpl.checkForTable(SchemaStoreImpl.java:125)
    	at com.openexchange.groupware.update.internal.SchemaStoreImpl.getSchema(SchemaStoreImpl.java:103)
    	... 28 more
    I think the problem is, that the mysql database is not on the same host where the ox-server is running.

    Can anyone help me to solve the problem. I reconstructed the backup, so now the ox-server runs on the version 6.14, but i will upgrade to 6.16.

    The host system as an ubuntu 8.04 lts with 64 bit vmware system. I did the update with the command dist-upgrade.

    Best regards

    Christian

  2. #2
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    49

    Default MySQL case-insensitive

    Hi Christian,

    the problem is caused by your MySQL setup. Ubuntu seems to configure MySQL to be case-insensitive. If a table is then created with the name 'updateTask' MySQL makes the name lowercase. That lowercase table is than not discovered by OX because we make a case sensitive match.

    I already made the change to discover this table case insensitive. But this will come with 6.18. To fix your issue please change the configuration of MySQL to be case sensitive. AFAIK this option is named lower_case_table_names.

    Regards,
    Marcus

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    If that was the case, please let us know!
    OXpedia.org - the answer to almost all questions.

  4. #4

    Default

    Hello!

    I solved the problem with your hint - thank you!

  5. #5
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    The fix is described in Marcus post above. Direct link: http://www.open-xchange.com/forum/sh...02&postcount=2
    OXpedia.org - the answer to almost all questions.

  6. #6
    Join Date
    Feb 2007
    Posts
    113

    Default

    hi,
    yes this is a fix. But in our case we use some other software where case-insensitivity is a must(!). So i guess OX should solve this to provide a consistent access to tables - i mean unique table names, case insensitive.

    Here we had to setup a new mysql server, because mysql-case-sensitive settings are not db related(!) - and update to 6.16 was not that nice
    regards

  7. #7
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    49

    Default

    In our case for Open-Xchange case-sensitivity is a nice-to-have! Case-insensitive systems are mostly M$ originated. All other systems work by default case-sensitive. Now guess why we choose case-sensitivity.

    So I guess that other software should solve this and not create table names with uppercase and require them with lowercase letters. Simply keep tables names as they are created and do not force them lowercase. If you configure MySQL to keep the name as it is created everything would work fine. Why does that other software do not work if everything is not forced to lowercase?

    I would encourage to setup OX with its own MySQL server because OX responsiveness relies on MySQL responsiveness.

    The problem with forced lowercase names is fixed with 6.18 release. Either buy OX maintenance to get this fixed in 6.16 release or wait for 6.18 release.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •