Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Join Date
    Jan 2008
    Posts
    140

    Default Installation problem SLES11SP1

    Hi,

    I'm currently trying to install the open xchange on a new machine.
    I tested everything on a SLES11 box, but now I want to use the new release.

    I used the same steps as shown in
    http://oxpedia.org/index.php?title=O...igure_services

    But now after starting the server for the first time
    the registration does not work:

    $ rcopen-xchange-admin start # works fine

    $ /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password

    error message:
    server could not be registered:
    Error: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused

    From the log file:
    Sep 2, 2010 11:15:26 AM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager fixService
    SEVERE: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
    Sep 2, 2010 11:15:26 AM org.apache.jcs.auxiliary.lateral.LateralCacheResto re canFix
    SEVERE: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462
    Sep 2, 2010 11:15:26 AM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
    SEVERE: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
    Sep 2, 2010 11:15:26 AM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager fixService
    SEVERE: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
    Sep 2, 2010 11:15:26 AM org.apache.jcs.auxiliary.lateral.LateralCacheResto re canFix
    SEVERE: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462


    I used localhost (pointing to 127.0.0.1) in the previous steps, but nothing seems to listen here....

    What's wrong ? Any idea ?

    Thanks & bye, Peer

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Peer,

    could you please check if the open-xchange-admin process is running? Try to ping "localhost" and nmap it for open ports. Port 1099 needs to be listening to accept RMI calls by the command line tools. Perhaps some firewall is blocking it?

    Greetings

  3. #3
    Join Date
    Jan 2008
    Posts
    140

    Default

    Hi,

    ping is working:
    ping localhost
    PING localhost (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.019 ms
    64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.018 ms


    open ports:
    ~ # netstat -a
    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 localhost:distinct32 *:* LISTEN
    tcp 0 0 *:sunrpc *:* LISTEN
    tcp 0 0 *:57461 *:* LISTEN
    tcp 0 0 *:ssh *:* LISTEN
    tcp 0 0 localhost:smtp *:* LISTEN
    tcp 0 0 *:54150 *:* LISTEN
    tcp 0 0 *:mysql *:* LISTEN
    tcp 0 0 localhost:47529 localhost:48411 FIN_WAIT2
    tcp 0 0 cal.xxx.de:ssh vibra.xxx:45374 VERBUNDEN
    tcp 0 0 cal.xxx.de:ssh vibra.xxx:52943 VERBUNDEN
    tcp 0 0 cal.xxx.:56958 ldap1.xxx:ldap VERBUNDEN
    tcp 1 0 cal.xxx.:52392 ldap2.xxx:ldap CLOSE_WAIT
    tcp 0 0 cal.xxx.:48952 yup.xxx.de:www-http TIME_WAIT
    tcp 0 0 cal.xxx.:48954 yup.xxx.de:www-http TIME_WAIT
    tcp 1 0 localhost:48411 localhost:47529 CLOSE_WAIT
    tcp 0 0 cal.xxx.de:ssh vibra.:57695 VERBUNDEN
    tcp 0 0 cal.xxx.:48953 yup.xxx.de:www-http TIME_WAIT
    tcp 0 0 cal.xxx.:48955 yup.xxx.de:www-http TIME_WAIT
    udp 0 0 *:sunrpc *:*
    udp 0 0 *:894 *:*


    The only not system processes are:
    /bin/sh /usr/bin/mysqld_safe --mysqld=mysqld --user=mysql --pid-file=/var/lib/mysql/mysqld.pid --socket=/var/lib/my
    /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/mysqld.pid --skip-e
    /usr/bin/java -Djava.net.preferIPv4Stack=true -Xmx50M -Dopenexchange.propdir=/opt/open-xchange/etc/admindaemon -Dop

    Is the java think the admin process ?

    Thanks for the quick response !

    Bye, Peer

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Yeah, the java process is the admindaemon process. However, port 1099 (rmiregistry) is not open. Could you check the admin log file while starting up and if some service is blocking this port from being opened?

    Thanks

  5. #5
    Join Date
    Jan 2008
    Posts
    140

    Default

    Here is the LOG from one start.
    I'll rebooted the machine to clean up everything.
    The log is from one start only.

    I've also tryied to shutdown the firewall and/or apparmor.
    Both services have no influence - as expected ...

    Thanks & bye , peer
    Attached Files Attached Files

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, seems like there are more issue starting the admindaemon. Could you please post a list of all installed open-xchange* packages and the output of java -version?

    Thanks

  7. #7
    Join Date
    Jan 2008
    Posts
    140

    Default

    cal:~ # rpm -qa | grep xcha
    open-xchange-jcharset-1.3.0-42_42.1
    open-xchange-xml-6.18.0.0-7_7.1
    open-xchange-publish-6.18.0.0-7_7.1
    open-xchange-management-6.18.0.0-7_7.1
    open-xchange-server-6.18.0.0-7_8.1
    open-xchange-genconf-mysql-6.18.0.0-7_7.2
    open-xchange-calendar-6.18.0.0-7_7.2
    open-xchange-subscribe-microformats-6.18.0.0-7_7.2
    open-xchange-messaging-facebook-6.18.0.0-7_7.2
    open-xchange-admin-plugin-hosting-6.18.0.0-7_7.2
    open-xchange-online-help-fr-6.18.0.0-6_8.1
    open-xchange-gui-wizard-plugin-gui-6.18.0.0-8_10.1
    open-xchange-genconf-6.18.0.0-7_7.1
    open-xchange-configread-6.18.0.0-7_7.1
    open-xchange-cache-6.18.0.0-7_7.1
    open-xchange-settings-extensions-6.18.0.0-7_7.2
    open-xchange-control-6.18.0.0-7_7.2
    open-xchange-publish-basic-6.18.0.0-7_7.2
    open-xchange-messaging-twitter-6.18.0.0-7_7.2
    open-xchange-meta-pubsub-6.18.0.0-7_7.1
    open-xchange-voipnow-gui-6.18.0.0-7_7.1
    open-xchange-online-help-en-6.18.0.0-6_8.1
    open-xchange-admin-doc-6.18.0.0-7_7.2
    open-xchange-common-6.18.0.0-7_7.1
    open-xchange-sql-6.18.0.0-7_7.1
    open-xchange-charset-6.18.0.0-7_7.1
    open-xchange-dataretention-6.18.0.0-7_7.1
    open-xchange-templating-6.18.0.0-7_7.2
    open-xchange-conversion-engine-6.18.0.0-7_7.1
    open-xchange-sessiond-6.18.0.0-7_7.1
    open-xchange-unifiedinbox-6.18.0.0-7_7.2
    open-xchange-push-udp-6.18.0.0-7_7.2
    open-xchange-gui-wizard-plugin-6.18.0.0-8_10.1
    open-xchange-contactcollector-6.18.0.0-7_7.2
    open-xchange-admin-lib-6.18.0.0-7_7.2
    open-xchange-messaging-generic-6.18.0.0-7_7.2
    open-xchange-publish-microformats-6.18.0.0-7_7.2
    open-xchange-messaging-rss-6.18.0.0-7_7.2
    open-xchange-subscribe-crawler-6.18.0.0-10_12.1
    open-xchange-admin-client-6.18.0.0-7_7.2
    open-xchange-meta-admin-6.18.0.0-7_7.1
    open-xchange-mobile-configuration-json-6.18.0.0-7_7.2
    open-xchange-online-help-de-6.18.0.0-6_8.1
    open-xchange-activation-1.1.1-42_42.1
    open-xchange-admin-plugin-hosting-doc-6.18.0.0-7_7.2
    open-xchange-meta-gui-6.18.0.0-7_7.1
    open-xchange-secret-6.18.0.0-16_16.1
    open-xchange-crypto-6.18.0.0-7_7.1
    open-xchange-twitter-6.18.0.0-7_7.1
    open-xchange-threadpool-6.18.0.0-7_7.1
    open-xchange-push-6.18.0.0-7_7.1
    open-xchange-spamhandler-default-6.18.0.0-7_7.2
    open-xchange-pop3-6.18.0.0-7_7.2
    open-xchange-imap-6.18.0.0-7_7.2
    open-xchange-calendar-printing-6.18.0.0-7_7.2
    open-xchange-themes-default-6.18.0.0-7_8.1
    open-xchange-admin-plugin-hosting-lib-6.18.0.0-7_7.2
    open-xchange-publish-json-6.18.0.0-7_7.2
    open-xchange-messaging-json-6.18.0.0-7_7.2
    open-xchange-meta-messaging-6.18.0.0-7_7.1
    open-xchange-admin-plugin-hosting-client-6.18.0.0-7_7.2
    open-xchange-meta-server-6.18.0.0-7_7.1
    open-xchange-gui-themes-default-6.18.0.0-7_8.1
    open-xchange-global-6.18.0.0-7_7.1
    open-xchange-conversion-6.18.0.0-7_7.1
    open-xchange-monitoring-6.18.0.0-7_7.1
    open-xchange-smtp-6.18.0.0-7_7.2
    open-xchange-conversion-servlet-6.18.0.0-7_7.2
    open-xchange-subscribe-6.18.0.0-7_7.2
    open-xchange-publish-infostore-online-6.18.0.0-7_7.2
    open-xchange-admin-6.18.0.0-7_7.2
    open-xchange-meta-singleserver-6.18.0.0-7_7.1
    open-xchange-gui-6.18.0.0-7_8.1
    open-xchange-xerces-ibm-6.18.0.0-7_7.1
    open-xchange-messaging-6.18.0.0-7_7.1
    open-xchange-i18n-6.18.0.0-7_7.1
    open-xchange-user-json-6.18.0.0-7_7.2
    open-xchange-data-conversion-ical4j-6.18.0.0-7_7.2
    open-xchange-authentication-database-6.18.0.0-7_7.2
    open-xchange-subscribe-json-6.18.0.0-7_7.2
    open-xchange-6.18.0.0-7_8.1
    open-xchange-report-client-6.18.0.0-7_7.2

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Thanks, looks fine so far. Could you please attach the contents of /etc/hosts and the output of "java -version" as well?

  9. #9
    Join Date
    Jan 2008
    Posts
    140

    Default

    cal:~ # cat /etc/hosts
    #
    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    195.37.229.32 cal.bgc-jena.mpg.de cal


    cal:~ # java -version
    java version "1.6.0"
    Java(TM) SE Runtime Environment (build pxa6460sr8-20100409_01(SR8))
    IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux amd64-64 jvmxa6460sr8-20100401_55940 (JIT enabled, AOT enabled)
    J9VM - 20100401_055940
    JIT - r9_20100401_15339
    GC - 20100308_AA)
    JCL - 20100408_01

  10. #10
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hrm, looks okay as well. I'm curious about the error message "No master credentials specified". Have you executed the initconfigdb and oxinstaller commands prior of starting the admin? Does the file /opt/open-xchange/etc/admindaemon/mpasswd exist and contain a entry like oxadminmaster:<hashed password>?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •