Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2011
    Posts
    1

    Default No Mail available

    Dear all,

    I have setup my OX follow this setup guide :http://oxpedia.org/wiki/index.php?ti...e_for_CentOS_5

    My OS is a Centos5 linux. I am not sure if there is a imapserver and a mta installed but there are two packages which let assume this would be the case.

    1) open-xchange-smtp.noarch 6.20.0.0-7_8.4 installed
    2) open-xchange-imap.noarch 6.20.0.0-7_8.4 installed

    When I login with my account then I get the message no connection to e-mail server possible.

    My open-xchange.log.0 tell me:

    Jun 28, 2011 7:32:15 AM com.openexchange.tools.exceptions.DefaultLoggingLo gic setupError
    SEVERE: Setup Error: MSG-0014 Category=10 Message=No mail account exists for admin user in context 1 exceptionID=26613365-315
    MSG-0014 Category=10 Message=No mail account exists for admin user in context 1 exceptionID=26613365-315
    at com.openexchange.folderstorage.mail.MailFolderStor age.getFolder(MailFolderStorage.java:649)
    at com.openexchange.folderstorage.cache.CacheFolderSt orage.loadFolder(CacheFolderStorage.java:1123)
    at com.openexchange.folderstorage.cache.CacheFolderSt orage.getFolder(CacheFolderStorage.java:706)
    at com.openexchange.folderstorage.cache.CacheFolderSt orage.getFolder(CacheFolderStorage.java:688)
    at com.openexchange.folderstorage.outlook.OutlookFold erStorage.getFolder(OutlookFolderStorage.java:910)
    at com.openexchange.folderstorage.cache.CacheFolderSt orage.loadFolder(CacheFolderStorage.java:1123)
    at com.openexchange.folderstorage.cache.CacheFolderSt orage.getFolder(CacheFolderStorage.java:706)
    at com.openexchange.folderstorage.cache.CacheFolderSt orage.getFolder(CacheFolderStorage.java:688)
    at com.openexchange.folderstorage.internal.performers .GetPerformer.doGet(GetPerformer.java:130)
    at com.openexchange.folderstorage.internal.FolderServ iceImpl.getFolder(FolderServiceImpl.java:161)
    at com.openexchange.folder.json.actions.GetAction.per form(GetAction.java:105)
    at com.openexchange.ajax.requesthandler.MultipleAdapt er.performRequest(MultipleAdapter.java:107)
    at com.openexchange.ajax.Multiple.doAction(Multiple.j ava:214)
    at com.openexchange.ajax.Multiple.parseActionElement( Multiple.java:173)
    at com.openexchange.ajax.Multiple.doPut(Multiple.java :125)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:619)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:413)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:219)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 523)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:134)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:33 5)
    at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:227)
    at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13 Task.java:352)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:166)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:750)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:776)
    at java.lang.Thread.run(Thread.java:636)
    Caused by: MSG-0014 Category=10 Message=No mail account exists for admin user in context 1 exceptionID=26613365-314
    at com.openexchange.mail.api.MailAccess.checkAdminLog in(MailAccess.java:679)
    at com.openexchange.mail.api.MailAccess.getInstance(M ailAccess.java:254)
    at com.openexchange.folderstorage.mail.MailFolderStor age.getFolder(MailFolderStorage.java:570)
    ... 28 more

    Any suggestions?

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    open-xchange-imap and -smtp are protocol implementations on the client side, not imap or smtp servers. OX does not ship a e-mail server backend. You need to setup such a thing using software like dovecot, cyrus, postfix... Then you can point OX user accounts to existing IMAP/SMTP accounts.

    Greetings

  3. #3
    Join Date
    Jun 2010
    Posts
    1

    Default

    Hi logan,

    I got the sam error after upgraded an Open-Xchange SE to version 6.20.

    The mail access for the admin user seems to be configurable in curren Open-Xchange versions.

    Look at the file /opt/open-xchange/etc/groupware/mail.properties. There's an entry

    com.openexchange.mail.adminMailLoginEnabled=false

    If you set this to "true", the email access of the admin user will be possible.

    regards,
    martin!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •