Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2010
    Posts
    19

    Default Session expires after 10 minutes

    Hi,

    Since installing the latest update for Open-XChange-SE [Version : 6.20.0 Rev20 (2011-07-25 17:04:53)] the web GUI session appears to timeout after 10 minutes of inactivity. I see this message in a box:

    Session has expired
    Your session has expired. Please log in again. (Error-ID: 1396257281-10748)

    Can someone please point me to the configuration setting used to increase this timeout? Perhaps I overwrote it on updating or maybe it's just new?

    Thanks,

    --
    Goad

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please check the full error message (at the servers log file) first, to find out what caused the session termination. Otherwise, session lifetime related settings are located at sessiond.properties. It could also be, that the client IP changes while working with the session or the cookie gets lost at the client. This will trigger the same error message.

    Martin

  3. #3
    Join Date
    Sep 2010
    Posts
    19

    Default

    Thanks for the quick reply.

    I think I have found the source of the problem: in a normal browser (e.g. Firefox) it works just fine, but I was using the mail client Thunderbird as a browser - I use the WAT (Web Application Tab) extension. My Thunderbird also has the Open-XChange Thunderbird Connector configured and running (although I don't use it anymore since the project appears to have died). The Open-XChange Connector was configured to access the server every 10 minutes and when it connected it threw out the web GUI session with the error message I mentioned. Presumably the server no longer likes to have two logins from the same PC and the same application at the same time?

    Note: this appears to be new behaviour since 6.20.0 Rev20 (or possibly 19 - which we skipped). However, the simple solution is just not to use OX Connector at all and use the OX GUI in a browser tab in Thunderbird or in a completely separate browser.

    Thanks for your help.

    --
    Goad

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •