Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    May 2010
    Posts
    21

    Default ActiveSync after upgrade to iOS5 stops working

    Hi,

    I have Open-Xchange Server Edition and OXtender for Business Mobility. In the past, there was no problem with synchronization of the contacts, calendar and todo items ti my iPhone 4. Two days ago I upgraded my iPhone's firmware to iOS5 - and synchronization doesn't work any more.

    Regards Andreas

  2. #2
    Join Date
    May 2010
    Posts
    21

    Default Error message

    Don't know if error is caused by the upgrade of my iPhone to iOS5 or because I applied the latest patch to OX.

    Critical error seems to be:
    Request to server denied for session: 9272e067081e4d2cb743ddb39365fbca. Client login IP changed from 217.86.xxx.166 to 178.63.yy.199.
    The first IP is the address of my iPhone, the second is the IP address of the ox server.

    Here is the error messsage in /var/log/open-xchange/open-xchange.log.0


    15.10.2011 23:15:04 com.openexchange.log.internal.LoggerTask call
    INFO: Logged at: com.openexchange.authentication.imap.impl.IMAPAuth entication.handleLoginInfo(IMAPAuthentication.java :324)
    Imap authentication for user muristan@example.com successful on host localhost:143
    15.10.2011 23:15:04 com.openexchange.log.internal.LoggerTask call
    INFO: Logged at: com.openexchange.ajax.Login.doLogin(Login.java:857 )
    Login:andreas.muristan IP:217.86.xxx.166 AuthID:138f6ccd-d1b9-43ee-931d-83cb8f141e91 Agent:Jakarta Commons-HttpClient/3.1 Client:USM-EAS(6.20.0.0-4371) Interface:HTTP_JSON Context:1(1,defaultcontext) User:3(andreas.keller) Session:9272e067081e4d2cb743ddb39365fbca Random:f77f918ebef643698a7f5bcc96f54473
    15.10.2011 23:15:04 com.openexchange.log.internal.LoggerTask call
    INFO: Logged at: com.openexchange.ajax.SessionServlet.checkIP(Sessi onServlet.java:358)
    Request to server denied for session: 9272e067081e4d2cb743ddb39365fbca. Client login IP changed from 217.86.xxx.166 to 178.63.yy.199.
    15.10.2011 23:15:04 com.openexchange.log.internal.LoggerTask call
    INFO: Logged at: com.openexchange.mail.cache.MailAccessCacheEventLi stener.handleEvent(MailAccessCacheEventListener.ja va:120)
    Detected a removed session: 9272e067081e4d2cb743ddb39365fbca. Removed all possibly cached mail access instances for user 3 in context 1
    15.10.2011 23:15:04 com.openexchange.usm.eas.delegate.BaseXMLDelegate logError
    SCHWERWIEGEND: null Unknown OX response reading configuration
    180003: com.openexchange.usm.api.exceptions.OXCommunicatio nException: Unknown OX response reading configuration, server-response=OX Error: {"category":3,"error":"Request to server was refused. Original client IP address changed. Please try again.","error_params":[],"error_id":"-1882307544-35","code":"SES-0205"}
    at com.openexchange.usm.ox_json.impl.OXJSONAccessImpl .readConfiguration(OXJSONAccessImpl.java:153)
    at com.openexchange.usm.ox_json.impl.OXJSONAccessImpl .getConfiguration(OXJSONAccessImpl.java:136)
    at com.openexchange.usm.ox_json.impl.OXJSONAccessServ ice.getConfiguration(OXJSONAccessService.java:156)
    at com.openexchange.usm.session.impl.SessionManagerIm pl.getSession(SessionManagerImpl.java:308)
    at com.openexchange.usm.session.impl.SessionManagerSe rvice.getSession(SessionManagerService.java:77)
    at com.openexchange.usm.eas.servlet.EASServlet.handle Request(EASServlet.java:499)
    at com.openexchange.usm.eas.servlet.EASServlet.doPost (EASServlet.java:397)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 562)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:138)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:36 4)
    at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:224)
    at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13 Task.java:394)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:138)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:750)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:776)
    at java.lang.Thread.run(Thread.java:662)


    And here is my /etc/apache2/conf.d/proxy_ajp.conf

    <Location /axis2>
    # restrict access to the soap provisioning API
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    # you might add more ip addresses / networks here
    # Allow from 192.168 10 172.16
    </Location>



    <IfModule mod_proxy_ajp.c>
    ProxyRequests Off
    # ProxyPass /usm-syncml ajp://127.0.0.1:8009/usm-syncml smax=0 ttl=60 retry=5
    <Proxy balancer://oxcluster>
    Order deny,allow
    Allow from all
    # multiple server setups need to have the hostname inserted instead localhost
    BalancerMember ajp://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
    # Enable and maybe add additional hosts running OX here
    # BalancerMember ajp://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
    ProxySet stickysession=JSESSIONID
    </Proxy>
    <Proxy /ajax>
    ProxyPass balancer://oxcluster/ajax
    </Proxy>
    <Proxy /axis2>
    ProxyPass balancer://oxcluster/axis2
    </Proxy>
    <Proxy /servlet>
    ProxyPass balancer://oxcluster/servlet
    </Proxy>
    <Proxy /infostore>
    ProxyPass balancer://oxcluster/infostore
    </Proxy>
    <Proxy /publications>
    ProxyPass balancer://oxcluster/publications
    </Proxy>
    <Proxy /Microsoft-Server-ActiveSync>
    ProxyPass balancer://oxcluster/Microsoft-Server-ActiveSync
    </Proxy>
    <Proxy /usm-json>
    ProxyPass balancer://oxcluster/usm-json
    </Proxy>
    </IfModule>

  3. #3
    Join Date
    May 2010
    Posts
    21

    Default solved

    I solved the problem inserting the public IP address of the ox server in /opt/open-xchange/etc/groupware/noipcheck.cnf

  4. #4
    Join Date
    Feb 2007
    Location
    Dortmund, Germany
    Posts
    168

    Default

    A more secure way is to let the EAS/USM synchronization use localhost, if this is not a distributed system. See here. You can remove the public IP address then from noipcheck.cnf
    Markus Wagner
    Open-Xchange Quality Assurance

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •