Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2012
    Posts
    3

    Unhappy ReWrite Rule greift nicht? You need to enable...

    Moinsen,

    ich bin am

    ich versuche seit knapp 4 Tagen OX auf einen VServer mit Ubuntu 10.4.4 zu installieren mit Plesk.
    Ich pack das nicht...

    Ich bekomme jedes mal "You need to enable JavaScript to access the Open-Xchange Server."

    Console meldet "check is not defined"

    Habe aus den index.html, ox.html und noch einer html datei die verknüpfungen händisch angepasst
    und komme bis zur Anmeldung, aber mit einer 404 Fehler meldung von der concat_init.jsz das der weitere Dateien nicht finden kann.

    Die Verknüpfungen haben alle noch einen solchen Ordner in der URL z.B. "v=NRlwMaR/themes/login/default.css"

    in der vhost.conf die ich durch die installation eingebunden habe ist ja eine ReWriteRule eingetragen die anscheinend nicht greift.
    Der Redirect auf den /ox6/ Ordner greift aber. Danach die Location´s weis ich nicht wie ich die überpürfen könnte.

    Selbst wenn ich die beiden Zeilen

    RewriteEngine On
    RewriteRule v=\w+/(.+) $1 [L]

    noch in eine .htaccess Datei packe greift das einfach nicht.

    Habe noch ein paar Testinstallation auf vmware´s ausprobiert und da klappt das Problemlos
    Aber da ist natürlich kein Plesk installiert :/

    Ich bedanke mich für jede Hilfe!
    Last edited by coax; 04-10-2012 at 02:38 PM.

  2. #2
    Join Date
    Apr 2012
    Posts
    3

    Default

    Gelöst

    durch die Uni Hamburg bin auf eine Info gestoßen die ich nicht wusste

    Ich habe in der config datei für den vhost die Location angepasst
    Die Anpassung darf man nur im Directory machen.


  3. #3
    Join Date
    Apr 2012
    Posts
    1

    Default Open-Xchange 6 on a Ubuntu 10.04 LTS/Plesk 10.4.4 vserver

    Quote Originally Posted by coax View Post
    Gelöst

    durch die Uni Hamburg bin auf eine Info gestoßen die ich nicht wusste

    Ich habe in der config datei für den vhost die Location angepasst
    Die Anpassung darf man nur im Directory machen.

    Hallo coax,

    könntest Du Deine Lösung etwas genauer vorstellen? Ich habe ein ähnliches System und scheitere daran, eine vhost.conf für meine Domain so zu erstellen und anzupassen, dass ich mich in die GUI von Open-Xchange einloggen kann.

    Entweder wird die Seite meinedomain.de/ox6 nicht gefunden oder der berüchtigte Satz "You need to enable JavaScript to access the Open-Xchange Server" erscheint.

    Mein System:
    V-Server bei Strato mit Ubuntu 10.04 LTS
    Plesk 10.4.4
    1 Domain (ich nenne sie mal meinedomain.de)
    OpenXchange 6 Community Edition,

    Da in einem mit Plesk administrierten System die Default Website Settings in /etc/apache2/sites-available/default anscheinend keine Rolle spielen, funktioniert die Anleitung auf http://oxpedia.org/wiki/index.php?ti...r_Ubuntu_10.04 nicht.

    Um die Konfigurationseinstellungen samt Redirect für meine Domain anzuwenden, müssen sie bei Plesk in eine vhost.conf geschrieben und im Verzeichnis /var/www/vhosts/meinedomain.de/conf abgelegt werden.

    Das habe ich probiert, habe Plesk "gezwungen", die Settings mit dem Befehl /usr/local/psa/admin/bin/httpdmng --reconfigure-all einzulesen, aber das Ergebnis ist wie oben beschrieben.

    Wie muss die vhost.conf aussehen?

    Bin für jeden Hinweis dankbar.

    Alf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •