Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    May 2012
    Posts
    6

    Default open-xchange-meta-cpanel.noarch dependency problems

    Hi,

    I'm running in to dependency problems when I'm trying to install the package open-xchange-meta-cpanel .

    Any ideas ?

    Kernel: 2.6.18-028stab091.2 #1 SMP Fri Jun 3 00:02:40 MSD 2011 x86_64 x86_64 x86_64 GNU/Linux

    CentOS release 5.8 (Final)

    Excerpt of yum output:

    --> Running transaction check
    ---> Package open-xchange-meta-cpanel.noarch 0:6.20.4.0-1_1.1 set to be updated
    --> Processing Dependency: open-xchange-online-help-ja-jp for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-admin-plugin-reseller-soap for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-zh-cn for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-nl-nl for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-zh-tw for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-sk-sk for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-lv-lv for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-pl-pl for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-zh-tw for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-online-help-nl-nl for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-it-it for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-online-help-pl-pl for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-spamhandler-spamassassin for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-cs-cz for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-group-managerequest for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-online-help-es-es for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-es-es for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-online-help-zh-tw for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-lv-lv for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-it-it for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-online-help-it-it for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-es-es for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-nl-nl for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-ja-jp for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-authentication-imap for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-pl-pl for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-sk-sk for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-ja-jp for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-hu-hu for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-gui-lang-cs-cz for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-zh-cn for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-lang-hu-hu for package: open-xchange-meta-cpanel
    --> Processing Dependency: open-xchange-online-help-zh-cn for package: open-xchange-meta-cpanel
    --> Running transaction check
    ---> Package open-xchange-admin-plugin-reseller-soap.noarch 0:6.20.4.0-1_1.9 set to be updated
    --> Processing Dependency: open-xchange-admin-plugin-reseller for package: open-xchange-admin-plugin-reseller-soap
    --> Processing Dependency: open-xchange-admin-soap for package: open-xchange-admin-plugin-reseller-soap
    ---> Package open-xchange-authentication-imap.noarch 0:6.20.4.0-1_1.4 set to be updated
    ---> Package open-xchange-group-managerequest.noarch 0:6.20.4.0-1_1.4 set to be updated
    ---> Package open-xchange-gui-lang-cs-cz.noarch 0:6.20.4.0-1_1.1 set to be updated
    --> Processing Dependency: open-xchange-lang for package: open-xchange-gui-lang-cs-cz
    ---> Package open-xchange-gui-lang-es-es.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-hu-hu.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-it-it.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-ja-jp.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-lv-lv.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-nl-nl.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-pl-pl.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-sk-sk.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-zh-cn.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-gui-lang-zh-tw.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-cs-cz.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-es-es.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-hu-hu.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-it-it.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-ja-jp.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-lv-lv.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-nl-nl.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-pl-pl.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-sk-sk.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-zh-cn.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-lang-zh-tw.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-es-es.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-it-it.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-ja-jp.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-nl-nl.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-pl-pl.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-zh-cn.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-online-help-zh-tw.noarch 0:6.20.4.0-1_1.1 set to be updated
    ---> Package open-xchange-spamhandler-spamassassin.noarch 0:6.20.4.0-1_1.4 set to be updated
    --> Running transaction check
    ---> Package open-xchange-admin-plugin-reseller.noarch 0:6.20.4.0-1_1.9 set to be updated
    --> Processing Dependency: open-xchange-admin-plugin-autocontextid >= 6.20.0.0 for package: open-xchange-admin-plugin-reseller
    --> Processing Dependency: open-xchange-admin-plugin-autocontextid-client >= 6.20.0.0 for package: open-xchange-admin-plugin-reseller
    ---> Package open-xchange-admin-soap.noarch 0:6.20.4.0-1_1.9 set to be updated
    --> Processing Dependency: open-xchange-axis2 >= 6.20.4.0 for package: open-xchange-admin-soap
    ---> Package open-xchange-lang.noarch 0:6.20.4.0-1_1.1 set to be updated
    --> Running transaction check
    ---> Package open-xchange-admin-plugin-autocontextid.noarch 0:6.20.4.0-1_1.9 set to be updated
    ---> Package open-xchange-admin-plugin-autocontextid-client.noarch 0:6.20.4.0-1_1.9 set to be updated
    ---> Package open-xchange-axis2.noarch 0:6.20.4.0-1_1.4 set to be updated
    --> Processing Conflict: open-xchange-spamhandler-default conflicts open-xchange-spamhandler-spamassassin
    --> Processing Conflict: open-xchange-authentication-imap conflicts open-xchange-authentication-database
    --> Processing Conflict: open-xchange-spamhandler-spamassassin conflicts open-xchange-spamhandler-default
    --> Finished Dependency Resolution
    open-xchange-spamhandler-spamassassin-6.20.4.0-1_1.4.noarch from ox has depsolving problems
    --> open-xchange-spamhandler-spamassassin conflicts with open-xchange-spamhandler-default
    open-xchange-spamhandler-default-6.20.4.0-1_1.4.noarch from installed has depsolving problems
    --> open-xchange-spamhandler-default conflicts with open-xchange-spamhandler-spamassassin
    open-xchange-authentication-imap-6.20.4.0-1_1.4.noarch from ox has depsolving problems
    --> open-xchange-authentication-imap conflicts with open-xchange-authentication-database
    Error: open-xchange-spamhandler-spamassassin conflicts with open-xchange-spamhandler-default
    Error: open-xchange-authentication-imap conflicts with open-xchange-authentication-database
    Error: open-xchange-spamhandler-default conflicts with open-xchange-spamhandler-spamassassin
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest


    Thanks.

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    This is the cause:

    Code:
    --> Processing Conflict: open-xchange-spamhandler-default conflicts open-xchange-spamhandler-spamassassin
    --> Processing Conflict: open-xchange-authentication-imap conflicts open-xchange-authentication-database
    --> Processing Conflict: open-xchange-spamhandler-spamassassin conflicts open-xchange-spamhandler-default
    --> Finished Dependency Resolution
    open-xchange-spamhandler-spamassassin-6.20.4.0-1_1.4.noarch from ox has depsolving problems
    --> open-xchange-spamhandler-spamassassin conflicts with open-xchange-spamhandler-default
    open-xchange-spamhandler-default-6.20.4.0-1_1.4.noarch from installed has depsolving problems
    --> open-xchange-spamhandler-default conflicts with open-xchange-spamhandler-spamassassin
    open-xchange-authentication-imap-6.20.4.0-1_1.4.noarch from ox has depsolving problems
    --> open-xchange-authentication-imap conflicts with open-xchange-authentication-database
    Error: open-xchange-spamhandler-spamassassin conflicts with open-xchange-spamhandler-default
    Error: open-xchange-authentication-imap conflicts with open-xchange-authentication-database
    Error: open-xchange-spamhandler-default conflicts with open-xchange-spamhandler-spamassassin
    The meta package is designed to use open-xchange-spamhandler-spamassassin and open-xchange-authentication-imap instead of what you have installed already.
    OXpedia.org - the answer to almost all questions.

  3. #3
    Join Date
    May 2012
    Posts
    6

    Default

    Hi,
    Quote Originally Posted by Carsten Hoeger View Post
    This is the cause:

    The meta package is designed to use open-xchange-spamhandler-spamassassin and open-xchange-authentication-imap instead of what you have installed already.
    Thanks for your reply.

    So there is a conflict on the packages of OX repository?
    Last edited by bolek; 05-21-2012 at 01:07 PM. Reason: grammar

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by bolek View Post
    Hi,
    Thanks for your reply.

    So there is a conflict on the packages of OX repository?
    The cpanel meta package has a requirement to open-xchange-spamhandler-spamassassin and open-xchange-authentication-imap, but you installed open-xchange-authentication-database and open-xchange-spamhandler-default.
    OXpedia.org - the answer to almost all questions.

  5. #5
    Join Date
    May 2012
    Posts
    6

    Default

    Quote Originally Posted by Carsten Hoeger View Post
    The cpanel meta package has a requirement to open-xchange-spamhandler-spamassassin and open-xchange-authentication-imap, but you installed open-xchange-authentication-database and open-xchange-spamhandler-default.
    I have followed the installation procedure from here.

    Do you know how can I solve this?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •