Hi.

I have been trying to install open-xchange community version on my vps running CentOS 6.2. I have found a thread detailing the installation on centos 5 and followed those instructions. However, I still cannot seem to complete the installation of open-xchange. My linux (and more so, centos) knowledge is limited. Perhaps I am missing something quite evident and obvious. If i install the complete server (as one stand-alone server) by either running the command:
Code:
$ yum install mysql-server open-xchange-meta-centos open-xchange-meta-singleserver \
   open-xchange-authentication-database open-xchange-spamhandler-default
or by using the "install a rpm" feature in CPanel WHM, I get the following output (for both cases):

Code:
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ufs.ac.za
 * extras: mirror.ufs.ac.za
 * updates: mirror.ufs.ac.za
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package open-xchange.noarch 0:6.20.4.0-1_4.1 will be installed
--> Processing Dependency: open-xchange-tx >= 6.20.4.0 for package: open-xchange-6.20.4.0-1_4.1.noarch
--> Processing Dependency: open-xchange-i18n >= 6.20.4.0 for package: open-xchange-6.20.4.0-1_4.1.noarch
.
.
.
.
.
---> Package redhat-lsb.x86_64 0:4.0-3.el6.centos will be installed
--> Processing Dependency: perl-CGI for package: redhat-lsb-4.0-3.el6.centos.x86_64
---> Package xml-common.noarch 0:0.6.3-32.el6 will be installed
--> Finished Dependency Resolution
Error: Package: open-xchange-server-6.20.4.0-1_4.1.noarch (ox)
           Requires: java-sun
Error: Package: redhat-lsb-4.0-3.el6.centos.x86_64 (base)
           Requires: perl-CGI
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
bandmin-1.6.1-5.noarch has missing requires of perl(bandmin.conf)
bandmin-1.6.1-5.noarch has missing requires of perl(bmversion.pl)
bandmin-1.6.1-5.noarch has missing requires of perl(services.conf)
exim-4.77-1.x86_64 has missing requires of perl(SafeFile)
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0

Install complete.
To my knowledge perl:cgi is installed. when I try to install perl:java (via cpanel perl package install) I recieve the following errors:

Code:
Checking C compiler....C compiler (/usr/bin/cc) OK
Tuned C compiler (/usr/bin/cc -march=native) OK....Done
CPAN fallback is disabled since /var/cpanel/conserve_memory exists, and cpanm is available.
Method: Using Perl Expect, Installer: cpanm
You have make /usr/bin/make
Falling back to HTTP::Tiny 0.009
You have /bin/tar: tar (GNU tar) 1.23
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later .
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by John Gilmore and Jay Fenlason.
You have /usr/bin/unzip
You have Cpanel::HttpRequest 2.1
Testing connection speed...(using fast method).....Done
.
.
.
.
....mirror search failed......(request attempt 4/12)...Resolving search.cpan.org...(resolve attempt 1/65)...search.cpan.org did not have any working mirrors.  Please check your internet connection or dns server. at /usr/local/cpanel/Cpanel/HttpRequest.pm line 596.
Perl Expect failed with non-zero exit status: 65280

All available perl module install methods have failed
Could you please guide me on how I could possibly resolve this problem and have a working version of open-xchange on my vps.

Much apprecaited.

Thanks.