Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 1 of 1
  1. #1
    Join Date
    Jun 2012
    Posts
    1

    Default Server Memory Allocation

    Hello everyone.

    So i am installing Open Xchange right now, things are going pretty well.


    Okay, so the first problem I was having was I couldnt add servername while adding master-pass, and configdb-pass, etc.
    But I fixed that. So nevermind that. I appologize for posting that, cuz I fixed it minutes after.

    For reference for others.
    The missing Parameters that showed in the output, all I did was
    /opt/open-xchange/sbin/oxinstaller --configdb-pass=db_password --master-pass=admin_master_password
    when I typed that, it said missing required option servername. So I did the same thing
    /opt/open-xchange/sbin/oxinstaller --configdb-pass=db_password --master-pass=admin_master_password --servername=localhost

    that made all the parameters fine. its working fine now, so forget this part, and go to the bottom and see the question about servermemory please.



    FORGET THIS PART:
    So i ran the
    Code:
    $ /opt/open-xchange/sbin/oxinstaller --add-license=YOUR-OX-LICENSE-CODE \
    --servername=oxserver --configdb-pass=db_password \
    --master-pass=admin_master_password --ajp-bind-port=localhost --servermemory 512
    command from the Knowledgebase, and I configured everything right so far, but I keep getting this output:
    Code:
    missing required option --configdb-pass
    For some reason I keep getting that, I am not sure why though?
    Because I am entering the configdb password I set the step before.

    Also in the parameters that it shows after you enter that, it also shows that the Master Pass is missing as well.
    Not sure why, because I am entering both..


    Any thoughts as to why this is happening?



    Another thing I should mention is, I had to also enter "--servername=localhost" which wasn't in the knowledgebase, but after I got the error I entered it and it did work, as it shows in the parameters.

    :FORGET ALL THIS PART UP TO HERE



    This is the real issue now:

    for further information, I am running on CentOS 5.7 right now.



    And I also wanted to ask another slight off topic question, in regards to the --servermemory. I read the whitepaper in regards to sizing, but it still doesn't really apply to my situation.
    I'm really looking to run a VERY small instance of OX. Literally I mean small.
    Its only going to be used for a couple people on my Design/Development team. And I'm talking like 5-6 people.
    So what should I set the server memory to for this small of a team?
    I mean I have a VPS, so I am quite limited on my memory allocation..
    And I know that OX is more aimed at Enterprise sized, but I really don't see why I couldn't scale it down to my size.
    Whats your thoughts on servermemory for my situation?


    Hope someone can help.

    Thanks for your time folks.
    Last edited by CDesign; 06-24-2012 at 05:37 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •