Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2013
    Posts
    4

    Angry Open-Xchange AppSuite Installation failed

    Hey guys from the open xchange community,

    yesterday I tried to install the ox app suite for the first time. During the intallation I had different errors like this:

    Code:
    $ /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 \
    -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext \
    -e oxadmin@example.com -q 1024 --access-combination-name=groupware_standard
    Code:
    Error: Option(s) "contextid" missing
    Usage: createcontext
     -h,--help                                         Prints a help text
        --environment                                  Show info about commandline environment
        --nonl                                         Remove all newlines (\n) from output
        --csv-import <CSV file>                        Full path to CSV file with user data to import. This option makes
                                                       mandatory command line options obsolete, except credential options (if
                                                       needed). But they have to be set in the CSV file.
     -c,--contextid <contextid>                      * The id of the context
     -A,--adminuser <adminuser>                      ? master Admin user name
     -P,--adminpass <adminpass>                      ? master Admin password
     -N,--contextname <contextname>                    context name
     -u,--username <username>                        * Username of the user
     -d,--displayname <displayname>                  * Display name of the user
     -g,--givenname <givenname>                      * Given name for the user
     -s,--surname <surname>                          * Sur name for the user
     -p,--password <password>                        * Password for the user
     -e,--email <email>                              * Primary mail address
     -l,--language <language>                          Language for the user (de_DE,en_US)
     -t,--timezone <timezone>                          Timezone of the user (Europe/Berlin)
     -q,--quota <quota>                              * Context wide filestore quota in MB.
        --extendedoptions                              Set this if you want to see all options, use this instead of help option
     -L,--addmapping <addmapping>                      Add login mappings.Seperated by ","
     -F,--destination-store-id <destination-store-id>  Create context in the given filestore
     -D,--destination-database-id <destination-database-id>  Create context in the given database
        --access-combination-name <access-combination-name>  Access combination name
    
    Entries marked with an asterisk (*) are mandatory.
    Entries marked with an question mark (?) are mandatory depending on your
    configuration.
    Entries marked with a pipe (|) are mandatory for one another which means that
    at least one of them must be set.
    It didn't work so I skipped it at first.

    But now it looks like this, when I open the link to the appsuite folder: http://5.231.7.144/appsuite

    Please help me to fix this problem.

    I made now up to 8 reinstallations on fully new installed machines on my server. I'm really desperate!!!

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, you should be able to create contexts of course. Please check if the copy&pasted command is correctly formatted at your shell. You may need to re-format it at a text editor. Besides that, if /appsuite does not exist, the UI does not seem to be installed and/or Apache seems to be misconfigured.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •