Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1

    Default file build-project.xml missing in documentconverter api sources

    Hi,

    I took a look at the documentconverter api sources on the weekend. I am not very versatile when java is involved, but it seems that the file com.openxchange.documentconverter.uno/build-project.xml is missing in the documentconverter-api git repository. This file is required to build the sources with ant.

    I would appreciate it very much, if you could look into that.

    Greetings.

  2. #2
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    49

    Default

    Hi,

    that file is not missing. We use a generalized build system and the local build.xml just overwrites some targets of the generalized build-project.xml. During the build process the build-project.xml file is copied to the local projects.

    Regards.

  3. #3
    Join Date
    Oct 2014
    Location
    Bergen, Norway
    Posts
    10

    Default

    Sorry to awaken this thread from the dead, but I'm interested in doing some backend developement for OX, namely a SMS integration for Twilio, similar to the open-xchange-sms-sipgate package, and ran into the same wall regarding e.g. build-project.xml.

    Does there exist some documentation on the aforementioned build system that you're using, and on how one can perform such builds?

    EDIT: Okay, I've played around with the build repo some, which has gotten me somewhere along the way.

    [root@localhost build]# ant -f buildAll.xml -DprojectSets=backend-packages -DdestDir=/dest buildLocally
    [...]
    BUILD FAILED
    /home/ox/ox-backend/build/buildAll.xml:123: The following error occurred while executing this line:
    /home/ox/ox-backend/build/build.xml:157: The following error occurred while executing this line:
    /home/ox/ox-backend/build/tools.xml:172: /home/ox/ox-backend/build/tools.xml:202: The following error occurred while executing this line:
    /home/ox/ox-backend/com.openexchange.bundles/build-project.xml:281: The following error occurred while executing this line:
    /home/ox/ox-backend/com.openexchange.bundles/build.xml:14: The following error occurred while executing this line:
    /home/ox/ox-backend/com.openexchange.bundles/java-commons.xml:11: The following error occurred while executing this line:
    /home/ox/ox-backend/com.openexchange.bundles/java-commons.xml:19: The following error occurred while executing this line:
    /home/ox/ox-backend/com.openexchange.bundles/java-commons.xml:43: get doesn't support the nested "url" element.
    Are there any specific versions of ant I need to use? I'm currently on 1.7.1.

    On some other tasks I've attempted to run, it fails while trying to download shared libraries from http://artifactory.open-xchange.com , giving me errors such as:
    [get] Error opening connection java.io.FileNotFoundException: https://artifactory.open-xchange.com...ions-1.3.3.jar
    Are these resources not available to the public? Or am I doing something wrong?
    Last edited by hognevevle; 12-01-2016 at 11:35 PM.

  4. #4
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    49

    Default

    Hi Hogne,

    you did an unbelievable good job! We did not document yet the build system, because even the local build becomes really complex if you want to build more than only the backend component and it does not really work good. The build system is tailored to the complete build infrastructure including the package build using OpenSUSE buildservice.

    Your failing download is one of these problems. This would require to make our artifactory publicly available with read permission. This means to maintain another system and to protect it from being attacked.

    To solve your issue, extract the JAR from the failing download from the open-xchange-core package and place it into the com.openexchange.bundles/jars directory. Try to build then again locally.

    Kind regards

  5. #5
    Join Date
    Oct 2014
    Location
    Bergen, Norway
    Posts
    10

    Default

    In case anyone else is reading this, the logback-extensions-1.3.3.jar that I needed was found in the open-xchange-osgi package.

    Extracted the .rpm using:
    rpm2cpio open-xchange-osgi-7.8.3-5_7.1.noarch.rpm | cpio -idmv
    (I'm using CentOS)

    I then copied that file (opt/open-xchange/bundles/logback-extensions-1.3.3.jar) into com.openexchange.bundles/jars as suggested by Marcus. This relieved the build tasks from having to connect to the OX artifactory, allowing the build to continue.

    Regarding the other error:
    [...]/com.openexchange.bundles/java-commons.xml:43: get doesn't support the nested "url" element.
    .. the solution for me was to install a newer version of ant. CentOS 6 currently provides only version 1.7.1 through the official repos. After compiling and installing the newest version from source (currently 1.9.7), this error disappeared as well.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •