Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    sulung Guest

    Default Problem while communicating with external authorization while access Config-Extra

    Hi, me again

    I install OX Hyperion on:
    - Debian 3.1 Sarge x86_64 (AMD Opteron)
    - SMTP: netqmail-1.0.5
    - POP: Vpopmail-5.4.25 uses MySQL Auth as auth backend
    - IMAP/IMAPS: Dovecot-1.0rc4

    I install Courier-IMAP (v0.58) using Debian package as its referenced by OX beside Cyrus IMAP. It runs on port 1143 (my custom IMAP) and port 9993 (my custom IMAPS). My Courier uses authvchkpw as its auth backend.

    I modify some lines in /opt/open-xchange/etc/groupware/imap.properties:
    imaps=true
    imapsPort=9993
    imapServer=127.0.0.1:1143

    then restart Open-Xchange.

    Normal access to web mail OK. But I get this error while click Configuration-Extras menu:
    "11-03-2007 11:57 AM-->Error code: Problem while communicating with external authorization. (LGI-0003,-1036753854-31)"

    Likewise while I login to admin panel (http://server/ox6/admin).
    While click a user name in Administration-Management-User setup it displays error message: "11-03-2007 05:18 AM-->Error code: Error occured in: com.openexchange.admin.rmi.extensions.OXUserMailfi lterExtension! Errortext: java.net.ConnectException: Connection refused (SVL-0001,-1036753854-41)"

    Any idea?

    Regards,
    Sulung

  2. #2
    sulung Guest

    Default

    I check my log file:
    ....
    Nov 5, 2007 3:23:00 PM com.openexchange.mail.watcher.MailConnectionWatche r init
    INFO: Mail connection watcher successfully established and ready for tracing
    Nov 5, 2007 3:23:01 PM com.openexchange.imap.user2acl.User2ACL init
    INFO: Auto-Detection for IMAP server implementation
    Nov 5, 2007 3:23:01 PM com.openexchange.imap.user2acl.User2ACLAutoDetecto r mapInfo2IMAPServer
    WARNING: No IMAP server found that corresponds to greeting:^M
    "* OK Dovecot ready."^M
    Since ACLs are disabled (through IMAP configuration) or not supported by IMAP server, "Cyrus" is used as fallback.
    Nov 5, 2007 3:23:01 PM com.openexchange.imap.user2acl.User2ACLAutoDetecto r loadUser2ACLImpl
    INFO:
    IMAP server [localhost/127.0.0.1] greeting successfully mapped to: Cyrus
    Nov 5, 2007 3:23:01 PM com.openexchange.imap.IMAPLogicTools logUnsupportedQuotaResources
    WARNING: Unsupported QUOTA resource(s) [<name> (<usage>/<limit>]:
    MESSAGE (0/10000)
    Nov 5, 2007 3:23:11 PM org.apache.jcs.engine.memory.shrinking.ShrinkerThr ead checkForRemoval
    INFO: Exceeded maxIdleTime CacheKey context=1 | key=11
    Nov 5, 2007 3:23:14 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 3:23:14 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 3:23:14 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 3:23:14 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 3:23:14 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 3:23:14 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 3:23:14 PM com.openexchange.ajax.ConfigJump doGet
    SEVERE: LGI-0003 Category=5 Message=Problem while communicating with external authorization. exceptionID=1752826556-7
    LGI-0003 Category=5 Message=Problem while communicating with external authorization. exceptionID=1752826556-7
    at com.openexchange.groupware.integration.ExpressImpl .getLink(ExpressImpl.java:141)
    at com.openexchange.ajax.ConfigJump.doGet(ConfigJump. java:108)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:399)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:138)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
    at com.openexchange.tools.ajp13.AJPv13Request.respons e(AJPv13Request.java:92)
    at com.openexchange.tools.ajp13.AJPv13RequestHandler. createResponse(AJPv13RequestHandler.java:357)
    at com.openexchange.tools.ajp13.AJPv13Connection.crea teResponse(AJPv13Connection.java:168)
    at com.openexchange.tools.ajp13.AJPv13Listener.run(AJ Pv13Listener.java:246)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl .java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSoc ketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:366)
    at java.net.Socket.connect(Socket.java:520)
    at java.net.Socket.connect(Socket.java:470)
    at java.net.Socket.<init>(Socket.java:367)
    at java.net.Socket.<init>(Socket.java:240)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock etFactory.java:80)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock etFactory.java:122)
    at org.apache.commons.httpclient.HttpConnection.open( HttpConnection.java:707)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteWithRetry(HttpMethodDirector.java:387)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteMethod(HttpMethodDirector.java:171)
    at org.apache.commons.httpclient.HttpClient.executeMe thod(HttpClient.java:397)
    at com.openexchange.groupware.integration.ExpressImpl .getLink(ExpressImpl.java:136)
    ... 10 more

    If I am not wrong, OX still detects Dovecot as my IMAP server and can not recognize my new Courier IMAP running in port 1143 and 9993 (?)
    Whereas, I am 100% sure that web mail in OX already use port 9993 as its IMAPS port.

    Any Help Is Appreciated.

    Regards,
    Sulung

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    one possibility to solve this is to configure the imapServer per user (check the "user" table at open-xchange-db). Configuring via imap.properties is very inflexible and should only be done for testing purposes.

    Greetings.

  4. #4
    sulung Guest

    Default

    Thanks for reply.
    I update "user" table:
    mysql > use open-xchange-db;
    mysql > UPDATE user SET imapServer='localhost:1143' WHERE cid=1 AND id=13;

    I restart Openexchange.
    Problem still happen, nevertheless now my OX can recognize Courier IMAP on port 1143:
    ...
    INFO:
    IMAP server [localhost/127.0.0.1] greeting successfully mapped to: Courier
    Nov 5, 2007 4:22:04 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 4:22:04 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 4:22:04 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 4:22:04 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 4:22:04 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 4:22:04 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 4:22:04 PM com.openexchange.ajax.ConfigJump doGet
    SEVERE: LGI-0003 Category=5 Message=Problem while communicating with external authorization. exceptionID=-49793327-5
    LGI-0003 Category=5 Message=Problem while communicating with external authorization. exceptionID=-49793327-5
    at com.openexchange.groupware.integration.ExpressImpl .getLink(ExpressImpl.java:141)
    at com.openexchange.ajax.ConfigJump.doGet(ConfigJump. java:108)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:399)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:138)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
    at com.openexchange.tools.ajp13.AJPv13Request.respons e(AJPv13Request.java:92)
    at com.openexchange.tools.ajp13.AJPv13RequestHandler. createResponse(AJPv13RequestHandler.java:357)
    at com.openexchange.tools.ajp13.AJPv13Connection.crea teResponse(AJPv13Connection.java:168)
    at com.openexchange.tools.ajp13.AJPv13Listener.run(AJ Pv13Listener.java:246)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl .java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSoc ketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:366)
    at java.net.Socket.connect(Socket.java:520)
    at java.net.Socket.connect(Socket.java:470)
    at java.net.Socket.<init>(Socket.java:367)
    at java.net.Socket.<init>(Socket.java:240)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock etFactory.java:80)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock etFactory.java:122)
    at org.apache.commons.httpclient.HttpConnection.open( HttpConnection.java:707)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteWithRetry(HttpMethodDirector.java:387)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteMethod(HttpMethodDirector.java:171)
    at org.apache.commons.httpclient.HttpClient.executeMe thod(HttpClient.java:397)
    at com.openexchange.groupware.integration.ExpressImpl .getLink(ExpressImpl.java:136)
    ... 10 more


    Likewise while I then update "imapLogin" in "user" table:
    mysql > UPDATE user SET imapLogin='someone' WHERE cid=1 AND id=13;

    then restart Openexchange, it still happen:
    ...
    INFO:
    IMAP server [localhost/127.0.0.1] greeting successfully mapped to: Courier
    Nov 5, 2007 4:32:03 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 4:32:03 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 4:32:03 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 4:32:03 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 4:32:03 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    Nov 5, 2007 4:32:03 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
    INFO: Retrying request
    Nov 5, 2007 4:32:03 PM com.openexchange.ajax.ConfigJump doGet
    SEVERE: LGI-0003 Category=5 Message=Problem while communicating with external authorization. exceptionID=-1265070294-5
    LGI-0003 Category=5 Message=Problem while communicating with external authorization. exceptionID=-1265070294-5
    at com.openexchange.groupware.integration.ExpressImpl .getLink(ExpressImpl.java:141)
    at com.openexchange.ajax.ConfigJump.doGet(ConfigJump. java:108)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:399)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:138)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
    at com.openexchange.tools.ajp13.AJPv13Request.respons e(AJPv13Request.java:92)
    at com.openexchange.tools.ajp13.AJPv13RequestHandler. createResponse(AJPv13RequestHandler.java:357)
    at com.openexchange.tools.ajp13.AJPv13Connection.crea teResponse(AJPv13Connection.java:168)
    at com.openexchange.tools.ajp13.AJPv13Listener.run(AJ Pv13Listener.java:246)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl .java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSoc ketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:366)
    at java.net.Socket.connect(Socket.java:520)
    at java.net.Socket.connect(Socket.java:470)
    at java.net.Socket.<init>(Socket.java:367)
    at java.net.Socket.<init>(Socket.java:240)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock etFactory.java:80)
    at org.apache.commons.httpclient.protocol.DefaultProt ocolSocketFactory.createSocket(DefaultProtocolSock etFactory.java:122)
    at org.apache.commons.httpclient.HttpConnection.open( HttpConnection.java:707)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteWithRetry(HttpMethodDirector.java:387)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteMethod(HttpMethodDirector.java:171)
    at org.apache.commons.httpclient.HttpClient.executeMe thod(HttpClient.java:397)
    at com.openexchange.groupware.integration.ExpressImpl .getLink(ExpressImpl.java:136)
    ... 10 more
    Nov 5, 2007 4:32:08 PM org.apache.jcs.engine.memory.shrinking.ShrinkerThr ead checkForRemoval
    INFO: Exceeded maxIdleTime CacheKey context=1 | key=13

    I've checked my Courier, and telnet to localhost:1143. No problem.

    Regards,
    Sulung

  5. #5
    sulung Guest

    Default

    I got it.
    My Apache run in secure mode (HTTPS/443). Port 80 (HTTP) is disabled.
    So I enable port 80, and I can access Extra link in menu Configuration now.

    But its weird, the new menu (Open-Xchange Server - Admin) pop up in text mode.
    I can input my password, but I can not click something (link or button) to save it.
    There is "Save", but its not a link or button, so doesn't work.

    BTW: Where is the setting to use HTTPS (443) instead HTTP (80)?

    Thanks.

    Regard

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    Quote Originally Posted by sulung View Post
    But its weird, the new menu (Open-Xchange Server - Admin) pop up in text mode.
    I can input my password, but I can not click something (link or button) to save it.
    There is "Save", but its not a link or button, so doesn't work.
    That's a known issue and is related to wrong placed css/js files:
    http://www.open-xchange.com/forum/sh...68&postcount=7

    Quote Originally Posted by sulung View Post
    BTW: Where is the setting to use HTTPS (443) instead HTTP (80)?
    At your webserver configuration.

    Greetings

  7. #7
    sulung Guest

    Default

    I'm sorry if it is a very basic question. I've read above issue.
    But I realy still confused.
    How can I fix the correct path?

    Should I make a link?
    I tried to make these symbolic link:
    # ln -s ox/admin/css /var/www/css
    # ln -s ox/admin/js /var/www/js
    then restart OX, but they don't work.

    Regards,
    Sulung

  8. #8
    sulung Guest

    Default

    Because no body help me :'( I try to fix this myself.
    I hope can be useful for idiots (like me ) that meets the same problem to fix the wrong on some path.
    I do these to fix above problem:

    ln -s /var/www/ox6/js /var/www/js
    ln -s /var/www/ox6/ox.css /var/www/ox.css
    ln -s /var/www/ox/admin/css/admin.css /var/www/ox6/css/admin.css
    ln -s /var/www/ox/admin/js/umin.js /var/www/ox6/js/umin.js

    Now extra link works perfectly.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •