Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    danisahne1 Guest

    Default Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127

    Hi,

    i just followed the wiki on how to get ox installed.
    i came til V.3. Open-Xchange Database

    here i get this output:

    server:/opt/open-xchange/sbin# /opt/open-xchange/sbin/oxinstaller -f --oxdb-pass=xxx --admin-pass=xxx --maildomain xxx.de
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    setting AUTO_TO_LOWERCASE_UID in /opt/open-xchange/etc/admindaemon/User.properties
    (Re)Starting Admin Daemon
    Server response:
    OXAdminCore
    admindaemon startup still in progress, waiting...
    admindaemon startup still in progress, waiting...
    admindaemon startup still in progress, waiting...
    admindaemon startup still in progress, waiting...
    admindaemon startup still in progress, waiting..

    And here is the logfile:

    server:/var/log/open-xchange# cat open-xchange-admin.log.0
    04.11.2007 17:31:49 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    04.11.2007 17:31:50 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:50 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
    SCHWERWIEGEND: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
    04.11.2007 17:31:50 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager <init>
    SCHWERWIEGEND: Failure, lateral instance will use zombie service
    java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPSender.init(LateralTCPSender.java:141)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPSender.<init>(LateralTCPSender.java:111)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService.<init>(LateralTCPService.java:72)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager.<init>(LateralTCPCacheManager.jav a:167)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager.getInstance(LateralTCPCacheManage r.java:108)
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheFactory.createCache(LateralTCPCacheFactor y.java:84)
    at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseAuxiliary(CompositeCacheConfigurator.j ava:554)
    at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseRegion(CompositeCacheConfigurator.java :346)
    at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseRegion(CompositeCacheConfigurator.java :267)
    at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseRegions(CompositeCacheConfigurator.jav a:244)
    at org.apache.jcs.engine.control.CompositeCacheConfig urator.doConfigure(CompositeCacheConfigurator.java :139)
    at org.apache.jcs.engine.control.CompositeCacheManage r.configure(CompositeCacheManager.java:314)
    at org.apache.jcs.engine.control.CompositeCacheManage r.configure(CompositeCacheManager.java:258)
    at com.openexchange.cache.Configuration.configure(Con figuration.java:125)
    at com.openexchange.cache.Configuration.load(Configur ation.java:100)
    at com.openexchange.admin.tools.OXRunner.init(OXRunne r.java:94)
    at com.openexchange.admin.tools.AdminCache.initOXProc cess(AdminCache.java:460)
    at com.openexchange.admin.tools.AdminCache.initCache( AdminCache.java:142)
    at com.openexchange.admin.daemons.AdminDaemon.initCac he(AdminDaemon.java:140)
    at com.openexchange.admin.daemons.Activator.start(Act ivator.java:89)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:991)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.start(AbstractBundle.java:256)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.st artBundles(EclipseStarter.java:1094)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.lo adBasicBundles(EclipseStarter.java:657)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.st artup(EclipseStarter.java:305)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:173)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ma in(EclipseStarter.java:150)
    04.11.2007 17:31:52 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:52 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:52 com.openexchange.admin.daemons.AdminDaemon initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:31:52 com.openexchange.admin.daemons.AdminDaemon$LocalSe rverFactory createServerSocket
    INFO: Admindaemon will listen on localhost!
    04.11.2007 17:31:52 com.openexchange.admin.rmi.impl.OXUser <init>
    INFO: Class loaded: com.openexchange.admin.rmi.impl.OXUser
    04.11.2007 17:31:54 com.openexchange.admin.rmi.impl.OXGroup <init>
    INFO: Class loaded: com.openexchange.admin.rmi.impl.OXGroup
    04.11.2007 17:31:54 com.openexchange.admin.rmi.impl.OXResource <init>
    INFO: Class loaded: com.openexchange.admin.rmi.impl.OXResource
    04.11.2007 17:31:54 com.openexchange.admin.rmi.impl.OXLogin <init>
    INFO: Class loaded: com.openexchange.admin.rmi.impl.OXLogin
    04.11.2007 17:31:54 com.openexchange.admin.daemons.Activator start
    INFO: Version: 6.5.0
    04.11.2007 17:31:54 com.openexchange.admin.daemons.Activator start
    INFO: Name: open-xchange-admin
    04.11.2007 17:31:54 com.openexchange.admin.daemons.Activator start
    INFO: Build: 0
    04.11.2007 17:31:54 com.openexchange.admin.daemons.Activator start
    INFO: Admindaemon successfully started.
    04.11.2007 17:31:54 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin changed to 2
    04.11.2007 17:31:54 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:54 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:54 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:54 com.openexchange.admin.PluginStarter initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:31:54 com.openexchange.admin.PluginStarter start
    INFO: Backup Plugin started!
    04.11.2007 17:31:54 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_backup changed to 2
    04.11.2007 17:31:54 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_ca_mgmt_simple changed to 2
    04.11.2007 17:31:54 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:54 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:54 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:54 com.openexchange.admin.PluginStarter initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:31:54 com.openexchange.admin.PluginStarter start
    INFO: Context-Light started!
    04.11.2007 17:31:54 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_context_light changed to 2
    04.11.2007 17:31:54 com.openexchange.admin.daemons.Activator$2 serviceChanged
    INFO: Service: open_xchange_admin_plugin_imap, 1

  2. #2
    danisahne1 Guest

    Default

    04.11.2007 17:31:54 com.openexchange.admin.daemons.Activator$2 serviceChanged
    INFO: open_xchange_admin_plugin_imap registered service
    04.11.2007 17:31:54 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_imap changed to 2
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:55 com.openexchange.admin.PluginStarter initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:31:55 com.openexchange.admin.daemons.Activator$2 serviceChanged
    INFO: Service: open_xchange_admin_plugin_mail, 1
    04.11.2007 17:31:55 com.openexchange.admin.daemons.Activator$2 serviceChanged
    INFO: open_xchange_admin_plugin_mail registered service
    04.11.2007 17:31:55 com.openexchange.admin.PluginStarter start
    INFO: OXMailServer RMI Plugin registered
    04.11.2007 17:31:55 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_mail changed to 2
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:55 com.openexchange.admin.rmi.PluginStarter initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:31:55 com.openexchange.admin.daemons.Activator$2 serviceChanged
    INFO: Service: open_xchange_admin_plugin_mailfilter, 1
    04.11.2007 17:31:55 com.openexchange.admin.daemons.Activator$2 serviceChanged
    INFO: open_xchange_admin_plugin_mailfilter registered service
    04.11.2007 17:31:55 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_mailfilter changed to 2
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:55 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:55 com.openexchange.admin.PluginStarter initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:31:55 com.openexchange.admin.PluginStarter start
    INFO: OS Config Plugin started!
    04.11.2007 17:31:55 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_osconfig changed to 2
    04.11.2007 17:31:55 com.openexchange.admin.PluginStarter start
    INFO: Service Plugin started!
    04.11.2007 17:31:55 com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
    INFO: open_xchange_admin_plugin_services changed to 2
    04.11.2007 17:31:56 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    04.11.2007 17:31:56 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: ...OX init done!
    04.11.2007 17:31:56 com.openexchange.admin.tools.AdminCache initCache
    INFO: Init Cache
    04.11.2007 17:31:56 com.openexchange.admin.PluginStarter initCache
    INFO: Cache and Pools initialized!
    04.11.2007 17:32:01 com.openexchange.admin.storage.sqlStorage.OXAdminP oolDBPool getREADConnectionForCONFIGDB
    SCHWERWIEGEND: Error pickup configdb database read connection from ox pool!
    DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-1617557442-1
    at com.openexchange.database.Database.get(Database.ja va:118)
    at com.openexchange.server.DBPool.pickup(DBPool.java: 67)
    at com.openexchange.admin.storage.sqlStorage.OXAdminP oolDBPool.getREADConnectionForCONFIGDB(OXAdminPool DBPool.java:75)
    at com.openexchange.admin.tools.AdminCache.getREADCon nectionForCONFIGDB(AdminCache.java:183)
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.list(OXContextMySQLStorage.java:47 5)
    at com.openexchange.admin.PluginStarter.initTimers(Pl uginStarter.java:162)
    at com.openexchange.admin.PluginStarter.start(PluginS tarter.java:152)
    at com.openexchange.admin.Activator.start(Activator.j ava:70)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:991)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
    at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1037)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)
    Caused by: com.openexchange.pooling.PoolingException: Cannot create pooled object.
    at com.openexchange.pooling.ReentrantLockPool.get(Ree ntrantLockPool.java:387)
    at com.openexchange.database.Database.get(Database.ja va:116)
    ... 20 more
    Caused by: java.sql.SQLException: Server connection failure during transaction. Due to underlying exception: 'java.net.SocketException: java.net.ConnectException: Connection refused'.

    ** BEGIN NESTED EXCEPTION **

    java.net.SocketException
    MESSAGE: java.net.ConnectException: Connection refused

    STACKTRACE:

    java.net.SocketException: java.net.ConnectException: Connection refused
    at com.mysql.jdbc.StandardSocketFactory.connect(Stand ardSocketFactory.java:156)
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:284)
    at com.mysql.jdbc.Connection.createNewIO(Connection.j ava:2706)
    at com.mysql.jdbc.Connection.<init>(Connection.java:1 485)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonReg isteringDriver.java:266)
    at java.sql.DriverManager.getConnection(DriverManager .java:525)
    at java.sql.DriverManager.getConnection(DriverManager .java:140)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:210)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:151)
    at com.openexchange.pooling.ReentrantLockPool.get(Ree ntrantLockPool.java:379)
    at com.openexchange.database.Database.get(Database.ja va:116)
    at com.openexchange.server.DBPool.pickup(DBPool.java: 67)
    at com.openexchange.admin.storage.sqlStorage.OXAdminP oolDBPool.getREADConnectionForCONFIGDB(OXAdminPool DBPool.java:75)
    at com.openexchange.admin.tools.AdminCache.getREADCon nectionForCONFIGDB(AdminCache.java:183)
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.list(OXContextMySQLStorage.java:47 5)
    at com.openexchange.admin.PluginStarter.initTimers(Pl uginStarter.java:162)
    at com.openexchange.admin.PluginStarter.start(PluginS tarter.java:152)
    at com.openexchange.admin.Activator.start(Activator.j ava:70)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:991)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
    at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1037)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)


    ** END NESTED EXCEPTION **


    Attempted reconnect 3 times. Giving up.
    at com.mysql.jdbc.Connection.createNewIO(Connection.j ava:2781)
    at com.mysql.jdbc.Connection.<init>(Connection.java:1 485)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonReg isteringDriver.java:266)
    at java.sql.DriverManager.getConnection(DriverManager .java:525)
    at java.sql.DriverManager.getConnection(DriverManager .java:140)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:210)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:151)
    at com.openexchange.pooling.ReentrantLockPool.get(Ree ntrantLockPool.java:379)
    ... 21 more

  3. #3
    danisahne1 Guest

    Default

    04.11.2007 17:32:01 com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage list
    SCHWERWIEGEND: Pool error
    com.openexchange.admin.rmi.exceptions.PoolExceptio n: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-1617557442-1
    at com.openexchange.admin.storage.sqlStorage.OXAdminP oolDBPool.getREADConnectionForCONFIGDB(OXAdminPool DBPool.java:80)
    at com.openexchange.admin.tools.AdminCache.getREADCon nectionForCONFIGDB(AdminCache.java:183)
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.list(OXContextMySQLStorage.java:47 5)
    at com.openexchange.admin.PluginStarter.initTimers(Pl uginStarter.java:162)
    at com.openexchange.admin.PluginStarter.start(PluginS tarter.java:152)
    at com.openexchange.admin.Activator.start(Activator.j ava:70)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:991)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
    at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1037)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)
    04.11.2007 17:32:10 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
    SCHWERWIEGEND: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
    04.11.2007 17:32:10 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager fixService
    SCHWERWIEGEND: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
    04.11.2007 17:32:10 org.apache.jcs.auxiliary.lateral.LateralCacheResto re canFix
    SCHWERWIEGEND: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462

    i was just searching on this forum and google for some hours and tried out much but
    i couldn't get rid of this problem

    someone has an idea?

    greets daniel

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    The Admindaemon is unable to get a connection to the database.

  5. #5
    danisahne1 Guest

    Default

    yes i know...
    but i don`t know why

    perhaps someone solved this problem already?

    just removed all files and tried with the installer
    ->the same

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, this can be caused by many problems, for example that no database has been created by the oxinstaller script due existing database credentials or a not started database service. Or just a problematic network configuration which does not allow to connect to "localhost" or something like that.

  7. #7
    danisahne1 Guest

    Default

    what is done in V.3. Open-Xchange Database ?

    what databases are created with what contents?

    i got configdb

    +------------------------+
    | Tables_in_configdb |
    +------------------------+
    | configdb_sequence |
    | context |
    | context_server2db_pool |
    | db_cluster |
    | db_pool |
    | filestore |
    | login2context |
    | reason_text |
    | server |
    +------------------------+
    9 rows in set (0.01 sec)

    mysql> select * from configdb_sequence;
    +----+
    | id |
    +----+
    | 1 |
    +----+
    1 row in set (0.02 sec)

    all others tables are empty.
    is this correct?

  8. #8
    danisahne1 Guest

    Default

    mysql -h localhost -u openexchange -p configdb

    works

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    configdb is being created by importing a mysql dump but no real database access. If there are no data at the whole configdb or if there is no "open-xchange-db" i guess something got wrong at the installation process - did you get a error message when executing the "oxinstaller" script which initializes all databases?

    //edit
    ah ok, i did not mention the output of oxinstaller you posted. It seems that some modules could not be loaded, would you please post the output of open-xchange-admin-console.log?

    btw. the evil looking error message
    SCHWERWIEGEND: Failure, lateral instance will use zombie service
    java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462
    just tells you that clustering is not possible because the file cache.ccf has not been configured correctly, but if you don't want to set up a ox cluster this has no relevance for you.

    Greetings
    Last edited by Martin Heiland; 11-05-2007 at 01:39 AM.

  10. #10
    mayank Guest

    Default

    yes
    i think Martin is right.
    it is possible that some modules might not have loaded .
    Also check your host file entries .

    Quote Originally Posted by Martin Braun View Post
    Hi,

    configdb is being created by importing a mysql dump but no real database access. If there are no data at the whole configdb or if there is no "open-xchange-db" i guess something got wrong at the installation process - did you get a error message when executing the "oxinstaller" script which initializes all databases?

    //edit
    ah ok, i did not mention the output of oxinstaller you posted. It seems that some modules could not be loaded, would you please post the output of open-xchange-admin-console.log?

    btw. the evil looking error message
    SCHWERWIEGEND: Failure, lateral instance will use zombie service
    java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462
    just tells you that clustering is not possible because the file cache.ccf has not been configured correctly, but if you don't want to set up a ox cluster this has no relevance for you.

    Greetings

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •