Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2013
    Posts
    4

    Question Hostname in OX Message-ID Header-Field

    Hi,

    i'm using Open-Xchange 6.22.3 in combination with iRedMail and fetchmail under Debian Squeeze. All basic funtions are working quite well.

    I use my ISP's SMTP-Server as relayhost, which is also working. Now I want to hide information about local hostnames in the mail headers. I managed to adjust the configuration files of postfix/amavis etc. but I don't know how to get rid of the following infomation in my outgoing mails:

    Code:
    Message-ID: <1234567890.1.1234567890.open-xchange@[local-hostname].[local-domainname].local>
    In which configuration do I have to change settings to change the line to

    Code:
    Message-ID: <1234567890.1.1234567890.open-xchange@[public-domainname].[tld]>

    Has anybody an idea how to manage this.

    Thanks a lot

    Gobi

  2. #2
    Join Date
    Aug 2013
    Posts
    4

    Default

    Hi,

    as I did not find the corresponding configuration file in open-xchange I solved my problem by using the header_checks-function in postfix.

    /etc/postfix/main.cf

    Code:
    header_checks = regexp:/etc/postfix/header_checks
    /etc/postfix/header_checks

    Code:
    /^Message-ID:.*[local-hostname].*/ IGNORE

    Gobi
    Last edited by Gobitodic; 08-23-2013 at 10:31 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •