Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    juliusspencer Guest

    Unhappy Can't build without build.xml

    Hi,

    I have followed the Installation instructions in the wiki but cannot build the cvs checked out project.

    Code:
    ant -Dlib.dir=/opt/open-xchange/lib install
    Buildfile: build.xml does not exist!
    Build failed
    Code:
    open-xchange]# find . -name build.xml
    ./global/build.xml
    ./charset/build.xml
    ./server/build.xml
    If I try to build on of these:
    Code:
    global]# ant -Dlib.dir=/opt/open-xchange/lib install
    Buildfile: build.xml
    
    prepare:
    
    compile:
        [javac] Compiling 10 source files to /tmp/open-xchange/global/build
        [javac] /tmp/open-xchange/global/src/com/openexchange/groupware/AbstractOXException.java:63: package org.apache.commons.logging does not exist

    Yet I have these:

    Code:
    activation.jar
    commons-cli-1.0.jar
    commons-codec-1.3.jar
    commons-fileupload.jar
    commons-io.jar
    commons-logging-1.1.jar
    commons-logging-adapters-1.1.jar
    commons-logging-api-1.1.jar
    commons-logging.jar
    commons-logging-1.1.jar
    concurrent.jar
    jakarta-slide-webdavlib-2.1.jar
    jcharset-1.3.jar
    jcs-1.2.7.9.2.jar
    jdom.jar
    json.jar
    junit-4.3.1.jar
    mail.jar
    mysql-connector-java-3.1.13-bin.jar
    org.eclipse.osgi_3.2.2.ox.jar
    saxon8.jar
    servlet-api-2.4.jar
    spring-beans.jar
    spring-core.jar
    tnef.jar
    Any ideas? Thanks.

  2. #2
    ole Guest

    Default

    Hi Julius,

    is that possible,that You use the HEAD-cvs?

    In the moment it is not possible (maybe only for developpers) to use this cvs-branch for building.
    One of the open-xchange developpers said this here in the forum.Because the sources are under heavely devellopping.Use the stable cvs-tree.I hope it helps.

  3. #3
    juliusspencer Guest

    Red face

    Hi,

    Thanks for the reply. I used:

    Code:
    cvs -d :pserver:anonymous@www.open-xchange.com:/cvsroot/ co open-xchange
    Can you tell me how to get the stable release?

    Thanks!

  4. #4
    ole Guest

    Default

    Hi Julius,

    this is a posting from Marcus (developper of open-xchange).
    He said the following:
    'Hi,

    if you check out the HEAD repository you'll find the build.xml at the server/ directory. Please note that there is no documentation how to build the HEAD right now, many changes are going on at the sourcecode and you should not rely on stability of the code.
    If you need to compile and run a stable version, please check out the "bf_6_4" code by adding "-r bf_6_4" to the cvs checkout command.

    For example:
    Code:

    cvs -dserver:anonymous@www.open-xchange.com:/cvsroot co -r bf_6_4 open-xchange

    You need to do this for all repositories except:
    json-jdk15
    open-xchange-admin-console-ee
    open-xchange-admin-gui-ee

    those three repositories need to be checked out with "-r HEAD" as there is no bugfix branch for these.'

    In the post,You will find the command to the STABLE-cvs.

    Or look in the thread: Problem with OXInstaller.
    There are some more details.

    Good luck :-)

  5. #5
    juliusspencer Guest

    Smile [SOLVED]

    Thanks ole, that was it. Now I'm having other trouble building. Will open another thread though.

  6. #6
    ole Guest

    Default

    Hi Julius,

    have a look in the community-installer script.There are some nice options to bulid hyperion with ant.Maybe with this script You have no errors.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •