Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2014
    Posts
    8

    Default 404 in OX Installation

    Hi,

    I am new to OX and have tried to install but get an error 404 if I try to login.

    Steps:

    I have installed OX based on packages of the repository on an Ubuntu system:

    Code:
    deb http://software.open-xchange.com/OX6/6.22/frontend/DebianSqueeze/ /
    deb http://software.open-xchange.com/OX6/6.22/backend/DebianSqueeze/ /
    deb http://software.open-xchange.com/OX6/6.22/usm/DebianSqueeze/ /
    Installed packages are:

    Code:
    open-xchange
    open-xchange-admin
    open-xchange-appsuite
    open-xchange-appsuite-backend
    open-xchange-appsuite-l10n-en-us
    open-xchange-appsuite-manifest
    open-xchange-authentication-database
    open-xchange-authorization-standard
    open-xchange-core
    open-xchange-grizzly
    open-xchange-gui
    open-xchange-gui-l10n
    open-xchange-gui-l10n-en-us
    open-xchange-gui-loading-theme-default
    open-xchange-gui-login-theme-default
    open-xchange-gui-themes-default
    open-xchange-halo
    open-xchange-imap
    open-xchange-l10n-en-us
    open-xchange-oauth
    open-xchange-osgi
    open-xchange-smtp
    open-xchange-xerces-sun
    The general document I followed was:

    http://http://oxpedia.org/wiki/index...pdate_packages

    Once I try to login to the webpage I get:

    Code:
    [01/Jun/2014:15:19:21 +0200] "POST /ajax/login?action=login&modules=true&client=com.openexchange.ox.gui.dhx
    19xtml&version=6.22.6%20Rev13&authId=5b6635ff-4c39-478d-b5c9-168e7fc4b45f HTTP/1.1" 404 501 "http://openx.av.loc/ox6/ox.html" "Mox1.
    5)xzilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0"
    The documentation says I would have to change some apache config.

    This also includes the statement:

    Code:
    <Location /webservices>
    This means to me based on my apache knowledge there should be a directory "webservices" under the apache document root - but there is none.

    I probably have missed to install a package or something else.

    Can someone please give me a hint!

    Regards
    Karl-Heinz

  2. #2
    Join Date
    Jun 2014
    Posts
    8

    Default

    anyone to give me a hint?
    Regards
    Karl-Heinz

  3. #3
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Hard to tell.
    1. the 404 looks strange. Seems that the api (/ajax) path is not configured or available.
    You should post your proxy_http.conf probably.

    Also /webservices is not a real path on your webserver. It's directly passed to the application server and handled from there.

  4. #4
    Join Date
    Jun 2014
    Posts
    8

    Default

    Hi Wolfgang,

    I have replied twice on your message but this seem to stuck in the approval queue of the admins.

    Meanwhile I have found out the root cause of all the trouble.

    But I need to tell a little bit more to show the way I had to go.

    Due to some other reason, I have setup a new ubuntu server. Clean installation. Just for testing.

    After that was done, I decided to install OX on this server to see if this will work.

    What shall I say: It worked.

    This gave me the impression, on my original server, there would be something configured totally wrong, although it worked for all components I had installed except OX.

    Now, I took a heavy decision: Drop the server and setup the server from skratch. To be honest, not such a big deal since it is no production environment and not so many components are installed.

    Result: Everything worked, except OX.

    And now I give to all of you the root cause I found out. Watch out!!!!!!!

    File permissions on "/etc/apache2/conf-available/proxy_http.conf" were wrong, but apache did not complain about. And therefore port 8009 was not active since the config was not loaded.

    Anyhow. It now works.
    Regards
    Karl-Heinz

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •