Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2013
    Location
    Stuttgart
    Posts
    10

    Default Open-xChange App Suite on Debian Plesk 12

    Dear all,

    I have a VPS hostet by Strato. I am sure that a struggle at a very easy position.

    I used the installation Guide "http://oxpedia.org/wiki/index.php?title=AppSuite:Open-Xchange_Installation_Guide_for_Debian_7.0" and have problems with the "/etc/apache2/conf.d/proxy_http.conf"
    because there is no folder called conf.d in apache2. So I found a folder called "/etc/apache2/plesk.conf.d" and stroed the file there.

    After this I changed the httpd.conf file in /var/www/vhosts/system/mail.domain.de/conf.

    PHP Code:
    #ATTENTION!
    #
    #DO NOT MODIFY THIS FILE BECAUSE IT WAS GENERATED AUTOMATICALLY,
    #SO ALL YOUR CHANGES WILL BE LOST THE NEXT TIME THE FILE IS GENERATED.
    #IF YOU REQUIRE TO APPLY CUSTOM MODIFICATIONS, PERFORM THEM IN THE FOLLOWING FILES:
    #/var/www/vhosts/system/mail.domain.de/conf/vhost.conf
    #/var/www/vhosts/system/mail.domain.de/conf/vhost_ssl.conf
    <IfModule mod_ssl.c>

            <
    VirtualHost 81.169.181.156:443 >
                    
    ServerName "mail.domain.de:443"
                    
    ServerAlias "www.mail.domain.de"
                    
    ServerAlias "ipv4.mail.domain.de"
                    
    ServerAdmin "mail@yves-bork.de"
                    
    UseCanonicalName Off

                    DocumentRoot 
    "/var/www"
                    
    CustomLog /var/www/vhosts/system/mail.domain.de/logs/access_ssl_log plesklog
                    ErrorLog 
    "/var/www/vhosts/system/mail.domain.de/logs/error_log"

                    
    <IfModule mod_suexec.c>
                            
    SuexecUserGroup "yvesbork" "psacln"
                    
    </IfModule>

                    <
    IfModule mod_userdir.c>
                            
    UserDir "/var/www/vhosts/domain.de/web_users"
                    
    </IfModule>

                    <
    IfModule mod_sysenv.c>
                            
    SetSysEnv PP_VHOST_ID "d4ecd1f7-3321-4620-a010-50267cdad856"
                    
    </IfModule>

                    
    ScriptAlias "/cgi-bin/" "/var/www/vhosts/domain.de/mail.domain.de/cgi-bin/"

                    
    Alias "/plesk-stat" "/var/www/vhosts/system/mail.domain.de/statistics"
                    
    <Location  /plesk-stat/>
                            
    Options +Indexes
                    
    </Location>
                    <
    Location  /plesk-stat/logs/>
                            Require 
    valid-user
                    
    </Location>
                    
    Alias /webstat /var/www/vhosts/system/mail.domain.de/statistics/webstat
                    Alias 
    /webstat-ssl /var/www/vhosts/system/mail.domain.de/statistics/webstat-ssl
                    Alias 
    /ftpstat /var/www/vhosts/system/mail.domain.de/statistics/ftpstat
                    Alias 
    /anon_ftpstat /var/www/vhosts/system/mail.domain.de/statistics/anon_ftpstat
                    Alias 
    /awstats-icon /usr/share/awstats/icon

                    SSLEngine on
                    SSLVerifyClient none
                    SSLCertificateFile 
    /opt/psa/var/certificates/certzeA471V

                    SetEnv PP_CUSTOM_PHP_INI 
    /var/www/vhosts/system/mail.domain.de/etc/php.ini
                    SetEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi

                    
    <IfModule mod_fcgid.c>
                            
    FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/system/mail.domain.de/etc/php.ini
                            FcgidInitialEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi
                            FcgidMaxRequestLen 134217728
                    
    </IfModule>

                    <
    Directory /var/www>

                            <
    IfModule mod_python.c>
                                    <
    Files ~ (\.py$)>
                                            
    SetHandler python-program
                                            PythonHandler mod_python
    .cgihandler
                                    
    </Files>
                            </
    IfModule>
                            <
    IfModule mod_fcgid.c>
                            
    FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/system/mail.domain.de/etc/php.ini
                            FcgidInitialEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi
                            FcgidMaxRequestLen 134217728
                    
    </IfModule>

                    <
    Directory /var/www>

                            <
    IfModule mod_python.c>
                                    <
    Files ~ (\.py$)>
                                            
    SetHandler python-program
                                            PythonHandler mod_python
    .cgihandler
                                    
    </Files>
                            </
    IfModule>
                            <
    IfModule mod_fcgid.c>
                                    <
    Files ~ (\.fcgi$)>
                                            
    SetHandler fcgid-script
                                            Options 
    +ExecCGI
                                    
    </Files>
                            </
    IfModule>
                            <
    IfModule mod_fcgid.c>
                                    <
    Files ~ (\.php$)>
                                            
    SetHandler fcgid-script
                                            FCGIWrapper 
    /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
                                            Options 
    +ExecCGI
                                    
    </Files>
                            </
    IfModule>
                           
    Options Indexes FollowSymLinks MultiViews
                           AllowOverride None
                           Order allow
    ,deny
                            allow from all
                            RedirectMatch 
    ^/$ /appsuite/

                            
    SSLRequireSSL

                            Options 
    -Includes +ExecCGI

                    
    </Directory>
                           <
    Directory /var/www/appsuite>
                   
    Options None +SymLinksIfOwnerMatch
                   AllowOverride Indexes FileInfo
           
    </Directory>

                    <
    Directory /var/www/vhosts/domain.de/web_users>

                            <
    IfModule mod_php4.c>
                                    
    php_admin_flag engine off
                            
    </IfModule>

                            <
    IfModule mod_php5.c>
                                    
    php_admin_flag engine off
                            
    </IfModule>

                    </
    Directory>

                    <
    Directory /var/www/vhosts/mail.domain.de>
                            
    Options +FollowSymLinks
                    
    </Directory>

                    <
    Directory "/var/www/vhosts/system/mail.domain.de/statistics">
                            
    AuthType Basic
                            AuthName 
    "Domainstatistiken"
                            
    AuthUserFile "/var/www/vhosts/system/mail.domain.de/pd/d..httpdocs@plesk-stat"
                            
    require valid-user
                    
    </Directory>
                    <
    IfModule mod_security2.c>
                    </
    IfModule>

            </
    VirtualHost>

    </
    IfModule>

    <
    VirtualHost 81.169.181.156:80 >
            
    ServerName "mail.domain.de:80"
            
    ServerAlias "www.mail.domain.de"
            
    ServerAlias "ipv4.mail.domain.de"
            
    ServerAdmin "mail@yves-bork.de"
            
    UseCanonicalName Off

            DocumentRoot 
    "/var/www/vhosts/domain.de/mail.domain.de"
            
    CustomLog /var/www/vhosts/system/mail.domain.de/logs/access_log plesklog
            ErrorLog 
    "/var/www/vhosts/system/mail.domain.de/logs/error_log"

            
    <IfModule mod_suexec.c>
                    
    SuexecUserGroup "yvesbork" "psacln"
            
    </IfModule>

            <
    IfModule mod_userdir.c>
                    
    UserDir "/var/www/vhosts/domain.de/web_users"
            
    </IfModule>

            <
    IfModule mod_sysenv.c>
                    
    SetSysEnv PP_VHOST_ID "d4ecd1f7-3321-4620-a010-50267cdad856"
            
    </IfModule>

            
    ScriptAlias "/cgi-bin/" "/var/www/vhosts/domain.de/mail.domain.de/cgi-bin/"

            
    Redirect permanent /plesk-stat https://mail.domain.de/plesk-stat
            
    Redirect permanent /webstat https://mail.domain.de/webstat
            
    Redirect permanent /webstat-ssl https://mail.domain.de/webstat-ssl
            
    Redirect permanent /ftpstat https://mail.domain.de/ftpstat
            
    Redirect permanent /anon_ftpstat https://mail.domain.de/anon_ftpstat
            
    Redirect permanent /awstats-icon https://mail.domain.de/awstats-icon

            
    <IfModule mod_ssl.c>
                    
    SSLEngine off
            
    </IfModule>

            
    SetEnv PP_CUSTOM_PHP_INI /var/www/vhosts/system/mail.domain.de/etc/php.ini
            SetEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi

            
    <IfModule mod_fcgid.c>
                    
    FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/system/mail.domain.de/etc/php.ini
                    FcgidInitialEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi
                    FcgidMaxRequestLen 134217728
            
    </IfModule>

            <
    Directory /var/www/vhosts/domain.de/mail.domain.de>

                    <
    IfModule mod_python.c>
                            <
    Files ~ (\.py$)>
                                    
    SetHandler python-program
                                    PythonHandler mod_python
    .cgihandler
                            
    </Files>
                    </
    IfModule>
                    <
    IfModule mod_fcgid.c>
                            <
    Files ~ (\.fcgi$)>
                                    
    SetHandler fcgid-script
                                    Options 
    +ExecCGI
                            
    </Files>
                    </
    IfModule>
                    <
    IfModule mod_fcgid.c>
                            <
    Files ~ (\.php$)>
                                    
    SetHandler fcgid-script
                                    FCGIWrapper 
    /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
                                    Options 
    +ExecCGI
                            
    </Files>
                    </
    IfModule>
                                    
    Options FollowSymLinks
                    AllowOverride None
                    RewriteEngine On
                    RewriteCond 
    %{HTTPSoff
                    RewriteRule 
    (.*) https://%{HTTP_HOST}%{REQUEST_URI}

                    
    Options -Includes +ExecCGI

            
    </Directory>

            <
    Directory /var/www/vhosts/domain.de/web_users>

                    <
    IfModule mod_php4.c>
                            
    php_admin_flag engine off
                    
    </IfModule>

                    <
    IfModule mod_php5.c>
                            
    php_admin_flag engine off
                    
    </IfModule>

            </
    Directory>

            <
    Directory /var/www/vhosts/mail.domain.de>
                    
    Options +FollowSymLinks
            
    </Directory>

            <
    Directory "/var/www/vhosts/system/mail.domain.de/statistics">
                    
    AuthType Basic
                    AuthName 
    "Domainstatistiken"
                    
    AuthUserFile "/var/www/vhosts/system/mail.domain.de/pd/d..httpdocs@plesk-stat"
                    
    require valid-user
            
    </Directory>

            <
    IfModule mod_security2.c>
            </
    IfModule>

    </
    VirtualHost
    This seems to work because when I visite the domain mail.domain.de I got redirectet to appsuite/signin ang get the message "Connection Error - The service is not available right now. Retry". I think this is relatet that the proxy_http.conf didn't work propper!

    Please help!

    Regards
    Arexx

  2. #2
    Join Date
    Jan 2013
    Location
    Stuttgart
    Posts
    10

    Default

    It was related to Apache 2.4

    [Thu Oct 24 09:45:46.159087 2013] [proxy:crit] [pid 1473] AH02432: Cannot find LB Method: byrequests
    [Thu Oct 24 09:45:46.204362 2013] [proxy_balancer:emerg] [pid 1473] (22)Invalid argument: AH01183: Cannot share balancer
    [Thu Oct 24 09:45:46.204528 2013] [:emerg] [pid 1473] AH00020: Configuration Failed, exiting
    After go throw this steps and fine tune the proxy_http.conf it works fine....



    Having apache 2.4 at a supported distro is still a way to go. However, here are some changes we need to take care at documentation when describing ox setup. Tested with Debian Jessie.

    * etc/conf.d has moved to etc/conf-available. Configuration files can be en/disabled like:
    a2enconf ox-proxy_http
    a2enconf redirect

    * mod_proxy has been refactored, separate lb modules are now available
    a2enmod lbmethod_byrequests

    Also, it looks like the mod_proxy syntax has been altered with 2.4

    <Proxy /ajax>
    ProxyPass http://localhost:8009/ajax
    </Proxy>

    will no longer work, but

    <Location /ajax>
    ProxyPass http://localhost:8009/ajax
    </Location>

    and

    ProxyPass /ajax http://localhost:8009/ajax

    works.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •