Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    kld Guest

    Default Javac error on build

    Hi,
    I have the following error when i try to compile Open xchange on debian.

    [javac] Compiling 209 source files to /tmp/open-xchange/build
    [javac] /tmp/open-xchange/src/com/openexchange/tools/servlet/ServletContextWrapper.java:73: com.openexchange.tools.servlet.ServletContextWrapp er is not abstract and does not override abstract method getContextPath() in javax.servlet.ServletContext
    [javac] public class ServletContextWrapper implements ServletContext {
    [javac] ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 1 error

    Thanks for any help.

  2. #2
    slybob Guest

    Default getting the same error

    Hi, Im getting the same error. I think its because I haven't got all the 3rd party libraries in order.

    have a look at http://wiki.open-xchange.com/wiki/in...y_dependencies

    I think they all have to have the appropriate filenames, a couple of them need compiling from source.

  3. #3
    altariq Guest

    Default

    Best solution i think is to download the vmware image and copy the jar files out of the image. (easy way with windows is "winspc" via ssh) and than to /opt/open-xchange/lib/

    i tried it yet and it works

  4. #4
    kld Guest

    Default

    thanks ,
    I keep on checking the dependencies and let let you know ( if i find) witch one has the problem. I tkink it's jsdk.jar but i have to be sure. I tired with those in the link but a problème get worse I had one error and know 100 errors.... I stil missed something....
    I use servlet-2_5-api.jar witch i renamed to jsdk.jar is this correct?
    Last edited by kld; 03-20-2007 at 05:35 PM.

  5. #5
    Ben Pahne Guest

    Default

    http://java.sun.com/products/servlet/download.html
    Download the specification 2.3 Final Release class files.
    After download rename the zip file to jsdk.jar.

  6. #6
    kld Guest

    Default

    Thanks ben ! .
    I downloaded them and the build proccess was succesfull.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •