Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Apr 2016
    Posts
    10

    Default Problems with Apache Configuration

    Hi,

    I installed OX on our Ubuntu Server using the installation instructions for Debian/NGU 7.0 (Wheezy).
    the installation finished with no errors, and the OX process is running.

    Unfortunately, it seems like there are problem with my Grizzly and/or Apache Communication.

    When I open our OX website, I get:
    "Connection error The service is not available right now. Retry"
    Bildschirmfoto vom 2016-04-08 12:01:12.png

    When I try SSH port forwarding and directly go to the Grizzly, I get:
    Resource identified by path '/', does not exist.
    Bildschirmfoto vom 2016-04-08 12:02:38.png

    Here is my Apache Config file:

    Code:
    <virtualhost *:443>
       ServerName ox.myhost.de
       ServerAdmin admin@myhost.de
    
       SSLEngine On
            SSLProtocol all -SSLv2
            SSLCipherSuite ALL:!ADH:!SSLv2:RC4+RSA:+HIGH:+MEDIUM
       SSLCertificateFile /etc/ssl/myhost.crt
       SSLCertificateKeyFile /etc/ssl/private/myhost.key
       SSLCertificateChainFile /etc/ssl/intermediate.crt
       #Internet Explorer SSL Einstellung:
       SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
       #RequestHeader set X-Forwarded-Proto "https"
    
       #Man-In-The-Middle-Attacks verhindern mit Strict Transport Security
       # <IfModule mod_headers.c>
       #   Header always set Strict-Transport-Security "max-age=15768000; includeSu$
       #   KeepAlive On
       #   KeepAliveTimeout 100
       #   MaxKeepAliveRequests 200
       # </IfModule>
    
    
        DocumentRoot /var/www/appsuite
        <Directory /var/www/appsuite>
            Options Indexes FollowSymLinks MultiViews SymLinksIfOwnerMatch
            AllowOverride None
            Order allow,deny
            allow from all
            RedirectMatch ^/$ /appsuite/
        </Directory>
    
         <Directory /var/www/appsuite>
            Options None +SymLinksIfOwnerMatch
            AllowOverride Indexes FileInfo
        </Directory>
         # deflate
            AddOutputFilterByType DEFLATE text/html text/plain text/javascript appl$
            # pre-compressed files
            AddType text/javascript .jsz
            AddType text/css .cssz
            AddType text/xml .xmlz
            AddType text/plain .po
    
            AddEncoding gzip .jsz .cssz .xmlz
            SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip
    
            ExpiresActive On
            <Location /var/www/appsuite>
                    # Expires (via ExpiresByType to override global settings)
                    ExpiresByType image/gif "access plus 6 months"
                    ExpiresByType image/png "access plus 6 months"
                    ExpiresByType image/jpg "access plus 6 months"
                    ExpiresByType image/jpeg "access plus 6 months"
                    ExpiresByType text/css "access plus 6 months"
                    ExpiresByType text/html "access plus 6 months"
                    ExpiresByType text/xml "access plus 6 months"
                    ExpiresByType text/javascript "access plus 6 months"
                    ExpiresByType text/x-js "access plus 6 months"
                    ExpiresByType application/x-javascript "access plus 6 months"
                    ExpiresDefault "access plus 6 months"
                    Header append Cache-Control "private"
                    Header unset Last-Modified
                    Header unset Vary
                    # Strip version
                    RewriteEngine On
                    RewriteRule v=\w+/(.+) $1 [L]
                    # Turn off ETag
                    Header unset ETag
                    FileETag None
            </Location>
            <Location /var/www/appsuite/index.html>
                    ExpiresByType text/html "now"
                    ExpiresDefault "now"
                    Header unset Last-Modified
                    Header set Cache-Control "no-store, no-cache, must-revalidate, $
                    # Turn off ETag
                    Header unset ETag
                    FileETag None
            </Location>
    
    
    
    </virtualhost>
    Can someone help my out on this?

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    The mod_proxy configuration would be more interesting. Do you have an http_proxy.conf?

  3. #3
    Join Date
    Apr 2016
    Posts
    10

    Default

    Hello Wolfgang,

    thanks for your reply, here is the file, which is named proxy_http.conf.
    I think I copied it 1:1 from the instructions.

    a2enmod proxy_http says "Module proxy_http already enabled"

    Code:
    <IfModule mod_proxy_http.c>
       ProxyRequests Off
       ProxyStatus On
       # When enabled, this option will pass the Host: line from the incoming request to the proxied host.
       ProxyPreserveHost On
       # Please note that the servlet path to the soap API has changed:
       <Location /webservices>
           # restrict access to the soap provisioning API
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
           # you might add more ip addresses / networks here
           # Allow from 192.168 10 172.16
       </Location>
    
       # The old path is kept for compatibility reasons
       <Location /servlet/axis2/services>
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
       </Location>
    
       # Enable the balancer manager mentioned in
       # http://oxpedia.org/wiki/index.php?title=AppSuite:Running_a_cluster#Updating_a_Cluster
       <IfModule mod_status.c>
         <Location /balancer-manager>
           SetHandler balancer-manager
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
         </Location>
       </IfModule>
    
       <Proxy balancer://oxcluster>
           Order deny,allow
           Allow from all
           # multiple server setups need to have the hostname inserted instead localhost
           BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
           # Enable and maybe add additional hosts running OX here
           # BalancerMember http://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
    
       # The standalone documentconverter(s) within your setup (if installed)
       # Make sure to restrict access to backends only
       # See: http://httpd.apache.org/docs/$YOUR_VERSION/mod/mod_authz_host.html#allow for more infos
       #<Proxy balancer://oxcluster_docs>
       #    Order Deny,Allow
       #    Deny from all
       #    Allow from backend1IP
       #    BalancerMember http://converter_host:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 keepalive=On route=APP3
       #    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
       #       SetEnv proxy-initial-not-pooled
       #    SetEnv proxy-sendchunked
       #</Proxy>
       # Define another Proxy Container with different timeout for the sync clients. Microsoft recommends a minimum value of 15 minutes.
       # Setting the value lower than the one defined as com.openexchange.usm.eas.ping.max_heartbeat in eas.properties will lead to connection
       # timeouts for clients.  See http://support.microsoft.com/?kbid=905013 for additional information.
       #
       # NOTE for Apache versions < 2.4:
       # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
       # BalancerMember's IP so Apache can treat it as additional BalancerMember with a different timeout.
       #
       # Example from /etc/hosts: 127.0.0.1 localhost localhost_sync
       #
       # Alternatively select one or more hosts of your cluster to be restricted to handle only eas/usm requests
       <Proxy balancer://eas_oxcluster>
          Order deny,allow
          Allow from all
          # multiple server setups need to have the hostname inserted instead localhost
          BalancerMember http://localhost_sync:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
          # Enable and maybe add additional hosts running OX here
          # BalancerMember http://oxhost2:8009 timeout=1900  smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
    
       # When specifying additional mappings via the ProxyPass directive be aware that the first matching rule wins. Overlapping urls of
       # mappings have to be ordered from longest URL to shortest URL.
       #
       # Example:
       #   ProxyPass /ajax      balancer://oxcluster_with_100s_timeout/ajax
       #   ProxyPass /ajax/test balancer://oxcluster_with_200s_timeout/ajax/test
       #
       # Requests to /ajax/test would have a timeout of 100s instead of 200s
       #
       # See:
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#proxypass Ordering ProxyPass Directives
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#workers Worker Sharing
       ProxyPass /ajax balancer://oxcluster/ajax
       ProxyPass /appsuite/api balancer://oxcluster/ajax
       ProxyPass /drive balancer://oxcluster/drive
       ProxyPass /infostore balancer://oxcluster/infostore
       ProxyPass /publications balancer://oxcluster/publications
       ProxyPass /realtime balancer://oxcluster/realtime
       ProxyPass /servlet balancer://oxcluster/servlet
       ProxyPass /webservices balancer://oxcluster/webservices
    
       #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws
    
       ProxyPass /usm-json balancer://eas_oxcluster/usm-json
       ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync
    
    </IfModule>

  4. #4
    Join Date
    Apr 2016
    Posts
    10

    Default

    Hell Wolfgang, thanks for your reply.
    I think I copied it directly from the installation instructions.



    Code:
    <IfModule mod_proxy_http.c>
       ProxyRequests Off
       ProxyStatus On
       # When enabled, this option will pass the Host: line from the incoming request to the proxied host.
       ProxyPreserveHost On
       # Please note that the servlet path to the soap API has changed:
       <Location /webservices>
           # restrict access to the soap provisioning API
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
           # you might add more ip addresses / networks here
           # Allow from 192.168 10 172.16
       </Location>
    
       # The old path is kept for compatibility reasons
       <Location /servlet/axis2/services>
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
       </Location>
    
       # Enable the balancer manager mentioned in
       # http://oxpedia.org/wiki/index.php?title=AppSuite:Running_a_cluster#Updating_a_Cluster
       <IfModule mod_status.c>
         <Location /balancer-manager>
           SetHandler balancer-manager
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
         </Location>
       </IfModule>
    
       <Proxy balancer://oxcluster>
           Order deny,allow
           Allow from all
           # multiple server setups need to have the hostname inserted instead localhost
           BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
           # Enable and maybe add additional hosts running OX here
           # BalancerMember http://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
    
      # The standalone documentconverter(s) within your setup (if installed)
       # Make sure to restrict access to backends only
       # See: http://httpd.apache.org/docs/$YOUR_VERSION/mod/mod_authz_host.html#allow for more infos
       #<Proxy balancer://oxcluster_docs>
       #    Order Deny,Allow
       #    Deny from all
       #    Allow from backend1IP
       #    BalancerMember http://converter_host:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 keepalive=On route=APP3
       #    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
       #       SetEnv proxy-initial-not-pooled
       #    SetEnv proxy-sendchunked
       #</Proxy>
       # Define another Proxy Container with different timeout for the sync clients. Microsoft recommends a minimum value of 15 minutes.
       # Setting the value lower than the one defined as com.openexchange.usm.eas.ping.max_heartbeat in eas.properties will lead to connection
       # timeouts for clients.  See http://support.microsoft.com/?kbid=905013 for additional information.
       #
       # NOTE for Apache versions < 2.4:
       # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
       # BalancerMember's IP so Apache can treat it as additional BalancerMember with a different timeout.
       #
       # Example from /etc/hosts: 127.0.0.1 localhost localhost_sync
       #
       # Alternatively select one or more hosts of your cluster to be restricted to handle only eas/usm requests
       <Proxy balancer://eas_oxcluster>
          Order deny,allow
          Allow from all
          # multiple server setups need to have the hostname inserted instead localhost
          BalancerMember http://localhost_sync:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
          # Enable and maybe add additional hosts running OX here
          # BalancerMember http://oxhost2:8009 timeout=1900  smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
    
       # When specifying additional mappings via the ProxyPass directive be aware that the first matching rule wins. Overlapping urls of
       # mappings have to be ordered from longest URL to shortest URL.
       #
       # Example:
       #   ProxyPass /ajax      balancer://oxcluster_with_100s_timeout/ajax
       #   ProxyPass /ajax/test balancer://oxcluster_with_200s_timeout/ajax/test
       #
       # Requests to /ajax/test would have a timeout of 100s instead of 200s
       #
       # See:
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#proxypass Ordering ProxyPass Directives
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#workers Worker Sharing
       ProxyPass /ajax balancer://oxcluster/ajax
       ProxyPass /appsuite/api balancer://oxcluster/ajax
       ProxyPass /drive balancer://oxcluster/drive
       ProxyPass /infostore balancer://oxcluster/infostore
       ProxyPass /publications balancer://oxcluster/publications
       ProxyPass /realtime balancer://oxcluster/realtime
       ProxyPass /servlet balancer://oxcluster/servlet
       ProxyPass /webservices balancer://oxcluster/webservices
    
       #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws
    
       ProxyPass /usm-json balancer://eas_oxcluster/usm-json
       ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync
    
    </IfModule>

  5. #5
    Join Date
    Apr 2016
    Posts
    10

    Default

    trying to answer but my post always gets to "has to be seen by a moderator for release" ...

  6. #6
    Join Date
    Apr 2016
    Posts
    10

    Default

    Code:
    <IfModule mod_proxy_http.c>
       ProxyRequests Off
       ProxyStatus On
       # When enabled, this option will pass the Host: line from the incoming request to the proxied host.
       ProxyPreserveHost On
       # Please note that the servlet path to the soap API has changed:
       <Location /webservices>
           # restrict access to the soap provisioning API
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
           # you might add more ip addresses / networks here
           # Allow from 192.168 10 172.16
       </Location>
    
       # The old path is kept for compatibility reasons
       <Location /servlet/axis2/services>
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
       </Location>
    
       # Enable the balancer manager mentioned in
       # http://oxpedia.org/wiki/index.php?title=AppSuite:Running_a_cluster#Updating_a_Cluster
       <IfModule mod_status.c>
         <Location /balancer-manager>
           SetHandler balancer-manager
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
         </Location>
       </IfModule>
    
       <Proxy balancer://oxcluster>
           Order deny,allow
           Allow from all
           # multiple server setups need to have the hostname inserted instead localhost
           BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
           # Enable and maybe add additional hosts running OX here
           # BalancerMember http://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
    
      # The standalone documentconverter(s) within your setup (if installed)
       # Make sure to restrict access to backends only
       # See: http://httpd.apache.org/docs/$YOUR_VERSION/mod/mod_authz_host.html#allow for more infos
       #<Proxy balancer://oxcluster_docs>
       #    Order Deny,Allow
       #    Deny from all
       #    Allow from backend1IP
       #    BalancerMember http://converter_host:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 keepalive=On route=APP3
       #    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
       #       SetEnv proxy-initial-not-pooled
       #    SetEnv proxy-sendchunked
       #</Proxy>
       # Define another Proxy Container with different timeout for the sync clients. Microsoft recommends a minimum value of 15 minutes.
       # Setting the value lower than the one defined as com.openexchange.usm.eas.ping.max_heartbeat in eas.properties will lead to connection
       # timeouts for clients.  See http://support.microsoft.com/?kbid=905013 for additional information.
       #
       # NOTE for Apache versions < 2.4:
       # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
       # BalancerMember's IP so Apache can treat it as additional BalancerMember with a different timeout.
       #
       # Example from /etc/hosts: 127.0.0.1 localhost localhost_sync
       #
       # Alternatively select one or more hosts of your cluster to be restricted to handle only eas/usm requests
       <Proxy balancer://eas_oxcluster>
          Order deny,allow
          Allow from all
          # multiple server setups need to have the hostname inserted instead localhost
          BalancerMember http://localhost_sync:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
          # Enable and maybe add additional hosts running OX here
          # BalancerMember http://oxhost2:8009 timeout=1900  smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
    
       # When specifying additional mappings via the ProxyPass directive be aware that the first matching rule wins. Overlapping urls of
       # mappings have to be ordered from longest URL to shortest URL.
       #
       # Example:
       #   ProxyPass /ajax      balancer://oxcluster_with_100s_timeout/ajax
       #   ProxyPass /ajax/test balancer://oxcluster_with_200s_timeout/ajax/test
       #
       # Requests to /ajax/test would have a timeout of 100s instead of 200s
       #
       # See:
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#proxypass Ordering ProxyPass Directives
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#workers Worker Sharing
       ProxyPass /ajax balancer://oxcluster/ajax
       ProxyPass /appsuite/api balancer://oxcluster/ajax
       ProxyPass /drive balancer://oxcluster/drive
       ProxyPass /infostore balancer://oxcluster/infostore
       ProxyPass /publications balancer://oxcluster/publications
       ProxyPass /realtime balancer://oxcluster/realtime
       ProxyPass /servlet balancer://oxcluster/servlet
       ProxyPass /webservices balancer://oxcluster/webservices
    
       #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws
    
       ProxyPass /usm-json balancer://eas_oxcluster/usm-json
       ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync
    
    </IfModule>

  7. #7
    Join Date
    Apr 2016
    Posts
    10

    Default

    Thanks for your reply Wolfgang. I directly copied the proxy_http from the installation instructions.

  8. #8
    Join Date
    Apr 2016
    Posts
    10

    Default

    ... and I do not know if it is causing any problems, as the directives in the proxy_http.conf are preety much a riddle for me.

  9. #9
    Join Date
    Apr 2016
    Posts
    10

    Default

    Hello,

    anybody any ideas on this?


    Brgds
    Jörg

  10. #10
    Join Date
    Jul 2016
    Posts
    4

    Default

    I seemingly had similar problems with Apache configuration. I proxy OXchange to nginx from Apache, but that doesn't matter as I also had the problem with Apache.

    I was also getting the "Connection error The service is not available right now. Retry" -error. After checking my http_proxy.conf, I noticed or rather remembered that I had tried a different solution to the problem before:

    I had ProxyPass with localhost like follows. Also I don't know if it has anything to do with this problem but my http_proxy.conf was located in conf.d.
    # ProxyPass /ajax balancer://oxcluster/ajax
    ProxyPass /ajax http://localhost:8009/ajax
    # ProxyPass /appsuite/api balancer://oxcluster/ajax
    ProxyPass /appsuite/api http://localhost:8009/ajax
    # ProxyPass /drive balancer://oxcluster/drive
    ProxyPass /drive http://localhost:8009/drive
    # ProxyPass /infostore balancer://oxcluster/infostore
    ProxyPass /infostore http://localhost:8009/infostore
    # ProxyPass /publications balancer://oxcluster/publications
    ProxyPass /publications http://localhost:8009/publications
    # ProxyPass /realtime balancer://oxcluster/realtime
    ProxyPass /realtime http://localhost:8009/realtime
    # ProxyPass /servlet balancer://oxcluster/servlet
    ProxyPass /servlet http://localhost:8009/servlet
    # ProxyPass /webservices balancer://oxcluster/webservices
    ProxyPass /webservices http://localhost:8009/webservices
    # #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws


    # ProxyPass /usm-json balancer://eas_cluster/usm-json
    ProxyPass /usm-json http://localhost:8009/usm-json
    # ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync[/url]
    ProxyPass /Microsoft-Server-ActiveSync http://localhost:8009/Microsoft-Server-ActiveSync
    I then removed this config and started with a fresh example from the tutorial. I placed it in /etc/apache2/conf-available and made a symlink to /conf-available. Using Apache version 2.4.10 on Debian btw. After trying to restart apache2 I got this in the logs:

    ""[Fri Jul 15 01:08:29.195425 2016] [proxy:crit] [pid 4193] AH02432: Cannot find LB Method: byrequests
    [Fri Jul 15 01:08:29.195500 2016] [proxy_balancer:emerg] [pid 4193] (22)Invalid argument: AH01183: Cannot share balancer
    ""
    Leading me to: http://stackoverflow.com/questions/1...e-load-balance and just using the commented solution
    "a2enmod lbmethod_byrequests slotmem_shm" After this Apache restarted normally and I was able to get to and use the login screen.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •