Announcement

Collapse
No announcement yet.

Mails mit Outlook und Co senden

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mails mit Outlook und Co senden

    Hi,

    ich arbeite mich jetzt schon die ganze Nacht durch diverse Configs um herauszufinden wie ich es schaffe Mail von Extern (Outlook, Thunderbird, ...) zu senden.

    Hat irgendjemand eine Ahnung wie ich die Authentifizierung von Postfix über die Datenbank laufen lassen kann???

    Danke
    Mani

  • #2
    Hallo Mani,

    das machst du am besten in dem du Postfix nach der Anleitung im Wiki konfigurierst.
    Dort wird die SMTP Authentifikation gegen PAM gemacht, das seinerseits wieder gegen die OX-User DB geht. Denk auch daran den Client entsprechend einzurichten (SMTP Auth). Falls es Schwierigkeiten gibt, empfielt es sich zu sniffen was die Groupware schickt und was der externe Client schickt, vielleicht werden dann Unterschiede sichtbar.

    mfg
    Last edited by Martin Heiland; 08-06-2007, 08:51 AM.

    Comment


    • #3
      Das ist es ja gerade, Postfix ist wie im Wiki beschrieben konfiguriert, aber das senden über Outlook funktioniert trotzdem nicht.
      Wie soll es auch, wenn kein "smtpd_sasl_auth_enable = yes" gesetzt ist.
      Wenn ich das aber setze geht gar nichts mehr, weder mit Outlook noch mit OX.
      In der smtpd.conf habe ich versucht als Authentifizierung pam zu setzen und dann die selbe Konfig wie bei imap zu verwenden. Leider Fehlanzeige.
      Komm da wirklich nicht weiter...

      Bei der EE funktioniert es übrigens auch nicht.

      Lg Mani

      Comment


      • #4
        Hallo Mani,

        hast du die Authentifizierung für SMTP in Outlook für das entsprechende Konto aktiviert?

        mfg

        Comment


        • #5
          Ja hab ich, aber Posfix verlangt gar keine Authentifizierung, sondern lehnt Verbindungen von außen immer ab.
          Habs auch mit Telnet versucht um Outlook als Fehlerquelle auszuschließen.

          Comment


          • #6
            Hallo,

            ich habs gerade mit Outlook 2003 und 2007 versucht nachzustellen - funktioniert hier ohne Probleme gegen eine frisch installierte und aktualisierte OX Express.

            Comment


            • #7
              Code:
              220 proliantML110.example.com ESMTP Postfix (Open-Xchange Express)
              
              EHLO qaxp
              
              250-proliantML110.example.com
              250-PIPELINING
              250-SIZE 10240000
              250-VRFY
              250-ETRN
              250-STARTTLS
              250-AUTH LOGIN PLAIN
              250-AUTH=LOGIN PLAIN
              250 8BITMIME
              
              AUTH LOGIN
              
              334 VXNlcm5hbWU6
              
              bWFydGluLmJyYXVu
              
              334 UGFzc3dvcmQ6
              
              bmV0bGluZQ==
              
              235 Authentication successful
              
              MAIL FROM: <martin.braun@example.com>
              
              250 Ok
              
              RCPT TO: <postmaster@example.com>
              
              250 Ok
              
              DATA
              
              354 End data with <CR><LF>.<CR><LF>
              
              From: "Martin Braun" <martin.braun@example.com>
              To: <postmaster@example.com>
              Subject: foo
              Date: Tue, 7 Aug 2007 18:55:10 +0200
              Message-ID: <000501c7d913$b71b1580$ba20a8c0@qaxp>
              MIME-Version: 1.0
              Content-Type: multipart/alternative;
              .boundary="----=_NextPart_000_0006_01C7D924.7AA3E580"
              X-Mailer: Microsoft Office Outlook 11
              Thread-Index: AcfZE7bH74/xylUETcSWLXfJM94hrw==
              X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2962
              
              This is a multi-part message in MIME format.
              
              ------=_NextPart_000_0006_01C7D924.7AA3E580
              Content-Type: text/plain;
              .charset="us-ascii"
              Content-Transfer-Encoding: 7bit
              
              bar
              
              ------=_NextPart_000_0006_01C7D924.7AA3E580
              Content-Type: text/html;
              .charset="us-ascii"
              Content-Transfer-Encoding: quoted-printable
              
              <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
              <HTML><HEAD>
              <META http-equiv=3DContent-Type content=3D"text/html; =
              charset=3Dus-ascii">
              <META content=3D"MSHTML 6.00.2900.2963" name=3DGENERATOR></HEAD>
              <BODY>
              <DIV><SPAN class=3D687045516-07082007><FONT face=3DArial=20
              size=3D2>bar</FONT></SPAN></DIV></BODY></HTML>
              
              ------=_NextPart_000_0006_01C7D924.7AA3E580--
              
              .
              250 Ok: queued as E57F866C84B
              QUIT
              221 Bye

              Comment


              • #8
                Code:
                250-AUTH LOGIN PLAIN
                250-AUTH=LOGIN PLAIN
                zu sowas kommts bei mir gar nicht.

                Hier die EE:
                Code:
                220 ox.local ESMTP Postfix (OXExpress)
                EHLO asdf
                250-ox.local
                250-PIPELINING
                250-SIZE 10240000
                250-VRFY
                250-ETRN
                250-STARTTLS
                250 8BITMIME
                AUTH LOGIN
                503 Error: authentication not enabled
                Bei der Community Version siehts gleich aus...

                Ich mach jetzt mal ein update für die EE, mal sehn ob sich da was ändert.

                Comment


                • #9
                  Mani,

                  hast du eventuell noch eine Beta Version von OX Express laufen? Der SMTP Tag (OXExpress) unterscheidet sich ja offenbar von meiner Installation.

                  mfg

                  Comment


                  • #10
                    Ja hab ich, vielleicht hät ich das mal dazu sagen sollen...

                    Die EE läuft aber nur interessehalber (Admin Gui, ...). Verwendet wird die Community Edition.

                    Mich würd wirklich interessieren wie deine main.cf und master.cf aussehen.

                    lg Mani

                    Comment


                    • #11
                      Für meine Community Edition OX habe ich die weitesgehend die SMTP Konfiguration aus dem Wiki übernommen und um einige Optimierungen erweitert - jedoch nichts was SMTP Auth betreffen sollte.

                      master.cf
                      Code:
                      smtp      inet  n       -       -       -       -       smtpd
                      pickup    fifo  n       -       -       60      1       pickup
                      cleanup   unix  n       -       -       -       0       cleanup
                      qmgr      fifo  n       -       n       300     1       qmgr
                      #qmgr     fifo  n       -       -       300     1       oqmgr
                      tlsmgr    unix  -       -       -       1000?   1       tlsmgr
                      rewrite   unix  -       -       -       -       -       trivial-rewrite
                      bounce    unix  -       -       -       -       0       bounce
                      defer     unix  -       -       -       -       0       bounce
                      trace     unix  -       -       -       -       0       bounce
                      verify    unix  -       -       -       -       1       verify
                      flush     unix  n       -       -       1000?   0       flush
                      proxymap  unix  -       -       n       -       -       proxymap
                      smtp      unix  -       -       -       -       -       smtp
                      relay     unix  -       -       -       -       -       smtp
                              -o fallback_relay=
                      showq     unix  n       -       -       -       -       showq
                      error     unix  -       -       -       -       -       error
                      discard   unix  -       -       -       -       -       discard
                      local     unix  -       n       n       -       -       local
                      virtual   unix  -       n       n       -       -       virtual
                      lmtp      unix  -       -       n       -       -       lmtp
                      anvil     unix  -       -       -       -       1       anvil
                      scache    unix  -       -       -       -       1       scache
                      maildrop  unix  -       n       n       -       -       pipe
                        flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
                      uucp      unix  -       n       n       -       -       pipe
                        flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
                      ifmail    unix  -       n       n       -       -       pipe
                        flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
                      bsmtp     unix  -       n       n       -       -       pipe
                        flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
                      scalemail-backend unix  -       n       n       -       2       pipe
                        flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
                      mailman   unix  -       n       n       -       -       pipe
                        flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
                        ${nexthop} ${user}
                      main.cf
                      Code:
                      smtpd_banner = $myhostname - ESMTP Service
                      mailbox_transport = lmtp:unix:/var/run/cyrus/socket/lmtp
                      
                      virtual_alias_domains = mysql:/etc/postfix/ox_domains.cf
                      virtual_alias_maps = mysql:/etc/postfix/ox_user_aliases.cf, mysql:/etc/postfix/ox_aliases.cf, mysql:/etc/postfix/ox_resource_aliases.cf, mysql:/etc/postfix/ox_group_aliases.cf
                      
                      smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/ox_externaldomaincheck.cf
                      smtpd_restriction_classes = local_only
                      local_only = check_recipient_access mysql:/etc/postfix/ox_domains.cf, reject
                      
                      smtpd_recipient_restrictions = check_sender_access mysql:/etc/postfix/ox_senderrestrictions.cf, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
                      smtpd_tls_cert_file = /etc/ssl/certs/eecert.pem
                      smtpd_tls_key_file = /etc/ssl/private/eekey.pem
                      procmail_destination_concurrency_limit = 1
                      procmail_destination_recipient_limit = 1
                      maximal_queue_lifetime = 1d
                      alias_maps = $alias_database
                      bounce_queue_lifetime = 1d
                      Last edited by Martin Heiland; 08-07-2007, 12:44 PM.

                      Comment


                      • #12
                        Naja, auch mit den selben Konfigs gibt es keine smtp Authentifizierung.

                        Fällt dir noch was ein??

                        lg Mani

                        Comment


                        • #13
                          evtl. das hier?:
                          http://www.tuxhausen.de/postfix_smtp_auth-3.html

                          Ist es möglich das bei deinem Postfix die SASL Authentifizierung nicht funktioniert?
                          Last edited by Martin Heiland; 08-07-2007, 01:48 PM.

                          Comment


                          • #14
                            Ach hier steht in der Konfig:
                            Code:
                            smtp_sasl_auth_enable = yes
                            Wie sieht denn deine smtpd.conf im /etc/postfix/sasl/ Verzeichnis aus? Vorausgesetzt du hast eine.

                            Comment


                            • #15
                              Problem gelöst

                              Es geht!

                              Folgende Schritte waren notwendig:

                              Zusätzliche Zeilen in main.cf
                              Code:
                              smtpd_sasl_auth_enable = yes
                              smtp_sasl_security_options = noanonymous
                              broken_sasl_auth_clients = yes
                              Dann eine Datei mit dem Namen smtpd.conf in das Verzeichnis /etc/postfix/sasl/.
                              Inhalt:
                              Code:
                              pwcheck_method: saslauthd
                              mech_list: PLAIN LOGIN
                              Eine Datei mit dem Namen smtp in das Verzeichnis /etc/pam.d/.
                              Den Inhalt nehmt ihr am besten aus der imap-Datei im selben Verzeichnis.

                              Dann noch den Benutzer Postfix der Gruppe sasl hinzufügen:
                              Code:
                              adduser postfix sasl
                              Postfix Konfiguration neu einlesen:
                              Code:
                              /etc/init.d/postfix reload
                              Fertig!!!

                              Es ist noch darauf zu achten, dass Postfix nicht in einer chroot-Umgebung läuft. -> master.cf

                              Lg Mani

                              Comment

                              Working...
                              X