Announcement

Collapse
No announcement yet.

Admin GUI on CentOS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Admin GUI on CentOS

    Has anyone got the admin gui for OX 6.18 working on Centos.

    I am having problems finding information relating to web access, or even desktop access, configuration for the administration gui.

    Is it a case of enabling something when registering the server or creating contexts? Using the CLT is complicated and I am concerned that I will break should I set a wrong command parameter.

    Is it possible to run the jar files on a Windows desktop at all?

  • #2
    Hi

    search for Peter's Admin GUI here in the forum.

    Comment


    • #3
      Thanks for the pointer sebbel. I have now an Admin GUI.

      Now my project can go ahead. Thank you again.

      Comment


      • #4
        With regard to the Admin GUI database access, I am seeing an error...
        "java.lang.Exception: com.openexchange.admin.rmi.exceptions.StorageExcep tion: com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.StorageExcep tion: Table 'configdb.sequence_context' doesn't exist at at.sciencesoft.controller.CreateContext.process(Cr eateContext.java:144) at at.sciencesoft.controller.Main.process(Main.java:8 3) at ......"

        The database "configdb" does not have the table mentioned above "sequence_context". Should I just create this table? and if so what fields should it have?
        Last edited by save9david; 12-10-2010, 12:04 PM. Reason: addition to text

        Comment


        • #5
          Hi!

          This error is probably not GUI releated.
          See following posting
          http://www.open-xchange.com/forum/sh...-createcontext

          Peter

          Comment


          • #6
            I managed to get Admin GUI running.
            I ran again the initconfigdb again after confirming open-xchange-admin-plugin-autocontextid was installed. After this I created a new table in mysql.configdb called sequence_context which was same as configdb_sequence.

            After running oxinstaller script, registerserver, registerfilstore & registerdatabase, I opened browser to admin-gui URL (http://myoxserver/servlet/webserver/index.html) and deleted the context created in earlier step.

            Now a new context could be created but when doing so an error appears. This can be ignored and can continue to view context after setting contextadmin.

            I can create new users in the default context through the gui but am getting errors now when I select Users when using a new context though, again I will continue to try and fix - help always accepted

            I will continue to update this thread as I go along.

            Comment

            Working...
            X