No announcement yet.

Problem installing Spanish packages

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem installing Spanish packages

    I'm doin' an standard install of OX 6.18 on an Ubuntu 10.04 server. When I install spanish packages and try to configure spanish in OX's gui, it says Undefined and it remains in English. Only English US & UK, German and French are available.

    Is it a bug? Any way to work around?

    Thank you

  • #2

    please describe what package versions you are using, what operating system and if there are any error messages when installing the packages or selecting spanish as a language.



    • #3
      Open Xchange packages are version, downloaded from repositories at Ubuntu version is Ubuntu server 10.04. I've done all the installation procedure just as described in

      That gave me an initial installation in english. Then, I do "apt-get install open-xchange-gui-lang-es-es and open-xchange-lang-es-es", no errors reported.
      Next, I log in as oxadmin and browse to "Configuration -> Otions -> Language and regions", but the list shows one new item described as "Undefined" (I suppose for spanish), which I selected, but everything remains in english



      • #4
        More info from the logs. Hope it helps:

        18-ene-2011 9:07:36 translate
        WARNING! No i18n service for locale es_ES.


        • #5

          Finally the problem is solved, but seems like there's a problem with OX's repositories for Ubuntu.

          The package open-xchange-gui-lang-es-es for Ubuntu at is empty.

          I downloaded the package for Debian at and it contains all .js files in /var/www/ox6 etc.

          Is this a bug?


          • #6
            Hi there!

            Finally this subject is solved!
            I was using OX's repositories for Ubuntu server 10.04 (It is OX version It seems that the package open-xchange-gui-lang-es-es is empty, it only has /usr/share/doc/open-xchange-gui-lang-es-es/changelog.Debian.gz and copyright files. Repository at

            I search for a suitable package in Debian repositories at, I downloaded open-xchange-gui-lang-es-es_6.18.0.0-14_all.deb and installed it with dpkg -i. This package does have .js files at /var/www/ox6/3rdparty...etc.

            Is this a bug in OX version for Ubuntu?
            Will it be solved in the future so I can update packages via apt?

            Thank you


            • #7
              Looks like there's something broken with the build.
              Please open a bug.


              • #8
                I already found the cause and fixed it with the next major release (6.20)


                • #9
                  Originally posted by Carsten Hoeger View Post
                  I already found the cause and fixed it with the next major release (6.20)

                  Do you still need me to file the bug? I'm about to push "Submit Bug"


                  • #10
                    No, thank you. That's not necessary anymore.


                    • #11
                      I'm digging this thread out since i'm having similar problems. I'm trying to install polish language packages from repositories, but no success. I'm running OX and when i try to install (apt-get, dpkg -i) any packages (from unsupported/Ubuntu and stable/DebianLenny) simply nothing happens. Actually nothing happens with any languages. I even tried installing open-xchange-lang open-xchange-lang-* open-xchange-gui-lang-* and still no additional languages. However, when i try installing everything, a similar to previously mentioned problem appears - some "undefined" choices appear on language combobox, but nothing changes when trying to switch to undefined language.