Announcement

Collapse
No announcement yet.

Open-Xchange-Server - Problems with Java

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Open-Xchange-Server - Problems with Java

    Hello community,

    First, I have installed Debian-Etch at my AMD64-Computer with Openxchange-0.8.6-3. I have installed Java(TM) SE Runtime Environment 1.6.0 to /opt/java and I have set the enviroments variable at Java by /opt/java:

    Code:
    JAVA_HOME=/opt/java
    CATALINA_HOME=/var/lib/tomcat5
    OX_HOME=/opt/open-xchange
    Nevertheless I get
    Code:
    java --version
    Code:
    java version "1.4.2"
    If I make
    Code:
    /opt/java/bin/java -version
    so I get the actual version
    Code:
    java version "1.6.0_01"
    Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
    Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_01-b06, mixed mode)
    My problem is now, I can't start OpenXchange not correctly. I have create my user in OpenLDAP, but if I want log in over the Webinterface, I get the message Can not build up Socket! SessionD running?.

    I have looled into the scripts, for example openexchange-sessiond:
    Code:
    #!/bin/sh
    #
    # This script should start the open-xchange sessiond part
    #
    # Sebastian Kauss
    #
    
    [ -f /etc/SuSE-release ] && SERVER=$(test "$HOSTTYPE" == "i386" && echo "-server")
    OPTS=""
    
    /usr/bin/java $SERVER $OPTS -ms20M -mx280M -Dopenexchange.propfile=/opt/open-xchange/etc/groupware/system.properties -DappName=sessiondApp -
    Djava.library.path=/opt/open-xchange/lib -classpath /opt/open-xchange/lib/nas.jar:/opt/open-xchange/lib/comfiretools.jar:/opt/open-xchange/l
    ib/intranet.jar:/opt/open-xchange/lib/sessiond.jar com.openexchange.sessiond.Sessiond
    If I start this script, I get:
    Exception in thread "main" java.lang.ClassFormatError: com.openexchange.sessiond.Sessiond (unrecognized class file version)
    at java.lang.VMClassLoader.defineClass(libgcj.so.70)
    at java.lang.ClassLoader.defineClass(libgcj.so.70)
    at java.security.SecureClassLoader.defineClass(libgcj .so.70)
    at java.net.URLClassLoader.findClass(libgcj.so.70)
    at java.lang.ClassLoader.loadClass(libgcj.so.70)
    at java.lang.ClassLoader.loadClass(libgcj.so.70)
    at gnu.java.lang.MainThread.run(libgcj.so.70)


    I believe there is a problem with libgcj.so.70 and so I have made
    Code:
    apt-get install  libgcj7-0
    But the result is the same, I can't start the three scripts openexchange-groupware, openexchange-sessiond and openexchange-webmail. There comes always simular messages as above.

    Have you a idea what could be wrong in my case?

    Thanks!

    SaxenPower
Working...
X