Announcement

Collapse
No announcement yet.

mod_jk Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mod_jk Problem

    Hello,

    if I try to log in to the GUI I get an error popup at 90% (Initialization: ... Please wait): "Syntax Error in Server reply: Syntax Error".
    I didn't find any errors in the open-xchange logs, but some in mod_jk.log


    [Fri Sep 21 14:23:45 2007] [error] ajp_get_reply::jk_ajp_common.c (1528): Tomcat is down or network problems. Part of the response has already been sent to the client
    [Fri Sep 21 14:23:45 2007] [error] ajp_get_reply::jk_ajp_common.c (1528): Tomcat is down or network problems. Part of the response has already been sent to the client
    [Fri Sep 21 14:23:45 2007] [error] ajp_get_reply::jk_ajp_common.c (1528): Tomcat is down or network problems. Part of the response has already been sent to the client
    [Fri Sep 21 14:23:45 2007] [error] ajp_service::jk_ajp_common.c (1758): Error connecting to tomcat. Tomcat is probably not started or is listening on the wrong port. worker=ajp13_worker failed
    [Fri Sep 21 14:23:45 2007] ajp13_worker domain.co.uk 0.286168

    [Fri Sep 21 14:23:45 2007] ajp13_worker domain.co.uk 0.260608

    [Fri Sep 21 14:23:47 2007] ajp13_worker domain.co.uk 0.132409

    [Fri Sep 21 14:23:49 2007] ajp13_worker domain.co.uk 0.014849


    I assume the problem is mod_jk, or are those errors quite normal?
    I DID NOT install tomcat and i can telnet to port 8009 and this is the output of netstat:

    # netstat -atnp | grep 8009
    tcp 0 0 127.0.0.1:8009 0.0.0.0:* LISTEN 11633/java
    tcp 0 0 127.0.0.1:8009 127.0.0.1:42857 ESTABLISHED11633/java
    tcp 0 0 127.0.0.1:8009 127.0.0.1:42605 ESTABLISHED11633/java
    tcp 0 0 127.0.0.1:8009 127.0.0.1:42609 ESTABLISHED11633/java
    tcp 0 0 127.0.0.1:8009 127.0.0.1:42657 ESTABLISHED11633/java
    tcp 0 0 127.0.0.1:8009 127.0.0.1:42627 ESTABLISHED11633/java
    tcp 0 0 127.0.0.1:42857 127.0.0.1:8009 ESTABLISHED13696/apache2
    tcp 0 0 127.0.0.1:42605 127.0.0.1:8009 ESTABLISHED26368/apache2
    tcp 0 0 127.0.0.1:42609 127.0.0.1:8009 ESTABLISHED13698/apache2
    tcp 0 0 127.0.0.1:42657 127.0.0.1:8009 ESTABLISHED13695/apache2
    tcp 0 0 127.0.0.1:42627 127.0.0.1:8009 ESTABLISHED13694/apache2


    Any ideas?



    edit: I also found this:

    # cat open-xchange-console.log
    log4j:WARN No appenders could be found for logger (Starter).
    log4j:WARN Please initialize the log4j system properly.
    Last edited by Gromit; 09-21-2007, 04:40 PM.

  • #2
    Originally posted by Gromit View Post
    [Fri Sep 21 14:23:45 2007] [error] ajp_get_reply::jk_ajp_common.c (1528): Tomcat is down or network problems. Part of the response has already been sent to the client
    If you are using Hyperion you must not run Tomcat. The few needed things Tomcat provides, are now directly handled by Hyperion itself resulting in better performance and stability.

    René

    Comment


    • #3
      @Renč:
      That's why he wrote:
      "I DID NOT install tomcat and i can telnet to port 8009 and this is the output of netstat:" ...

      Gromit, would you please post your workers.properties and ox.conf file? I don't know which distribution you are using, if you followed the wiki you may find ox.conf at /etc/apache2/conf.d

      What does a "ps axf | grep java" provide as output?

      Greetings
      Last edited by Martin Heiland; 09-22-2007, 01:58 PM.

      Comment

      Working...
      X