Announcement

Collapse
No announcement yet.

Installation of third party libraries

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation of third party libraries

    I have been trying to get this installed for awhile now per the documentation but I think I may be missing something with the third party library setup. I downloaded all the required files unzipped them and took the appropriate jar files out and placed then in the /opt/open-xchange/lib directory. Am I supposed to leave the jar files in the folders instead of taking them out? I should also mention i renamed the files that where different names according to the directions. When I try to do the open xchange installation step I get missing symbol errors and it seems like it cannot locate the jar files. Any help would be greatly appreciated.

  • #2
    ok, a short info here. you should have 2 folders:

    1. /tmp/open-xchange (or whatever you prefer as build folder!)

    and

    2. /opt/open-xchange (this folder comes from the installation)

    You are at the installation point and this means you must but the jar files into your /tmp/open-xchange/lib directory to build the ox server. when you have put all jars into the folder go whone level higher back to /tmp/open-xchange and try "ant install" here.

    try again with all lib files at the correct place and when you still have a problem then post the first 5 missings libraries that java whines about here.

    Comment


    • #3
      That did the job Build succesfull. Thankyou for your help!!

      Comment


      • #4
        Build Faile Open-Xchange Admindaemon Installation

        I am getting the following error when I attempt the build of the admindaemon.
        Buildfile: build.xml

        replacer:
        [copy] Copying 10 files to /tmp/open-xchange-admin

        compile:
        [javac] Compiling 70 source files to /tmp/open-xchange-admin/classes
        [javac] /tmp/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXUserMySQLStorage.java:86: cannot find symbol
        [javac] symbol : class OXFolderAction
        [javac] location: package com.openexchange.tools.oxfolder
        [javac] import com.openexchange.tools.oxfolder.OXFolderAction;
        [javac] ^
        [javac] /tmp/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXUserMySQLStorage.java:744: cannot find symbol
        [javac] symbol : class OXFolderAction
        [javac] location: class com.openexchange.admin.storage.mysqlStorage.OXUser MySQLStorage
        [javac] final OXFolderAction oxa = new OXFolderAction();
        [javac] ^
        [javac] /tmp/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXUserMySQLStorage.java:744: cannot find symbol
        [javac] symbol : class OXFolderAction
        [javac] location: class com.openexchange.admin.storage.mysqlStorage.OXUser MySQLStorage
        [javac] final OXFolderAction oxa = new OXFolderAction();
        [javac] ^
        [javac] /tmp/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXUserMySQLStorage.java:1611: warning: sun.misc.BASE64Encoder is Sun proprietary API and may be removed in a future release
        [javac] final String ret = (new sun.misc.BASE64Encoder().encode(pwhash));
        [javac] ^
        [javac] Note: /tmp/open-xchange-admin/src/com/openexchange/admin/tools/OXRunner.java uses or overrides a deprecated API.
        [javac] Note: Recompile with -Xlint:deprecation for details.
        [javac] Note: /tmp/open-xchange-admin/src/com/openexchange/admin/tools/PropertyHandler.java uses unchecked or unsafe operations.
        [javac] Note: Recompile with -Xlint:unchecked for details.
        [javac] 3 errors
        [javac] 1 warning

        BUILD FAILED
        /tmp/open-xchange-admin/build.xml:89: Compile failed; see the compiler error output for details.

        Total time: 4 seconds

        Comment


        • #5
          Anyone have any ideas why my admindaemon installation will not compile?

          Comment


          • #6
            Pushing a topic because only some hours without answer is really annoying!

            What commandline did you use to compile?
            Which version of Java Mysql Library did you use?

            Daniel

            Comment


            • #7
              Sorry didn't mean to offend anyone, I just unfortunately am being pushed to finish this installation.

              Command line used was same in documentation:
              ant -Dlibpath=/opt/open-xchange/lib -Dextlibpath=/opt/open-xchange/lib -Dlib.dir=/opt/open-xchange/lib install

              Java MySQL library = mysql-connector-java-3.1.14-bin.jar

              I changed the name to match in the build file.

              Comment


              • #8
                Originally posted by ap5000 View Post
                Sorry didn't mean to offend anyone, I just unfortunately am being pushed to finish this installation.

                Command line used was same in documentation:
                ant -Dlibpath=/opt/open-xchange/lib -Dextlibpath=/opt/open-xchange/lib -Dlib.dir=/opt/open-xchange/lib install

                Java MySQL library = mysql-connector-java-3.1.14-bin.jar

                I changed the name to match in the build file.
                no problem ap5000.

                you need all the libs again when you build the admindaemon. so the easiest day is to copy all the libs again into the admindaemon/lib dir. but this time you also need the ox_server.jar. this jar was made when you compiled the open-xchange server (your first posting) and this jar should be in /opt/open-xchange/lib (and it should also be in /tmp/open-xchange/lib) but only if you have successfully compiled the open-xchange server. to keep it short: compiling open-xchange server with "ant install" makes this jar and this ox_server.jar is the full server.
                so, the admindaemon needs this jar because he needs core elements from the server.

                hope this works for you but this stuff can also be found in the wiki installation document
                Last edited by Ben Pahne; 03-05-2007, 11:21 PM.

                Comment


                • #9
                  Same error

                  Thanks for trying to help I do appreciate it. Unfortunately the steps you mentioned lead to the same error I posted above. And yes I did include those extra jar files you where talking about that were created from the first install. Is it possible that it does not like the version of mysql-connector I am using?

                  Comment


                  • #10
                    hmm, no because "class OXFolderAction" is one of ours. i have to check this tomorrow at the office.

                    Comment


                    • #11
                      same problem

                      i had the same problem.

                      the com.openexchange.tools.oxfolder.OXFolderAction failed.
                      there is no class in ox_server.jar

                      Comment


                      • #12
                        Hi

                        File is empty in cvs revision 1.2

                        # ls -al src/com/openexchange/tools/oxfolder/OXFolderAction.java
                        -rw-r--r-- 1 root root 0 5. Mär 12:37 src/com/openexchange/tools/oxfolder/OXFolderAction.java

                        David

                        Comment


                        • #13
                          OK, problem fixed. We had a bug in the CVS merge script but this is fixed now and the CVS should be up-to-date. Just get the new admindaemon and try again.

                          Comment


                          • #14
                            problem persist

                            Hello

                            Just now I download from cvs Ox_admin and have de same problem above


                            Thanks

                            Comment


                            • #15
                              open-xchange-admin start failure

                              ok...the build of open-xchange-admin ist o.k.

                              But in the next step, i have following failure at start of open-xchange-admin

                              #:/etc/init.d/open-xchange-admin start
                              Starting Open-Xchange Admin Daemon: start-stop-daemon:
                              unrecognized option `--background'

                              Try `start-stop-daemon --help' for more information.

                              Any ideas ?
                              Last edited by Marky_bln; 03-06-2007, 04:28 PM.

                              Comment

                              Working...
                              X