No announcement yet.

Problem creating users after installation

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem creating users after installation

    Hello everyone,
    Could someone help me with the problem I face?
    When I try to create test user, or change user password (admin) I face this kind of the output. What is the problem?Any suggestions how I should fix it?
    I use Debian 7.
    Authentication failed
    at com.openexchange.admin.rmi.impl.BasicAuthenticator .doAuthentication(
    at com.openexchange.admin.rmi.impl.OXUser.getModuleAc cess(
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
    at java.lang.reflect.Method.invoke(
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe
    at sun.rmi.transport.Transport$ 77)
    at Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:173)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl
    at java.util.concurrent.ThreadPoolExecutor.runWorker(
    at java.util.concurrent.ThreadPoolExecutor$ (
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str
    at sun.rmi.server.UnicastRef.invoke( 60)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod( 194)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(
    at sun.proxy.$Proxy0.getModuleAccess(Unknown Source)
    at monfunctions(
    at com.openexchange.admin.console.user.Change.execute (
    at com.openexchange.admin.console.user.Change.main(Ch

  • #2
    same error here

    Same error here..

    [root@ip-172-31-7-114 ~]# /opt/open-xchange/sbin/createcontext -A oxadminmaster -P my_password -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p secret -L defaultcontext -e -q 1024 --access-combination-name=all
    context 1 could not be created: 
    Server response:
     The new context could not be created. All not full databases can not be connected to.
    	at com.openexchange.admin.rmi.impl.OXContextCommonImpl.createcommon(
    	at com.openexchange.admin.rmi.impl.OXContext.create(
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    	at java.lang.reflect.Method.invoke(
    	at sun.rmi.server.UnicastServerRef.dispatch(
    	at sun.rmi.transport.Transport$
    	at Method)
    	at sun.rmi.transport.Transport.serviceCall(
    	at sun.rmi.transport.tcp.TCPTransport.handleMessages(
    	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(
    	at sun.rmi.transport.tcp.TCPTransport$
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(
    	at java.util.concurrent.ThreadPoolExecutor$
    	at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(
    	at sun.rmi.transport.StreamRemoteCall.executeCall(
    	at sun.rmi.server.UnicastRef.invoke(
    	at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(
    	at java.rmi.server.RemoteObjectInvocationHandler.invoke(
    	at sun.proxy.$Proxy0.create(Unknown Source)
    	at com.openexchange.admin.console.context.Create.maincall(
    	at com.openexchange.admin.console.context.CreateCore.commonfunctions(
    	at com.openexchange.admin.console.context.Create.<init>(
    	at com.openexchange.admin.console.context.Create.main(
    [root@ip-172-31-7-114 ~]#
    but no help..


    • #3
      I dont know if this will fix your problem but when i installed for the 1st time OX 6.22 i followed the debian guide in the oxpedia but if you are using Debian Wheezy you must change the deb rep to match your version. and NOT USE the Squeeze ones the guide tell you to.

      I have installed the OX just as the guide says (step by step) and works "as intended" (well i am having other troubles but i think they are because of missconfiguration in my imap i am still investigating)

      Sorry for my bad english, my natal tongue is spanish