Announcement

Collapse
No announcement yet.

java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462

    Hi...
    My hardw/softw spec:
    AMD Opteron Server 2 GB RAM
    OS: Debian Sarge 3.1 x86_64
    SMTP Server: netqmail-1.0.5
    IMAP Server: Dovecot1.0rc4

    I can compile OX successfully, But while run oxinstaller, I get:

    # /opt/open-xchange/sbin/oxinstaller --oxdb-pass=secret --admin-pass=secret --maildomain example.com -f
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    setting AUTO_TO_LOWERCASE_UID in /opt/open-xchange/etc/admindaemon/User.properties
    (Re)Starting Admin Daemon
    done
    initializing database (step 2/2)
    done
    setting up the system
    creating certificates
    certificate created
    configuring mail system
    using example.domain.com as FQHN of the mail server
    Server response:
    Unable to write configuration
    done

    "Unable to write configuration" -> What's my fail?
    I've googling and get:
    http://www.open-xchange.com/forum/ar....php/t-45.html
    but still don't have any idea to solve it.

    I checked /var/log/open-xchange/open-xchange-admin.log.0 and get these:
    ...
    INFO: OX init starting...
    Oct 30, 2007 7:04:14 AM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
    SEVERE: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
    Oct 30, 2007 7:04:14 AM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager <init>
    SEVERE: Failure, lateral instance will use zombie service
    java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462
    at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPSender.init(LateralTCPSender.java:141)
    ...

    Thank you very much for any help.

  • #2
    I try to ignore above error messages and continue my OX installation.
    Everything looks OK and I am still on testing my new OX now.

    Just wondering above error messages. What's fail?
    Is it because I use IMAP/SMTP server other than Cyrus/Courier/Postfix?
    I think OX try to write to some configuration files that in Dovecot/Qmail does't exist.
    Is it safe if I ignore the error messages?

    BTW: Are there any user guide/manual using OX Hyperion?

    Thank you.

    Comment


    • #3
      Hi,

      Port 57462 is used as a TCP listener for the Java Caching System which is used in hosting environments to set up HA and clustered systems. This does not influence anything else afaik and you can ignore it safely.

      "Unable to write configuration" seems to be thrown by the SMTP server configuration. If you already have a working mail system you may also ignore this.

      Comment


      • #4
        My acoount user001 d'ont work so im login with user002

        I can't login admin gui ox6 oxadmin and pass secret

        i' am install all without fails from Mr. Braun and all other packaged from ox cvs.


        1 drwxr-xr-x 13 root root 512 Oct 29 09:33 open-xchange
        1 drwxr-xr-x 13 root root 480 Oct 28 21:15 open-xchange-admin
        0 drwxr-xr-x 11 root root 360 Oct 28 21:15 open-xchange-admin-console-ee
        0 drwxr-xr-x 11 root root 376 Oct 29 22:52 open-xchange-admin-gui-ee
        1 drwxr-xr-x 12 root root 784 Oct 28 11:10 open-xchange-admin-gui-ee-ajax
        0 drwxr-xr-x 5 root root 192 Oct 28 11:04 open-xchange-admin-gui-ee-templates
        0 drwxr-xr-x 10 root root 360 Oct 29 22:50 open-xchange-admin-plugin-backup
        0 drwxr-xr-x 11 root root 384 Oct 28 21:15 open-xchange-admin-plugin-ca_mgmt_simple
        0 drwxr-xr-x 13 root root 440 Oct 28 21:15 open-xchange-admin-plugin-context_light
        0 drwxr-xr-x 9 root root 336 Oct 28 21:15 open-xchange-admin-plugin-imap
        0 drwxr-xr-x 11 root root 384 Oct 28 21:15 open-xchange-admin-plugin-mail
        0 drwxr-xr-x 12 root root 408 Oct 28 21:15 open-xchange-admin-plugin-mailfilter
        0 drwxr-xr-x 12 root root 384 Oct 29 22:49 open-xchange-admin-plugin-osconfig
        0 drwxr-xr-x 9 root root 336 Oct 29 22:49 open-xchange-admin-plugin-services
        0 drwxr-xr-x 10 root root 360 Oct 29 22:47 open-xchange-admin-plugin-sw-update
        3 drwxr-xr-x 16 root root 2680 Oct 28 21:57 open-xchange-gui

        after changed the ox.conf
        restart apache2
        /etc/init.d/open-xchange-admin stop & start

        ox.conf from apache2 changed

        JkWorkersFile /etc/libapache-mod-jk/workers.properties
        JkLogFile /var/log/apache2/mod_jk.log
        JkLogLevel error
        JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
        JkRequestLogFormat "%w %V %T"
        JkMount /ajax/* ajp13_worker
        JkMount /servlet/* ajp13_worker
        JkMount /infostore ajp13_worker
        JkMount /infostore/ ajp13_worker
        JkMount /infostore/* ajp13_worker
        JkMount /oxadmin/* ajp13_worker
        JkMount /oxadmin ajp13_worker
        JkOptions +ForwardURICompatUnparsed


        So now can login successfull
        I don't have Error.


        Oct 30, 2007 12:51:29 PM com.openexchange.admin.tools.AdminCache initOXProccess
        INFO: ...OX init done!
        Oct 30, 2007 12:51:29 PM com.openexchange.admin.tools.AdminCache initCache
        INFO: Init Cache
        Oct 30, 2007 12:51:29 PM com.openexchange.admin.daemons.AdminDaemon initCache
        INFO: Cache and Pools initialized!
        Oct 30, 2007 12:51:29 PM com.openexchange.admin.daemons.AdminDaemon$LocalSe rverFactory createServerSocket
        INFO: Admindaemon will listen on localhost!
        Oct 30, 2007 12:51:29 PM com.openexchange.admin.rmi.impl.OXUser <init>
        INFO: Class loaded: com.openexchange.admin.rmi.impl.OXUser
        Oct 30, 2007 12:51:30 PM com.openexchange.admin.rmi.impl.OXGroup <init>
        INFO: Class loaded: com.openexchange.admin.rmi.impl.OXGroup
        Oct 30, 2007 12:51:30 PM com.openexchange.admin.rmi.impl.OXResource <init>
        INFO: Class loaded: com.openexchange.admin.rmi.impl.OXResource
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.rmi.impl.OXLogin <init>
        INFO: Class loaded: com.openexchange.admin.rmi.impl.OXLogin
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.Activator start
        INFO: Version: 6.5.0
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.Activator start
        INFO: Name: open-xchange-admin
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.Activator start
        INFO: Build: 0
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.Activator start
        INFO: Admindaemon successfully started.
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
        INFO: open_xchange_admin changed to 2
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
        INFO: open_xchange_admin_plugin_ca_mgmt_simple changed to 2
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.tools.AdminCache initOXProccess
        INFO: OX init starting...
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.tools.AdminCache initOXProccess
        INFO: ...OX init done!
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.tools.AdminCache initCache
        INFO: Init Cache
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.PluginStarter initCache
        INFO: Cache and Pools initialized!
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.PluginStarter start
        INFO: Context-Light started!
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
        INFO: open_xchange_admin_plugin_context_light changed to 2
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.Activator$2 serviceChanged
        INFO: Service: open_xchange_admin_plugin_imap, 1
        Oct 30, 2007 12:51:31 PM com.openexchange.admin.daemons.Activator$2 serviceChanged
        INFO: open_xchange_admin_plugin_imap registered service
        Last edited by user002; 10-31-2007, 10:13 AM.

        Comment

        Working...
        X