No announcement yet.

Few theming questions

  • Filter
  • Time
  • Show
Clear All
new posts

  • Few theming questions

    I'm currently running Open-Xchange community edition and I'm trying to change the theme. Unfortunately there were three things I couldn't accomplish and was hoping someone here could point me in the right direction.
    • I'm unable to change the color of the folder-counter (the count for unread messages). Tried to change colours in the definition.less and style.less file and even tried to change the css themselves, without any luck.
    • Changing the appointment color for reserved (appointment-reserved), only changes the bold bar on the left of the appointment, not the lighter and hover colour.
    • I'm unable to change the front / login-page, the wiki seems not complete or not up-to-date, cause it wouldn't load any other theme than the login.

  • #2
    I'm no UI expert for the first two items.

    Can you explain what you tried for the third to identify where the documentation lacks clarity or completeness?


    • #3
      What I tried is more or less what this page suggests.

      I created a directory specifically for the login page, /opt/open-xchange/appsuite/app/themes/customlogin.
      In this loginpage directory, I copied the login.less from the /opt/open-xchange/appsuite/app/themes/login folder.
      I renamed the login.less to style.less an I also copied a definations.less file to this folder.

      I made some changes to the color on the style.less page, especially for the wallpaper.

      Than I ran the

      I edit the as-config.yml as follows.
      # Override certain settings
          host: all
          signinTheme: customlogin
      # Override certain settings for certain hosts
      #    host: myexchange.myhost.mytld
      #    someConfig: some overriding value
      No sure if necessary, but I restarted the open-xchange service.

      After this I went to the webpage and unfortunately still the default login page is displayed.


      • #4
        Since I don't see an edit button, I fixed it by running the following command on the server: