Announcement

Collapse
No announcement yet.

New clean install, new errors :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New clean install, new errors :(

    A complete clean new install, step by step to wiki and now this:

    Code:
    root@wullbrandtundseele:/tmp/open-xchange-admin# /opt/open-xchange/sbin/oxinstaller --oxdb-pas
    s=mypass --admin-pass=mypass --maildomain wullbrandtundseele.de
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon
    done
    initializing database (step 2/2)
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    done
    setting up the system
    creating certificates
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    chmod: Zugriff auf â/etc/ssl/certs/eecert.pemâ nicht möglich: No such file or directory
    chmod: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
    chgrp: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
    done

  • #2
    Originally posted by altariq View Post
    A complete clean new install, step by step to wiki and now this:

    Code:
    root@wullbrandtundseele:/tmp/open-xchange-admin# /opt/open-xchange/sbin/oxinstaller --oxdb-pas
    s=mypass --admin-pass=mypass --maildomain wullbrandtundseele.de
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    initializing database (step 1/2)
    done
    Have a look in the wiki, i added a note yesterday about mysql auth:

    IV.3. Open-Xchange Database

    ... Adjust your MySQL authentification information (OXDB_USER_*) in /opt/open-xchange/sbin/oxinstaller and execute: ....

    Comment


    • #3
      The first error with mysql isn´t that bad.

      You must configure first after basic OX installments:
      1. sasl
      2. cyrus

      THEN, all steps have finished just perform this

      /opt/open-xchange/sbin/oxinstaller --oxdb-pass=....
      Of course it reporst first a mysql error, you can ignore safely.

      If you want be sure it is working, force reinstall of usernames/passwords with

      /opt/open-xchange/sbin/oxinstaller --oxdb-pass=....-f
      HTH

      Bei mir hat es so immer geklappt

      Nochmal auf deutsch, erst alles konfigurieren, danach oxinstaller ausführen.
      MySQL Fehler kannst ignorieren oder mit der Option '-f' erneut durchführen. Es wird definitiv keine Fehlermeldung erscheinen bei -f wenn alles korrekt eingerichtet wurde... es sei denn die Jungs haben die Sourcen wieder umgeschmissen im laufe des Vormittags
      Last edited by sledge0303; 03-30-2007, 11:42 AM.

      Comment


      • #4
        Also soll ich zuerst die Mailserverconfig durchführen?
        Dann währe es doch schön, wenn es im Wiki auch so angeordnet ist. Ich trau mich nicht, darin rumzueditieren sonst siehts nachher blöd aus.
        Das, was spiekey geschrieben hat, versteh ich irgendwie überhaupt nicht...

        Comment


        • #5
          Ich versteh schon was er meint, versuche aber zuerst die Basispakete zu installieren, danach fängst an mit dem sasl und danach Cyrus, genauso wie es im Wiki beschrieben ist.
          Mal eine andere Frage, welches OS benutzt du? Etch?

          Bei Etch musste erstmal das durchführen

          nano /etc/default/saslauthd
          START=yes
          /etc/init.d/saslauthd start
          Damit hast schon mal eine Fehlerquelle ausgeräumt.

          Danach installierst komplett die Basispakete incl. Docroot incl. Webdaemon.

          danach in Schritten:

          /etc/init.d/open-xchange-admin start
          /etc/imapd.conf
          /etc/init.d/cyrus2.2 restart
          /etc/pam.d/imap
          /etc/libnss-mysql.cfg
          /etc/libnss-mysql-root.cfg
          /etc/init.d/saslauthd restart
          /etc/init.d/cyrus2.2 restart
          /opt/open-xchange/sbin/oxinstaller.... [-f]
          /etc/init.d/open-xchange-groupware start

          Danach dürftest dich mit 'oxadmin' einloggen können.

          Ich kann es momentan nicht, weil irgendetwas bei der Config des Ligties fehlt...
          Muss mir den Fall heute nochmal genau ansehen.
          Das Wiki kannst als Howto nicht nehmen, du musst zuerst durchlesen was gemacht werden muss und danach die Schritte einplanen. Wichtig ist auch die Ausgaben während der Installation von Basispaketen zu beobachten, da kannst auch ersehen wo was klemmen könnte später
          Last edited by sledge0303; 03-30-2007, 12:00 PM.

          Comment


          • #6
            Hab ich jetzt gemacht. Bei installer kommen trotzdem diese Medlungen:
            Ich hoffe, dass die nicht relevant sind.

            Code:
            (Re)Starting Admin Daemon
            done
            initializing database (step 2/2)
            Error:
             Connection refused to host: 82.165.97.31; nested exception is:
                    java.net.ConnectException: Connection refused
            Error:
             Connection refused to host: 82.165.97.31; nested exception is:
                    java.net.ConnectException: Connection refused
            Error:
             Connection refused to host: 82.165.97.31; nested exception is:
                    java.net.ConnectException: Connection refused
            done
            setting up the system
            creating certificates
            Error:
             Connection refused to host: 82.165.97.31; nested exception is:
                    java.net.ConnectException: Connection refused
            chmod: Zugriff auf â/etc/ssl/certs/eecert.pemâ nicht möglich: No such file or directory
            chmod: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
            chgrp: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
            done

            Comment


            • #7
              Anmelden geht auch nicht. Was mich schon bei meiner letzten Installation gewundert hat ist das hier:

              Build: 0, 2007-03-30 12:48:01

              im Anmeldefenster.

              Der will auf var/www/ajax/ox.html zugreifen und die gibt es nicht.
              Ich glaub ich verpass mir selbst Urlaub ...

              Comment


              • #8
                Hallo,

                kann sein, dass die concurrent.jar nicht in Ordnung ist...
                Versuch es mal mit der im Anhang (.zip in .jar umbennen).

                Einfach nach /opt/open-xchange/lib/ kopieren und die bestehende überschreiben (bzw. vorher ne sicherungskopie machen)

                Danach noch mal oxinstall versuchen...

                Viele Grüße
                Axel
                Attached Files
                Last edited by robotronick; 03-30-2007, 03:18 PM.

                Comment


                • #9
                  nach vielen Versuchen haben wir es doch rausbekommen. Es war eigentlich nur eine falsche Namensauflösung in der /etc/hosts
                  Jetzt klappt es

                  Comment


                  • #10
                    Was genau hast du geändert? Ich hänge hier am gleichen Problem.

                    Gruß

                    Martin

                    -- bei mir war es die concurrent.jar --
                    Last edited by RockHound; 04-26-2007, 02:21 PM.

                    Comment


                    • #11
                      Der Fehler ist aufgetreten, weil ich irgendwann während der Installation den Hostnamen des Rechner geändert habe, dieses aber nicht in der etc/host geändert habe. Bei irgendeinem Teil der Installation musste der Name aber richtig aufgelöst werden. Warum genau, kann ich aber auch nicht sagen.

                      Comment


                      • #12
                        Hi,

                        I am struggling with the same problem.
                        Can someone explain me shortly in english ?

                        Thanks

                        Comment


                        • #13
                          It's because the hostname changed during the installation and can't be resolved now. You have to change/check it in the /etc/host file.

                          Comment


                          • #14
                            Same error, /etc/hosts not to blame

                            Hi,

                            I downloaded the sources from cvs yesterday (23rd May) and have been following the wiki installation process - on Fedora Core 6.

                            Got the same error as above, which appears to be occuring inside execution of:

                            Code:
                            /opt/open-xchange/sbin/allpluginsloaded
                            which is in turn executing the line:

                            Code:
                            /usr/bin/java -classpath /opt/open-xchange/lib/ox_admin_console_ee.jar:/opt/open-xchange/lib/ox_admindaemon.jar:/opt/open-xchange/lib/ox_admin_plugin_ca_mgmt_simple.jar:/opt/open-xchange/lib/ox_admin_plugin_context_light.jar:/opt/open-xchange/lib/ox_admin_plugin_imap.jar:/opt/open-xchange/lib/ox_admin_plugin_mailfilter.jar:/opt/open-xchange/lib/ox_admin_plugin_mail.jar: com.openexchange.admin.console.admincore.AllPluginsLoaded
                            I scoured the forum for hints, but can't see anything beyond this clue regarding the hosts file.

                            Which service is "com.openexchange.admin.console.admincore.AllPlugi nsLoaded" trying to communicate with? The mysql server, the apache server, or something else? I'm guessing this might be a port misconfig issue.

                            Note that as user root, I can type "mysql" to get straight into the local mysql client (no auth required). Also, I'm running all the above OX installation steps as user root.

                            Mystified!

                            Comment


                            • #15
                              I suppose this step checks communication with all sub-systems. Someone noted on the discussion page for the installation description, that you have to do the mailserver setup before the oxinstall. Maybe setting up cyrus and postfix according to the wiki before running the script helps?

                              Comment

                              Working...
                              X