Announcement

Collapse
No announcement yet.

can't connect to config-db

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • can't connect to config-db

    Hi,

    I have a problem while trying to install ox.

    If I start the oxinstaller-script, i will get an exception: Can't connect to config db... But the config-db was created successful and is reachable by the provided user and password. So do anybody have an idea what's going wrong?

    Here a cutout of the oxinstaller output:

    ---
    initializing database (step 2/2)
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Can't get connection to config DB. exceptionID=843910239-4
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Can't get connection to config DB. exceptionID=843910239-5
    Exception in thread "main" java.lang.NullPointerException
    at com.openexchange.admin.storage.mysqlStorage.OXMail ServerMySQLStorage.addMailDomain(OXMailServerMySQL Storage.java:104)
    at com.openexchange.admin.rmi.impl.OXMailServerImpl.a ddMailDomain(OXMailServerImpl.java:299)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:466)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:707)
    at java.lang.Thread.run(Thread.java:595)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:247)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:223)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 26)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 179)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:132)
    at $Proxy0.addMailDomain(Unknown Source)
    at com.openexchange.admin.console.maildomain.Add.<ini t>(Add.java:104)
    at com.openexchange.admin.console.maildomain.Add.main (Add.java:152)
    done
    ---

    Please tell me, if you need any more informations.

    Thank you,
    Axel

  • #2
    http://www.open-xchange.com/forum/sh...93&postcount=5

    Comment


    • #3
      Hi,

      i don't get an "connection refused". I get "can't connect to config db"... I think, there are different causes.

      Comment


      • #4
        Might be that the configdb.properties are somewhat out of order. Could you try this:

        http://www.open-xchange.com/wiki/ind...atabase_access

        Comment


        • #5
          Sorry for the delay...

          I was try to connect to the configdb with the params of the configdb.properties -> It works, but there is no application database present...

          Code:
          mysql> select * from db_pool;
          Empty set (0.00 sec)
          Thanks a lot,
          Axel

          Comment


          • #6
            Okay, I have the same thing here. A bit different output though:
            Code:
            initializing database (step 2/2)
            Server response:
             com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=11680494-5
            Server response:
             com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=11680494-6
            Server response:
             com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=11680494-8
            done
            setting up the system
            creating certificates
            Server response:
             com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=11680494-10
            chmod: cannot access `/etc/ssl/certs/eecert.pem': No such file or directory
            chmod: cannot access `/etc/ssl/private/eekey.pem': No such file or directory
            chgrp: cannot access `/etc/ssl/private/eekey.pem': No such file or directory
            configuring ox admin gui
            configuring mail system
            using mail.example.com as FQHN of the mail server
            Server response:
             com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=11680494-12
            done
            The connection to the database works great via commandline. The params in both configdb.properties files are fine.

            Any more ideas?

            Regards,

            Martin

            Comment


            • #7
              I should read the forum before I reply. My problem was a different name for 'mysql-connector-java-3.1.13-bin.jar' ...

              Comment

              Working...
              X