Announcement

Collapse
No announcement yet.

Kann mich nicht anmelden

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kann mich nicht anmelden

    Hallo,

    ich habe mir gerade nach folgender Anleitung OpenXChange installiert.
    ´http://www.open-xchange.com/wiki/ind...ion_Ubuntu8.04

    Die Installation lief auch sehr reibungslos ab. Vielen Dank schon mal für die neuen Pakete.
    Ich komme auch auf das login-interface. Wenn ich mich dort jedoch mit Benutzername und Passwort anmdelen will, kommt jedesmal, dass das Passwort nicht stimmt. Das kann jedoch nicht sein. Selbst als oxadmin, wo ich das Passwort beim erstellen neuer Benutzer mit abgeben muss (was funktioniert) lehnt er das passwort ab.

    Ich hoffe mir kann vielleicht jemand helfen.

    Danke

  • #2
    Hello Schlaubi,

    please, post logs.... It could be everything. starting from no account, to wrong-typed password, no process accepting a log-in, no mailbox listening for logins....... and so on.
    So - to cite a famous phrase - my crystal ball tells me that it must be the webserver

    CU
    Popeye

    Comment


    • #3
      Wie soll man denn Logs posten, wenn man nicht reinkommt, um diese zu sichten?

      Comment


      • #4
        Logs:

        /var/log/open-xchange/open-xchange.log.*

        Comment


        • #5
          Ich benutze VMware,

          und habe das gleiche Problem. Ich kann ja nicht in die log-Dateien einsehen. Falsche Schreibweise scheidet definitiv aus.
          Vllt kennt ja doch einer die Lösung.

          Mit freundlichen Grüßen

          Holger

          Comment


          • #6
            Hallo,

            man sieht die Log-Files nicht im OX-Webinterface, sondern indem man sich am Linux-Prompt anmeldet und z. B. mit 'less +F /var/log/open-xchange/open-xchange.log.0'.

            Wenn die Installation ansonsten reibungslos verlaufen ist, wie sieht denn die Hardwareausstattung des Servers bzw. der VM aus? 512 MB sind Mindestvoraussetzung, ansonsten startet die Groupware nicht.

            Grz
            Rene
            Viele Grüße
            Rene

            OS: Ubuntu Server amd64 16.4 LTS
            JRE: openjdk-8-jre, MySQL 5.7, Apache 2.4, Dovecot 2.2.22
            OX-Server backend: OXSE latest
            OX-frontend: OXSE latest appsuite + ox6

            Comment


            • #7
              Hi

              I ran into the same issue, I think.
              I am using an ubuntu 8.04 desktop VM, 1,5 G memory.
              I used that article :
              http://www.open-xchange.com/wiki/ind...ion_Ubuntu8.04
              Great work by the way...

              It worked until:
              Code:
              $ sudo /opt/open-xchange/sbin/createcontext -A oxadminmaster -P secret -c 1 \
              -u oxadmin -d "Context Admin" -g Admin -s User -p secret -L defaultcontext \
              -e oxadmin@example.com -q 1024 --access-combination-name=all
              This just gives back:
              Code:
              context 1 could not be created: 
              Server response:
               Authentication failed
              Log files are attached, I expect this to be the interesting lines:
              Code:
              Sep 3, 2008 6:25:22 PM com.openexchange.admin.rmi.impl.BasicAuthenticator doAuthentication
              SEVERE: Master authentication for user: oxadminmaster
              com.openexchange.admin.rmi.exceptions.InvalidCredentialsException: Authentication failed
              	at com.openexchange.admin.rmi.impl.BasicAuthenticator.doAuthentication(BasicAuthenticator.java:95)
              	at com.openexchange.admin.rmi.impl.OXContext.create(OXContext.java:188)
              	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              	at java.lang.reflect.Method.invoke(Method.java:585)
              	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
              	at sun.rmi.transport.Transport$1.run(Transport.java:153)
              	at java.security.AccessController.doPrivileged(Native Method)
              	at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
              	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
              	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
              	at java.lang.Thread.run(Thread.java:595)

              I assumed some typo on my way and tried:

              Code:
              user@ubuntu8041:~$ sudo /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=db_password \
              > --master-pass=admin_master_password
              setting up groupware configuration /opt/open-xchange/etc/groupware
              ................................................
              groupware daemon must now be restarted if already running
              setting up admin daemon configuration /opt/open-xchange/etc/admindaemon
              ......................
              *** RMI authentication is enabled
              using oxadminmaster as master account
              admin daemon must now be restarted if already running
              user@ubuntu8041:~$ sudo /etc/init.d/open-xchange-admin restart
              Restarting Open-Xchange Admin Daemon: open-xchange-admin.
              user@ubuntu8041:~$ sudo /opt/open-xchange/sbin/createcontext -A oxadminmaster -P secret -c 1 \
              > -u oxadmin -d "Context Admin" -g Admin -s User -p secret -L defaultcontext \
              > -e oxadmin@example.com -q 1024 --access-combination-name=all
              context 1 could not be created: 
              Server response:
               Authentication failed
              The createcontext command is the first that does not accept the identification. Unfortunately, I was not able to find a man page or similar documentation.

              Any ideas?

              Regards
              Michael


              EDIT:
              After finding the documentation for createcontext it became clear that the description contains a small issue: the password for oxadminmaster is admin_master_password (not secret) in the examples, therefore the statement should look like this:

              sudo /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 \
              -u oxadmin -d "Context Admin" -g Admin -s User -p secret -L defaultcontext \
              -e oxadmin@example.com -q 1024 --access-combination-name=all

              This works as expected. I changed the description in the Wiki article mentioned above.

              Regards
              Michael
              Attached Files
              Last edited by micmic; 09-03-2008, 10:18 PM. Reason: Got it

              Comment

              Working...
              X