Announcement

Collapse
No announcement yet.

secure imap configuration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • secure imap configuration

    hi,

    I want to use the google mail service wich provides a secure imap/smtp connection. This post http://gentoo-wiki.com/HOWTO_Open-Xc...TLS-encryption has some hints which properties have to be set. Now I have to add the certificate to a keystore to be trusted by OX6. Does OX6 has a predefined keystore file or do I have to add it by standard system properties?
    Is there a good documentation about this topic?

    thanks
    masc
    Last edited by masc; 09-20-2008, 08:34 AM.

  • #2
    The Gentto documentation is related to the communication of the different Open-Xchange components in Open-Xchange Server 5.

    1) Are you really using Open-Xchange Server 5?
    2) Do you want to simply fetch emails from Google Mail with fetchmail or what do you want to do?

    Regards,
    Daniel

    Comment


    • #3
      thanks daniel,

      I am absolute new in openxchange but in the mean time I found the OX6 Installation and Administration document which helped me a little bit.

      To answer your questions:
      1) No, I am using OX6, I installed it as described for the debian environement with no problems
      2) Yes, I want to fetch and transport emails through the google mail service.

      After reading a while through the docs and playing around with some properties I am able to fetch emails and folders and do folder operations like create, delete and move messages but not to send emails.

      The open-xchange.log.0 gives me the following stacktrace:

      WARNING: Missing transport server URL. Transport server URL not set for user 3 in context 1. Using fallback protocol smtp
      Sep 23, 2008 11:48:19 AM com.openexchange.mail.transport.TransportProviderR egistry getTransportProviderBySession
      WARNING: Missing transport server URL. Transport server URL not set for user 3 in context 1. Using fallback protocol smtp
      Sep 23, 2008 11:48:19 AM com.openexchange.ajax.Mail action
      SEVERE: MSG-0005 Category=10 Message=Configuration error: Cannot determine mail server URL for user 3 in context 1 exceptionID=1582142373-3
      MSG-0005 Category=10 Message=Configuration error: Cannot determine mail server URL for user 3 in context 1 exceptionID=1582142373-3
      at com.openexchange.mail.transport.config.TransportCo nfig.getTransportConfig(TransportConfig.java:111)
      at com.openexchange.smtp.SMTPTransport.getTransportCo nfig(SMTPTransport.java:245)
      at com.openexchange.smtp.SMTPTransport.getSMTPSession (SMTPTransport.java:207)
      at com.openexchange.smtp.SMTPTransport.sendMailMessag e(SMTPTransport.java:416)
      at com.openexchange.mail.transport.MailTransport.send MailMessage(MailTransport.java:142)
      at com.openexchange.mail.MailServletInterfaceImpl.sen dMessage(MailServletInterfaceImpl.java:940)
      at com.openexchange.ajax.Mail.action(Mail.java:3126)
      at com.openexchange.ajax.AJAXServlet.fireUploadEvent( AJAXServlet.java:702)
      at com.openexchange.ajax.Mail.doPost(Mail.java:3026)
      at javax.servlet.http.HttpServlet.service(HttpServlet .java:616)
      at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:376)
      at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:157)
      at com.openexchange.ajax.PermissionServlet.service(Pe rmissionServlet.java:98)
      at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
      at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:120)
      at com.openexchange.ajp13.AJPv13RequestHandler.create Response(AJPv13RequestHandler.java:466)
      at com.openexchange.ajp13.AJPv13Connection.createResp onse(AJPv13Connection.java:197)
      at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Li stener.java:259)
      at java.lang.Thread.run(Thread.java:595)


      Here are (hopefully all necessary) settings I've done:

      javamail.properties
      mail.smtp.socketFactory.class=com.openexchange.too ls.ssl.TrustAllSSLSocketFactory
      mail.smtp.starttls.enable=true

      mail.imap.socketFactory.class=com.openexchange.too ls.ssl.TrustAllSSLSocketFactory
      mail.imap.starttls.enable=true


      mail.properties
      com.openexchange.mail.loginType=config
      com.openexchange.mail.credSrc=user.imapLogin
      com.openexchange.mail.mailServer=imap://imap.gmail.com:993
      com.openexchange.mail.transportServer=smtp://smtp.gmail.com:465


      It seems that the transportServer property is not active.
      Any ideas?

      thanks
      masc
      Last edited by masc; 09-23-2008, 01:12 PM.

      Comment


      • #4
        Hi masc,

        javamail.properties is unrelated to this topic, it's more a internal config file and should not be touched in 99,999% of all cases.

        mail.properties contains some global settings that are used as fallback - but by default the users E-Mail configuration at the database is used (set by com.openexchange.mail.credSrc=user.imapLogin). To set a imaps/smtps server for a user, please use the create/changeuser command line tools and set:
        --imapserver imaps://imap.gmail.com/
        --smtpserver smtps://smtp.gmail.com/
        --imaplogin gmail-login-name

        Greetings

        Comment


        • #5
          martin,

          this simple solution works perfectly.
          thanks for your quick info.

          masc

          Comment


          • #6
            Hi guys. I think i'm trying to do something similar to Martin here had. The previous solution however doesn't say how to pass on full credentials to gmail. I can't find the correct parameter for password unfortunately. Can you please help?

            Comment


            • #7
              Hi,

              the OX users password must be equal to the password of the primary mail account. In this case, it needs to be equal to your gmail password.

              Greetings

              Comment


              • #8
                Hi,
                thanks for the reply. I've already managed to figure that out. The downside of this is that you need to enter the gmail password explicitly. At least using createuser command. It's probably the same case while importing user accounts from csv file.

                There is supposedly another way to do this. There's a switch property in user.properties that i haven't seen to it yet though. Have you (anyone) tried it out? Or perhaps any other way to keep users' gmail passwords hidden?

                Comment


                • #9
                  Hi,

                  what exactly is the problem here? OX stores your password using a SHA1 hash, it's not "visible" at the database in any way. You could create the OX account with some default password and change it afterwards at the configuration. Thous would keep your password away from the servers console.

                  Greetings

                  Comment


                  • #10
                    That does solve the problem. I haven't thought about that. Thx for tip.

                    Comment

                    Working...
                    X