Announcement

Collapse
No announcement yet.

Which kind of installation type I should use?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which kind of installation type I should use?

    Hi,

    at the wiki Ive found many different options to install the latest OX6. There are a step-by-step howto (http://www.open-xchange.com/wiki//wi...e_Installation), a installation via installer (http://www.open-xchange.com/wiki/ind...tion_Installer) or via repository (http://www.open-xchange.com/wiki/ind...dition_Debian4) - but which should I choose?

    HeinB

  • #2
    Hi,

    what you want to use depends on your personal preferrences:

    http://www.open-xchange.com/wiki//wi...e_Installation
    Is a installation from sourcecode which is pretty complicated and could be interesting for development/research but not for productive use. This How-To describes the installation of OX 6.4 which is not the latest release.

    http://www.open-xchange.com/wiki/ind...tion_Installer
    Does the same installation process from source but more automated, since the 6.4 Release is not the latest one this should not be used anymore because 6.6 is the most current release.

    http://www.open-xchange.com/wiki/ind...dition_Debian4
    Describes a very easy installation based on packages for your linux distribution which is far better for software management and administration. Plus it does not rely on a complicated build process and it delivers the latest release (OX6.6). I'd recommend this installation if you don't want to mess up with sourcecode and just want to have the software up and running. It's also a much less error-prone installation because you won't get into troubles with compiling issues etc.

    Greetings

    Comment


    • #3
      Hello Martin,

      thanks for your fast reply. So Ive choose the installation via repository. But the howto (http://www.open-xchange.com/wiki/ind...dition_Debian4) is not complete, so I think.

      Code:
      Requirements
      
          * Plain installed Debian GNU/Linux 4.0 with latest updates
          * A configured internet connection
      this is my setup.

      And after Ive install with this command line:

      Code:
      $ apt-get install mysql-server  open-xchange-admin-client \
      open-xchange-admin-doc open-xchange-admin-plugin-hosting-doc \
      open-xchange-admin-plugin-hosting open-xchange-admin \
      open-xchange-authentication-database open-xchange-cache \
      open-xchange-charset open-xchange-common open-xchange-configjump-generic \
      open-xchange-configread open-xchange-control open-xchange-data-conversion-ical4j \
      open-xchange-global open-xchange-group-managerequest open-xchange-gui \
      open-xchange-i18n open-xchange-imap open-xchange-jcharset open-xchange-mailfilter \
      open-xchange-management open-xchange-monitoring open-xchange-online-help-de \
      open-xchange-online-help-en open-xchange-online-help-fr \
      open-xchange-passwordchange-database open-xchange-passwordchange-servlet \
      open-xchange-push-udp open-xchange-resource-managerequest open-xchange-server \
      open-xchange-sessiond open-xchange-settings-extensions open-xchange-smtp \
      open-xchange-spamhandler-default open-xchange
      I dont have a Imap-Server and so on (Sieve for example) - which packages should I install for a complete OX6 server?

      HeinB

      Comment


      • #4
        The packages you commented are all packages to set up a complete OX6 Server. Open-Xchange is a Groupware, not a IMAP or SMTP Server. Use Postifx/Cyrus or any other SMTP/IMAP combination to enable E-Mail functionality.

        Greetings

        Comment


        • #5
          Don't forget the hardy heron quick install guide: http://www.open-xchange.com/wiki/ind...ion_Ubuntu8.04


          Originally posted by heinb View Post
          Hello Martin,

          thanks for your fast reply. So Ive choose the installation via repository. But the howto (http://www.open-xchange.com/wiki/ind...dition_Debian4) is not complete, so I think.

          I dont have a Imap-Server and so on (Sieve for example) - which packages should I install for a complete OX6 server?
          I reacted the same way. The community wiki installation guide as well as the community installer script for 6.4 also took care of Cyrus and Postfix installation and configuration. As the installer script was officially abandoned due to the presence of the OS-specific packages, I thought that all parts would have been installed after following the Quick installation guide.

          Originally posted by Martin Braun View Post
          The packages you commented are all packages to set up a complete OX6 Server. Open-Xchange is a Groupware, not a IMAP or SMTP Server. Use Postifx/Cyrus or any other SMTP/IMAP combination to enable E-Mail functionality.
          This explains why an SMTP/IMAP combination was not installed (big thanks for the clarification, which btw really should be added to the Quick installation wiki pages!), but doesn't help us 6.6 users to get a working groupware server running, especially since the documentation to get Cyrus/Postfix configured is for the bf_6_4_2 branch. After configuring with these wiki instructions, there are still many problems: http://www.open-xchange.com/forum/showthread.php?t=1713

          My conclusion about what installation guide is basically: Use the Community Installation guide or installer script to get a fully groupware server running, based on the 6.4.2 branch.

          To install the Groupware part through your favorite package manager, but without complete documentation on how to configure IMAP/SMTP/etc, use one the Quick installation guides...

          Comment


          • #6
            Originally posted by motin View Post
            My conclusion about what installation guide is basically: Use the Community Installation guide or installer script to get a fully groupware server running, based on the 6.4.2 branch.

            To install the Groupware part through your favorite package manager, but without complete documentation on how to configure IMAP/SMTP/etc, use one the Quick installation guides...

            I asked in another thread some weeks ago (but without answer), so again:
            why isn't it possible to modify the old installer script and either:

            remove all ox-install commands, so it's possible to install it by the package afterwards or (better):

            change the old ox download and make commands against the apt-get's of the new version
            so you get a complete new installer script with all the postfix/cyrus/sasl stuff ...
            Last edited by frosch; 09-25-2008, 10:12 AM.

            Comment


            • #7
              Originally posted by frosch View Post
              I asked in another thread some weeks ago (but without answer), so again:
              why isn't it possible to modify the old installer script and either:

              remove all ox-install commands, so it's possible to install it by the package afterwards or (better):

              change the old ox download and make commands against the apt-get's of the new version
              so you get a complete new installer script with all the postfix/cyrus/sasl stuff ...
              Exactly, that would be awesome, and I have been wondering the same thing.

              This morning I sent an e-mail to Martin Braun (hello Martin ), the original maintainer of the community installer scripts about this subject:
              Hey Martin!

              Have you considered reviving an installation script for the 6.6 series? - one that doesn't build everything from source, but still helps in configuring the required services regarding IMAP, SMTP, Sieve etc for a working groupware server?

              Currently, I haven't even found documentation of how to configure these parts together with the 6.6 version... After following the relevant parts of the 6.4 configuration guide at http://wiki.open-xchange.com/wiki/in...e_Installation (or use the community installer for these parts) we end up with many problems: http://www.open-xchange.com/forum/showthread.php?t=1713

              Do you have any light to shed in these matters regarding the 6.6 version?

              Big thanks for all the contributions you have done over time btw!

              Best regards,

              Fredrik Motin

              Comment


              • #8
                Hi,

                i received your E-Mail and i answer it here so that anybody can read it.

                The problem with installer scripts for E-Mail servers is, that every Linux distribution comes with different versions and sometimes even has a different configuration layout for those services. We also have the problem that some services that are used for the old installer are not available on some distributions that are now supported by the OX6 packages. Just for example, the pam-mysql packages is not contained in opensuse if i remember correctly, did not take a look at rhel/centos yet.

                So, at this point a script would have to compile 3rd party plugins and software for the target distribution which rises the amount of complexity. Furthermore a E-Mail server is a very critical component for personal or business communication. This requires the administrator to be able to maintain, update and fix those services if it is necessary. If we publish a script that does some configuration that a administrator does not understand or even if those settings do not fit the expectations of the administrator we will be held responsible for the E-Mail setup we create.

                I agree that a script is a very easy way to set up software, but on some point it's required that a administrator understands all backgrounds of the systems that are running. Just imagine you're driving a car and your driving teacher is doing all the stuff for you. Suddenly he disappears and you're on your own - that won't be a preferable situation especially not if it could lead to security or availability flaws. My final conclusion is: A script to setup a E-Mail environment is not wise nor preferable.

                But like i read on several postings here, there is a demand on a way to set up a E-Mail Server to work together with OX6. A brief guide to set up the services could be a good start, so we don't need any script that suggests a click&done functionality but the administrator has to learn some parts of the setup by executing a guide. I'd propose to start on a simple guide to set up the services, do basic authentication stuff and integrate this setup to OX6, i think this would help most of the users. If there is demand on a more complex setup, this needs to be done by the administrator himself because we cannot cover every single user scenario.

                Greetings

                Comment


                • #9
                  Hi,

                  i just started to write down a quick installation guide for a basic E-Mail server setup, you can check it out here: http://www.open-xchange.com/wiki/ind..._Setup_Debian4

                  You're welcome to add your feedback

                  Cheers,
                  Martin

                  Comment


                  • #10
                    Originally posted by Martin Braun View Post
                    Hi,

                    i just started to write down a quick installation guide for a basic E-Mail server setup, you can check it out here: http://www.open-xchange.com/wiki/ind..._Setup_Debian4

                    You're welcome to add your feedback

                    Cheers,
                    Martin
                    Thank you. Your installation guide will be very helpful. After a quick review, it looks like PAM has been dropped? Thus, we must, when new users are added, create the user in both OX (createuser) and in Cyrus/Postfix.

                    With regard to PAM, I think we actually have the config files working except I cannot find any documentation for the "crypt=??" code for pam_mysql to use SHA encryption for the password as OX 6.6 does.

                    We'll put the new install guide to work, but does anyone know the PAM options for SHA?

                    Comment


                    • #11
                      Hi,

                      we did use the crypt() algorithm at OX6.4 for a reason - PAM/pam-mysql does not handle SHA1 afaik

                      Greetings

                      Comment


                      • #12
                        Hi Martin
                        One direkt question.
                        When I install the OX now using the package installation, it work well.
                        Except I have no ADMIN inter face any longer?? Is this right?? At ox6/admin I get no answer anymore.

                        Second how to connect now the OX with cyrus ??
                        Is it still enoght to set the admins = oxadmin in cyrus.conf??

                        I know how to set up my mail server with cyrus, postfix and AmavisNew with out OX. But how does i get them working together?

                        Thorsten

                        Comment


                        • #13
                          On the pam_mysql page it says:

                          Sun, 18 Sep 2005
                          pam-mysql 0.6.1 and 0.7pre2 are released.
                          pam-mysql 0.6.1 and 0.7pre2 are finally released. I would thank all the people who supported the project through bug reports, suggestions, etc..

                          New features:

                          SHA1 hash support. (0.7pre2)
                          But we could not find any reference in how to use such SHA1 support.

                          If you find any reference, we would appreciate it. In the meantime, we're going to start over with the Basic Mail Setup guide you put together.

                          Thanks.

                          Comment


                          • #14
                            Download file. Unzip and tar and read the README.

                            Standing there:
                            ================================================== ====================
                            crypt (plain)

                            The method to encrypt the user's password:

                            0 (or "plain") = No encryption. Passwords stored in plaintext.
                            HIGHLY DISCOURAGED.

                            1 (or "Y") = Use crypt(3) function.

                            2 (or "mysql") = Use MySQL PASSWORD() function. It is possible
                            that the encryption function used by PAM-MySQL
                            is different from that of the MySQL server, as
                            PAM-MySQL uses the function defined in MySQL's
                            C-client API instead of using PASSWORD() SQL function
                            in the query.

                            3 (or "md5") = Use plain hex MD5.

                            4 (or "sha1") = Use plain hex SHA1.
                            ================================================== ====================

                            This will mean you have to set crypt=4 instead of crypt=1

                            Comment


                            • #15
                              Originally posted by sedeke View Post
                              Hi Martin
                              One direkt question.
                              When I install the OX now using the package installation, it work well.
                              Except I have no ADMIN inter face any longer?? Is this right?? At ox6/admin I get no answer anymore.

                              Second how to connect now the OX with cyrus ??
                              Is it still enoght to set the admins = oxadmin in cyrus.conf??

                              I know how to set up my mail server with cyrus, postfix and AmavisNew with out OX. But how does i get them working together?

                              Thorsten
                              1. There is no longer any admin gui in 6.6. This thread explains it: http://www.open-xchange.com/forum/sh...=8206#post8206

                              2. You need quite some more before authentication is done through OX database. Follow the 6.4 instructions of how to configure these, but adapt them for 6.6 (not the easiest - we have begun doing this here: http://www.open-xchange.com/forum/sh...ted=1#post8220 and here: http://www.open-xchange.com/wiki/ind...for_Ubuntu8.04 )

                              Comment

                              Working...
                              X