Announcement

Collapse
No announcement yet.

Default( and only ) language

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Default( and only ) language

    Hello,

    i just wanted to change the default language from Englisch (US) to German.

    I searched the forum, found nothing helpful and tried the following:

    -Changed the language.js file in /var/www/html/ox6/lang to:
    var all_languages = {

    "de_DE": "Deutsch"

    "":""};
    -restarted groupware service
    -cleared browser cache
    -opened open xchange webpage
    and then the page hangs on 10% with Autologin( no login fields appeared )
    -after a full restart of the server, it didnt work at all

    Does anybody know how to change the default language and/or how to do changes that only german will be available?

    Greetings

  • #2
    You forgot the comma. There's an additional empty entry in the last line, so that every real entry looks the same, with a comma at the end.

    Comment


    • #3
      Originally posted by Viktor Pracht View Post
      You forgot the comma. There's an additional empty entry in the last line, so that every real entry looks the same, with a comma at the end.
      Firstly, thanks for your answer. =)

      Well, i added the comma:

      var all_languages = {

      "de_DE": "Deutsch",

      "":""};
      With that, i can login... but the language is still English ( US ) and all the other languages are available in the GUI:

      If i change to English ( UK ), for example, i get the message that the "language will be applied after a new login" and that "the settings have been saved" and it is changed.

      There has to be an additional change somewhere... ???
      Last edited by wahnsinnn; 10-30-2008, 12:45 PM.

      Comment


      • #4
        but the language is still English ( US ) and all the other languages are available in the GUI
        ooops...

        this time, i forgot to clear browser cache...

        Ok, but the result is still not satisfying.

        I can't click on "Language and region" - its grey...

        AND although the ONLY language in languages.js is GERMAN, the GUI is in ENGLISH.
        Last edited by wahnsinnn; 10-30-2008, 01:24 PM.

        Comment


        • #5
          Are there any error messages in the JavaScript console in the browser?

          Comment


          • #6
            Originally posted by Viktor Pracht View Post
            Are there any error messages in the JavaScript console in the browser?
            Yes, there is an errror in the browser:
            Fehler(error): this.currentValues has no properties
            Quelldatei(source file): http://192.168.1.49/ox6/ox.html
            Zeile(line): 4890
            Well, i opened ox.html to have a look at line 4890, but it only has 488 lines.

            It is a little bit suspicious...
            i tried all default languages-> it worked
            i tried 2 of the languages -> it worked
            i tried 1 language -> it didn't work

            Comment


            • #7
              Ok, that was a bug. It's fixed in CVS ( will be synced to public CVS tonight), and will be available with the next release.
              In the meantime, you can fix it locally by editing the file concat_config.js: in the line containing "cs_language =" change the 1 to a 0.

              Comment


              • #8
                Originally posted by Viktor Pracht View Post
                Ok, that was a bug. It's fixed in CVS ( will be synced to public CVS tonight), and will be available with the next release.
                In the meantime, you can fix it locally by editing the file concat_config.js: in the line containing "cs_language =" change the 1 to a 0.
                cs_language = new ComboBox3(window, "cs_language", "15em", 1, true, "OX_Configuration_Settings_Changed_Language", 3);

                ...changed it to:

                cs_language = new ComboBox3(window, "cs_language", "15em", 0, true, "OX_Configuration_Settings_Changed_Language", 3);

                ...and it works.

                Thank you, Viktor!

                Existing users still had English GUI after restarting groupware. I had to click on German in the language options and then save it to update.

                When creating new users i have to add "--language "de_DE"" to the "createuser" command otherwise new users will be created with English as default language, but only German available to choose.
                Would be nice if there's a line in another file to change it globally for all, but not necessary.

                Comment


                • #9
                  I just found another thing.



                  Everything was changed in German but the inbox items still remain in English.

                  Where can i change that?

                  Comment


                  • #10
                    Originally posted by wahnsinnn View Post
                    Where can i change that?
                    Your IMAP server.

                    Comment


                    • #11
                      Thank you!

                      I will try to change it.

                      Comment


                      • #12
                        Originally posted by wahnsinnn View Post
                        Thank you!

                        I will try to change it.
                        Oh, I think this won't work. The name of the "Inbox" can't be changed.

                        Comment


                        • #13
                          Originally posted by Stefan Preuss View Post
                          Oh, I think this won't work. The name of the "Inbox" can't be changed.
                          Until now, i couldn't find any solution to get this work. So, there isn't any possibility to change "Inbox" into "Posteingang"?

                          If i understand right, this is a defined thing that can not be changed? Neither as an alias or display name maybe in the GUI nor as a configuration in the IMAP-Server?

                          Is it the same in the Appliance Edition?

                          Comment


                          • #14
                            Well, I could add some virtual kind of translation. Means, the GUI simply fake the name. We already did this in OX5. I'm going to check this.

                            Comment


                            • #15
                              Originally posted by Stefan Preuss View Post
                              Well, I could add some virtual kind of translation. Means, the GUI simply fake the name.
                              This is something what i was searching for.

                              Originally posted by Stefan Preuss View Post
                              We already did this in OX5.
                              So, why didn't you do this in OX6?
                              For me, it seems that this point is an impairment from OX5 to OX6.

                              Originally posted by Stefan Preuss View Post
                              I'm going to check this.
                              That's great! Thank you!

                              And thanks to the rest of the Open-Xchange team for the patience with me and all my questions so far.

                              Comment

                              Working...
                              X