Announcement

Collapse
No announcement yet.

OX6 compilation problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OX6 compilation problem

    Hello,

    after having used OX 5 for a time, I would like to use OX6. I have downloaded source code from opensuse repository, extract them and try to compile it. Some of packages are compile.


    Now I ave compilation problem to compile open-xchange-admin-plugin-imap.

    using ant -lib /opt/open-xchange/lib command I got the following error messages
    File to be compiled:
    [javac] /tmp/open-xchange-admin-plugin-imap/src/com/openexchange/admin/rmi/impl/OXUserIMAPImpl.java
    [javac] /tmp/open-xchange-admin-plugin-imap/src/com/openexchange/admin/rmi/impl/OXUserIMAPImpl.java:281: cannot find symbol
    [javac] symbol : method getLanguage()
    [javac] location: class java.lang.String
    [javac] lang = user.getLanguage().getLanguage() + "_" + user.getLanguage().getCountry();
    [javac] ^
    [javac] /tmp/open-xchange-admin-plugin-imap/src/com/openexchange/admin/rmi/impl/OXUserIMAPImpl.java:281: cannot find symbol
    [javac] symbol : method getCountry()
    [javac] location: class java.lang.String
    [javac] lang = user.getLanguage().getLanguage() + "_" + user.getLanguage().getCountry();
    [javac] ^
    [javac] 2 errors



    under /opt/open-change/lib I have the following lib

    activation.jar
    jakarta-slide-webdavlib-2.1.jar
    axis.jar
    jaxrpc.jar
    org.eclipse.osgi_3.2.2.ox.jar
    commons-cli-1.0.jar
    jcharset-1.3.jar
    pop3.jar
    commons-codec-1.3.jar
    jcs-1.2.7.9.2.jar
    commons-discovery-0.2.jar
    jdom.jar
    commons-fileupload.jar
    json.jar
    saxon8.jar
    commons-httpclient-2.0.2.jar
    jsr173_1.0_api.jar
    servlet-api-2.4.jar*
    commons-httpclient-3.0.1.jar
    junit-4.1.jar
    smtp.jar
    commons-io.jar
    ldb-client.jar
    spring-beans_1.2.7.jar
    commons-logging-1.0.4.jar
    license.jar
    spring-core_1.2.7.jar
    commons-logging.jar
    mail.jar
    tnef.jar
    concurrent.jar
    mailapi.jar
    wsdl4j-1.5.1.jar
    dsn.jar
    mailapi_1_3_1.jar
    xbean.jar
    imap.jar
    mysql-connector-java-3.1.13-bin.jar
    xmlpublic.jar

    Any Idea

    Thanks

  • #2
    Hi,

    why don't you just use the prebuild packages?
    http://www.open-xchange.com/oxpedia

    Greetings

    Comment


    • #3
      Hi

      Thanks for your reply

      I do not use it because I do not have the linux platform used with the prebuild package

      Regards

      Comment


      • #4
        Okay, i understand - but beware that there could be severe problems afterwards. Especially the scripts used to set up OX on a new machine do rely on man GNU utils on Linux. We already encountered problems on systems like *BSD or OSX where other variants of those tools exist that have different syntax.

        What version of the sources did you download exactly? open-xchange-admin-imap does look like OX 6.4 which is not longer supported.

        Comment


        • #5
          Compiling is a little complex and we do not have an up2date instruction on how to do.

          As a starting point, you could use this document:

          http://www.open-xchange.com/wiki/ind...urceCodeAccess

          and this

          http://www.open-xchange.com/wiki/ind...ges&oldid=1387

          The latter has already been removed, because it is horribly outdated.

          Comment


          • #6
            Thanks for the quick reply

            I have download sources code according to the wiki. As I was unable to compile, I have just download from
            http://download.opensuse.org/reposit...SUSE_11.0/src/
            thinking that these code are uptodate.
            Unfornutatly I have some compilation problem for some packages.
            Perhaps I have to download another source.
            I would like to compile it on a slackware.

            Thanks

            Comment

            Working...
            X