Announcement

Collapse
No announcement yet.

Install in OX free server version on Centos 5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install in OX free server version on Centos 5

    I am having some trouble with getting this to install correctly. I would appreciate any help. Thanks

    Here is the commands I am using:


    /etc/init.d/mysqld start

    /opt/open-xchange/sbin/initconfigdb -a -i --configdb-pass=NTXemailcfg

    /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=NTXemailcfg \
    --master-pass=NTXEadmin

    /etc/init.d/open-xchange-admin start

    /opt/open-xchange/sbin/registerserver -n oxserver -A NTXEadmin -P NTXemail

    mkdir /var/opt/filestore

    chown open-xchangepen-xchange /var/opt/filestore

    /opt/open-xchange/sbin/registerfilestore -A NTXEadmin -P NTXemail -t file:///var
    /opt/filestore

    /opt/open-xchange/sbin/registerdatabase -A NTXEadmin -P NTXemail -n oxservere -p NTXemail -m true

    Here are the errors:

    [root@SVR001-linux ~]# /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=NTXemailcfg \
    > --master-pass=NTXEadmin
    hostname: Unknown host
    hostname: Unknown host
    hostname: Unknown host
    hostname: Unknown host
    hostname: Unknown host

    /opt/open-xchange/sbin/oxinstaller currently knows the following parameters:

    Parameter | Default value | Possible values
    --------------------------------------------------------------------------------------------
    --servername | oxserver |
    --imapserver | |
    --smtpserver | |
    --imaplogintype | user | user config global
    --configdb-user | openexchange |
    --configdb-pass | NTXemailcfg |
    --configdb-readhost | localhost |
    --configdb-writehost | localhost |
    --configdb-dbname | configdb |
    --servermemory | 512 |
    --adminmemory | 100 |
    --clt-memory | 50 |
    --configdb-readport | 3306 |
    --configdb-writeport | 3306 |
    --tmpdir-path | /tmp |
    --master-pass | NTXEadmin |
    --master-user | oxadminmaster |
    --jkroute | APP1 |
    --ajp-bind-port | * |
    --imap-credentials | user.imapLogin | session user.imapLogin
    --object-link-hostname | |
    --extras-link | http:/// |
    --cache-udp-disc-addr | 224.0.0.1 |
    --cache-udp-disc-port | 6780 |
    --groupware-cache-port | 57461 |
    --admin-cache-port | 57462 |
    --gwsession-cache-port | 58849 |
    --ip-of-oxcluster | |
    --push-udp-disc-port | 9982 |
    --push-outlook-port | 44335 |
    --SesssionContTimeout | 4200000 |
    --NRSessionContainers | 8 |
    --maxSession | 0 |
    --DoubleLoginPerm | true | true false
    --sessionDefLifeTime | 3600000 |
    --disableauth | false | true false

    Example:

    /opt/open-xchange/sbin/oxinstaller --servername=ox6 --configdb-pass=secret --master-pass=secret

    use -D for Debug mode


    missing required option --object-link-hostname

    [root@SVR001-linux ~]# /etc/init.d/open-xchange-admin start
    Starting open-xchange-admin daemon [done] [ OK ]

    [root@SVR001-linux ~]# /opt/open-xchange/sbin/registerserver -n oxserver -A NTXEadmin -P NTXemail

    server could not be registered:
    Server response:
    Authentication failed
    [root@SVR001-linux ~]# mkdir /var/opt/filestore
    mkdir: cannot create directory `/var/opt/filestore': File exists

    [root@SVR001-linux ~]# chown open-xchangepen-xchange /var/opt/filestore

    [root@SVR001-linux ~]# /opt/open-xchange/sbin/registerfilestore -A NTXEadmin -P NTXemail -t file:///var/opt/filestore
    filestore could not be registered:
    Server response:
    Authentication failed

    [root@SVR001-linux ~]# /opt/open-xchange/sbin/registerdatabase -A NTXEadmin -P NTXemail -n oxserver -p NTXemail -m true
    database could not be registered:
    Server response:
    Authentication failed
    Last edited by NTX; 02-07-2009, 08:25 PM. Reason: Ease of Viewing

  • #2
    I encountered the same problem during a OX6/Centos 5.2 installation.

    The problem is very simple - the host localhost is unknown.

    Verify the /etc/hosts file. The entry
    127.0.0.1 localhost
    is missing. Add the entry, and OX will work.

    This is a strange problem - is seems the installer makes this boob if you disable IP 6 during the installation.

    Comment


    • #3
      Checked the local host did not fix the issue.

      Thanks for the help but after checking the localhost it still is not installing.

      ping localhost
      PING localhost (127.0.0.1) 56(84) bytes of data.
      64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.080 ms
      64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.079 ms


      [root@SVR001-linux java-1.5.0-sun]# /etc/init.d/mysqld start
      Starting MySQL: [ OK ]
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# /opt/open-xchange/sbin/initconfigdb -a -i --configdb-pass=NTXemailcfg
      initializing configdb from scratch... done
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=NTXemailcfg \
      > --master-pass=NTXemail
      hostname: Unknown host
      hostname: Unknown host
      hostname: Unknown host
      hostname: Unknown host
      hostname: Unknown host

      /opt/open-xchange/sbin/oxinstaller currently knows the following parameters:

      Parameter | Default value | Possible values
      --------------------------------------------------------------------------------------------
      --servername | oxserver |
      --imapserver | |
      --smtpserver | |
      --imaplogintype | user | user config global
      --configdb-user | openexchange |
      --configdb-pass | NTXemailcfg |
      --configdb-readhost | localhost |
      --configdb-writehost | localhost |
      --configdb-dbname | configdb |
      --servermemory | 512 |
      --adminmemory | 100 |
      --clt-memory | 50 |
      --configdb-readport | 3306 |
      --configdb-writeport | 3306 |
      --tmpdir-path | /tmp |
      --master-pass | NTXemail |
      --master-user | oxadminmaster |
      --jkroute | APP1 |
      --ajp-bind-port | * |
      --imap-credentials | user.imapLogin | session user.imapLogin
      --object-link-hostname | |
      --extras-link | http:/// |
      --cache-udp-disc-addr | 224.0.0.1 |
      --cache-udp-disc-port | 6780 |
      --groupware-cache-port | 57461 |
      --admin-cache-port | 57462 |
      --gwsession-cache-port | 58849 |
      --ip-of-oxcluster | |
      --push-udp-disc-port | 9982 |
      --push-outlook-port | 44335 |
      --SesssionContTimeout | 4200000 |
      --NRSessionContainers | 8 |
      --maxSession | 0 |
      --DoubleLoginPerm | true | true false
      --sessionDefLifeTime | 3600000 |
      --disableauth | false | true false

      Example:

      /opt/open-xchange/sbin/oxinstaller --servername=ox6 --configdb-pass=secret --master-pass=secret

      use -D for Debug mode


      missing required option --object-link-hostname
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# /etc/init.d/open-xchange-admin start
      Starting open-xchange-admin daemon [done] [ OK ]
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# /opt/open-xchange/sbin/registerserver -n oxserver -A openexchange -P oxchange
      server could not be registered:
      Server response:
      Authentication failed
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# mkdir /var/opt/filestore
      mkdir: cannot create directory `/var/opt/filestore': File exists
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# chown open-xchangepen-xchange /var/opt/filestore
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# /opt/open-xchange/sbin/registerfilestore -A NTXEadmin -P NTXemail -t file:///var/opt/filestore
      filestore could not be registered:
      Server response:
      Authentication failed
      [root@SVR001-linux java-1.5.0-sun]#
      [root@SVR001-linux java-1.5.0-sun]# /opt/open-xchange/sbin/registerdatabase -A NTXEadmin -P NTXemail -n oxserver -p NTXemail -m true
      database could not be registered:
      Server response:
      Authentication failed

      Comment

      Working...
      X