Announcement

Collapse
No announcement yet.

ox install Connection refused to host java net

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ox install Connection refused to host java net

    After 400 cigarettes and about 100 hours, three new installations i got every time this
    error by the command oxinstaller .......

    (Re)Starting Admin Daemon
    Error:
    Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused


    I use opensuse 10.2
    libs seem to be ok
    mysql ok
    apache2 ok
    sasl2 ok
    hosts checked
    the installations are build successfully.

    everything looks fine and now I don't have any idea.

    ps: sorry for my terrible english.

  • #2
    Additional Information

    The message "initialize database (2/2)" don't appear.
    Seem it hangs in allpluginsloaded

    Comment


    • #3
      Did you made sure the MySQL database is configured without a password for user "root"? Please activate the debug logging of MySQL to track down this to the original error, if the database did not get any query the problem might occur before.

      Comment


      • #4
        Geschafft

        Es waren bei mir einige Fehler noch enthalten. Habe nochmals neu installiert
        Folgendes
        - nicht exakt die Version : mysql-connector-java-3.1.13-bin.jar genommen
        - ANT 1.6 durch 1.7 ersetzt.

        und natürlich die vielen Änderungen vorher.

        Comment


        • #5
          hi there,

          i get the exact same error when executing the oxinstaller script. i use mysql-connector-java-3.1.14-bin.jar, is that really a problem? where can i find mysql-connector-java-3.1.13-bin.jar?
          I read in the wiki talk page that there is a hardcoded link to 3.1.13 in oxinstaller but creating a symlink did not solve the problem.

          the newest file in /var/log/mysql is mysql-bin.000043 when i open it using
          mysqlbinlog i get this:
          Code:
          CREATE TABLE context_server2db_pool (
              server_id INT4 UNSIGNED NOT NULL,
              cid INT4 UNSIGNED NOT NULL,
              read_db_pool_id INT4 UNSIGNED NOT NULL,
              write_db_pool_id INT4 UNSIGNED NOT NULL,
              db_schema VARCHAR(32) NOT NULL,
              PRIMARY KEY(`cid`, `server_id`),
              INDEX (write_db_pool_id),
              INDEX (server_id),
              INDEX (db_schema),
              FOREIGN KEY(`cid`) REFERENCES context (`cid`) ON DELETE CASCADE ON UPDATE CASCADE
          ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_general_ci/*!*/;
          DELIMITER ;
          # End of log file
          unfortunately I don't have debugging compiled into mysql, cause i'm running the ubuntu version of mysqld.

          so now i'm looking into org.eclipse.osgi_3.2.2.ox.jar, I cannot find this exact version, does org.eclipse.osgi_3.2.2.R32x_v20070118.jar work as well, or shall i try another one?

          and for java: i'm running the ubuntu distributed sun-java-1.6
          ant is version 1.6.5.

          in the mysql databes the user openexchange exists and a configdb database exists.

          i will investigate into it further.

          Comment


          • #6
            Hi,

            yes, it is important to use the exact filename which is given at the installation guide because the compile process will search for these files. Just rename the mysql-connector-java-3.1.14-bin.jar to mysql-connector-java-3.1.13-bin.jar and same with the OSGi framework .jar. I know this is a bit confusing, but the required .jar files are written with the exact filename to the build.xml file which is used by ant to compile.
            For MySQL logging: You do not need to compile with debug flags, just activate the query log at the my.cf file - its that entry with the "performance killer" warning - this option and a restart of mysql shows you all transactions logged to /var/log/mysql/mysql.log on a debian-like system.

            Greetings

            Comment


            • #7
              seems like it does not get to open a connection at all:

              Code:
              root@cuubserv1:/var/log/mysql# tail mysql.log
                  read_db_pool_id INT4 UNSIGNED NOT NULL,
                  write_db_pool_id INT4 UNSIGNED NOT NULL,
                  db_schema VARCHAR(32) NOT NULL,
                  PRIMARY KEY(`cid`, `server_id`),
                  INDEX (write_db_pool_id),
                  INDEX (server_id),
                  INDEX (db_schema),
                  FOREIGN KEY(`cid`) REFERENCES context (`cid`) ON DELETE CASCADE ON UPDATE CASCADE
              ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_general_ci
                                    8 Quit       
              root@cuubserv1:/var/log/mysql#
              as for the filenames, i renamed the links in all the build.xml files before compiling, and everything compiled cleanly. I'll try to create symlinks with the names as stated in the installation manual, and compile again. I suspect that there are some more hardcoded references in the code.

              I'll report when i'm done.

              regards
              tobias

              Comment


              • #8
                back again,

                all this did not get me any further unfortunately, I have symlinks in /opt/open-xchange/lib with the names of the installation manual pointing to the actual versions which i installed. I did not revert the references in the build.xml files however. After recompiling open-xchange and open-xchange-admin, the problem remains. maybe i need to give ANT an option to force overwrite of the previous installation.

                the mysql logs don't show anything about failed connections. There is a comment in my.cnf that says error logs go to syslog, and but /var/log/syslog does not mention mysql at all. there are two more files in /var/log: mysql.log and mysql.err, which are both empty.
                This is driving me nuts now. maybe i'll include some echos in the /opt/open-xchange/etc/admindaemon/oxfunctions.sh script.

                Or maybe i am stupid and need to compile every package of the admin* section by hand?
                Well I'll do a CVS update first, then we'll see.

                tobias

                Comment


                • #9
                  Hi,

                  just try to _rename_ the .jar files, not via symlinks. You do not need to modify the build.xml if you do so. Note that all jar files are used by groupware & admindaemon source files. You only have to compile the "open-xchange", "open-xchange-admin" and "open-xchange-gui" with the ant options shown at the wiki. You do not need to compile each open-xchange-admin-* directory as they are called by the open-xchange-admin build files. Does the compile process throw any error message? And please try with ANT 1.7

                  Greetings

                  Comment


                  • #10
                    i just executed ant clean and it removed /opt/open-xchange/lib
                    thank you for that...
                    to everyone: make backups of those files!

                    Comment


                    • #11
                      Hi,

                      A simple "ant clean" does not delete /opt/open-xchange/lib ... i tried it 5 seconds ago. Did you set the ${lib.dir} to /opt/open-xchange/lib yourself? That would explain it...

                      Comment


                      • #12
                        yes it was set to /opt/open-xchange/lib, but that is the default location and I just put the 3rd party libs there, as told in the installation manual.


                        well, but you still helped me get further:
                        i followed all of you instructions (using ant 1.7 and renamed all the .jar files)
                        and did a fresh co on all reps.

                        the next error:
                        Code:
                        Exception in thread "main" java.lang.NoClassDefFoundError: com/openexchange/admin/console/context/Create
                        Server response:
                         Authentication failed for user oxadmin
                        tried to run oxinstaller with passwords in the script and without, same error.

                        oxadmin does not exist:
                        Code:
                        mysql> select user, host from user;
                        +------------------+------------+
                        | user             | host       |
                        +------------------+------------+
                        | root             | 127.0.0.1  | 
                        | root             | ldapserver | 
                        | debian-sys-maint | localhost  | 
                        | openexchange     | localhost  | 
                        | root             | localhost  | 
                        | root             | mydb       | 
                        +------------------+------------+
                        6 rows in set (0.00 sec)

                        Comment


                        • #13
                          The default lib.dir for ant is the directory where it puts the build .jar files when compiling. With a "ant clean", this directory gets removed because it holds deprecated .jar files. Cleaning a external directory overrides the default.

                          Did you set the classpath when compiling? I use the following commands to compile the sources:
                          Code:
                          cd /usr/src/open-xchange
                          ant -Dlib.dir=/opt/open-xchange/lib install
                          
                          cd /usr/src/open-xchange-admin
                          ant -Dlib.dir=/opt/open-xchange/lib install
                          
                          cd /usr/src/open-xchange-gui
                          export CLASSPATH=/opt/open-xchange/lib/saxon8.jar
                          export ANT_OPTS="-Djavax.xml.transform.TransformerFactory=net.sf.saxon.TransformerFactoryImpl"
                          ant -Dlib.dir=/opt/open-xchange/lib/ deploy
                          Did you also compile the json and concurrent .jar files? These dependencies have to be built by yourself:

                          Code:
                          cd /usr/src/
                          cvs -Q -d:pserver:anonymous@www.open-xchange.com:/var/lib/cvs co json-jdk15
                          cd json-jdk15
                          ant
                          
                          <download the concurrent source files and unpack to /usr/src>
                          cd /usr/src/concurrent
                          ant dist
                          cp lib/concurrent.jar /opt/open-xchange/lib
                          Last edited by Martin Heiland; 07-11-2007, 03:05 PM.

                          Comment


                          • #14
                            martin,

                            i'm not yet at the point where i can compile open-xchange-gui, since I'm still stuck at creating the database via the oxinstaller script.
                            i compiled json.jar and concurrent.jar of course. they are both in /opt/open-xchange/lib
                            the output of oxinstaller up to the first error message:
                            Code:
                            root@cuubserv1:/opt/open-xchange/sbin# /opt/open-xchange/sbin/oxinstaller -f --oxdb-pass=xxx --admin-pass=xxx --maildomain callsunited.com
                            initializing database (step 1/2)
                            done
                            Configuring services
                            setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
                            setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
                            setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
                            setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
                            setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
                            setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
                            setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
                            setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
                            setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
                            setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
                            setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
                            setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
                            setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
                            setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
                            (Re)Starting Admin Daemon
                            done
                            initializing database (step 2/2)
                            Exception in thread "main" java.lang.NoClassDefFoundError: com/openexchange/admin/console/context/Create
                            Server response:
                             Authentication failed for user oxadmin
                            tobias

                            Edit: forgot to include JAVA_HOME/jre/bin into path before executing "for show", removed the error message so nobody gets confused,
                            the real problem is that user oxadmin is not in the db.
                            Last edited by bifi; 07-11-2007, 05:06 PM.

                            Comment


                            • #15
                              Hi, The user oxadmin is not created for me as well. but im getting error that --oxdb-pass is unknown option when i run

                              sudo /opt/open-xchange/sbin/oxinstaller --oxdb-pass=somepass --admin-pass=somepass --maildomain somedomain.com

                              Code:
                              getopt: unrecognized option `--oxdb-pass=somepass'
                              initializing database (step 1/2)
                              done
                              Configuring services
                              setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
                              setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
                              setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
                              setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
                              setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
                              setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
                              setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
                              setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
                              setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
                              setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
                              setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
                              setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
                              setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
                              setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
                              (Re)Starting Admin Daemon
                              Error:
                               Connection refused to host: localhost; nested exception is: 
                                      java.net.ConnectException: Connection refused
                              
                              etc... 
                              
                              etc....

                              Comment

                              Working...
                              X