No announcement yet.

current jcs- seams to be broken

  • Filter
  • Time
  • Show
Clear All
new posts

  • current jcs- seams to be broken

    When trying to compile ox the first time I got around 100 Compile-Errors and was not able to successfully build the ox.

    The very first error was, that the jcs- could not be read.
    I'm sorry that I accidentely overwrote my 1. ant_compile_log to give you the exact error-message.

    I downloaded the file several times in different ways, but the error always appeared again. Then I tried a different one and also changed the build.xml.

    While using an earlier version: jcs- (unfortunately no more current version was available), i was lucky to compile the ox-server without any errors within 24 secounds.

    Comparing my two downloaded jcs-file I had to assert, that the more current but broken jcs- is only 5.2 KB instead of the 402.1 KB of the older jcs-

    Does it make sense to go ahead? Could anybody please sent me a working jcs- to klaus_dot_kox_at_help-it_org ?

    Is their a way to inform the maintainers of this software about this issue ?

  • #2
    me again, with the original EM

    While compiling open-xchange-admin the same error appears again:

    Here the EM (Error Message)

    [javac] error: error reading /opt/open-xchange/lib/jcs-; error in opening zip file

    But changing the buid.xml in an apropiate way helped here to solve the problem too.

    A hint in the wiki, that the build.xml of the open-xchange-admin-directory should also be checked for differences in filenames used in /opt/open-xchange/lib would be helpful.



    • #3
      By all means, add it


      • #4
        Problem solved

        In between someone from the site-maintainers seams to have fixed the issue.
        The current jcs- has now a different and more reasonable size an could be read by the build-process.

        Thank you.