Announcement

Collapse
No announcement yet.

Unable to Compose Email Loading....

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Compose Email Loading....

    I am unable to compose any emails. Clicking on the new email icon brings up the New Email window; a "busy" icon shows and Loading... shows, but the Compose window never resolves to a point where I can actually write and send an email.
    It appears that everything else does work (calendar,addressbook,tasks). I have added two users; both users can see and read from their mailboxes.


    This is a new install on Ubuntu/Feisty following the wiki instructions.
    From the command line, I can telnet to localhost 25 and send an email. In OX, I can see and read the email I just sent.

    I did not see any error messages in open-xchange.log.0. I do think there may be a problem in mail.log but I do not understand what the error is, or if it is even related to my problem.

    Part of the mail.log for user mike:

    Jul 20 07:17:12 phoney cyrus/imap[8212]: login: localhost [127.0.0.1] mike plaintext U
    ser logged in
    Jul 20 07:17:12 phoney cyrus/imap[8212]: seen_db: user mike opened /var/lib/cyrus/user
    /m/mike.seen
    Jul 20 07:17:12 phoney cyrus/imap[8212]: open: user mike opened INBOX
    Jul 20 07:17:12 phoney cyrus/imap[8211]: open: user mike opened INBOX
    Jul 20 07:17:12 phoney cyrus/imap[8211]: SQUAT failed to open index file
    Jul 20 07:17:12 phoney cyrus/imap[8211]: SQUAT failed
    Jul 20 07:17:12 phoney cyrus/imap[8211]: SQUAT failed to open index file
    Jul 20 07:17:12 phoney cyrus/imap[8211]: SQUAT failed
    Jul 20 07:17:12 phoney cyrus/imap[8211]: open: user mike opened INBOX
    Jul 20 07:17:12 phoney cyrus/imap[8212]: telling master 1
    Jul 20 07:17:12 phoney cyrus/master[10370]: service imap pid 8212 in BUSY state: now a
    vailable and in READY state
    Jul 20 07:17:12 phoney cyrus/master[10370]: service imap now has 1 ready workers
    Jul 20 07:17:22 phoney cyrus/imap[8211]: telling master 1
    Jul 20 07:17:22 phoney cyrus/master[10370]: service imap pid 8211 in BUSY state: now a
    vailable and in READY state
    Jul 20 07:17:22 phoney cyrus/master[10370]: service imap now has 2 ready workers
    Jul 20 07:17:35 phoney cyrus/master[10370]: process 7682 exited, status 0
    Jul 20 07:17:35 phoney cyrus/master[10370]: service lmtpunix now has 0 ready workers
    Jul 20 07:18:12 phoney cyrus/master[10370]: process 8212 exited, status 0
    Jul 20 07:18:12 phoney cyrus/master[10370]: service imap now has 1 ready workers
    Jul 20 07:18:22 phoney cyrus/master[10370]: process 8211 exited, status 0


    I also installed on my home machine (also Ubuntu/Feisty) with the same situation. I did a re-install on my home machine but the same problem occurs.

    Any suggestions on where to look to resolve this?

    Thank you

    Mike

  • #2
    Hi Mike,

    this is a GUI issue which has already been fixed, it will be updated on the CVS tonight.

    Greetings

    Comment


    • #3
      Originally posted by Martin Braun View Post
      Hi Mike,

      this is a GUI issue which has already been fixed, it will be updated on the CVS tonight.

      Greetings
      Thank you.

      I have reinstalled using the wiki guide this morning (21 July 07) I have a new problem. I an unable to log into to OX. Error 503 Service Temporarily unavailable... only it is not temporary!

      The open-xchange logs show:

      tail open-xchange-console.log

      Error occurred during initialization of VM
      Too small initial heap for new size specified



      tail open-xchange-admin.log.0

      Jul 21, 2007 2:01:05 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager fixService
      SEVERE: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
      Jul 21, 2007 2:01:05 PM org.apache.jcs.auxiliary.lateral.LateralCacheResto re canFix
      SEVERE: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462
      Jul 21, 2007 2:01:05 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
      SEVERE: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
      Jul 21, 2007 2:01:05 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager fixService
      SEVERE: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
      Jul 21, 2007 2:01:05 PM org.apache.jcs.auxiliary.lateral.LateralCacheResto re canFix
      SEVERE: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462


      I did try to stop and then start /etc/init.d/open-xchange-admin and open-xchange-groupware. Just in case, I also rebooted... same error message.

      Mike

      Comment


      • #4
        Hi Mike,

        would you be so kind and post the java command which is running for the groupware? (ps aux | grep java) It seems that (for whatever case) the startup parameters for memory usage are set wrong

        Comment


        • #5
          Originally posted by Martin Braun View Post
          Hi Mike,

          would you be so kind and post the java command which is running for the groupware? (ps aux | grep java) It seems that (for whatever case) the startup parameters for memory usage are set wrong
          ps ax |grep java
          8591 ? Ssl 0:03 /usr/bin/java -ms50m -mx50m -Dopenexchange.propfile=/opt/open-xchange/etc/admindaemon/system.properties -Dconfigdir=/opt/open-xchange/etc/admindaemon -Djava.util.logging.config.file=/opt/open-xchange/etc/admindaemon/file-logging.properties -Duser.timezone=GMT -Dlibdir=/opt/open-xchange/lib -jar /opt/open-xchange/lib/org.eclipse.osgi_3.2.2.ox.jar -configuration file:/opt/open-xchange/etc/admindaemon/osgi/
          12469 pts/1 R+ 0:00 grep java

          Comment


          • #6
            Try to set the JVM Memory cap to a higher value, currently it is 50megs_

            /opt/open-xchange/etc/groupware/ox-scriptconf.sh
            JAVA_XTRAOPTS="-Xms50M -Xmx512M"

            Comment


            • #7
              Originally posted by Martin Braun View Post
              Try to set the JVM Memory cap to a higher value, currently it is 50megs_

              /opt/open-xchange/etc/groupware/ox-scriptconf.sh
              JAVA_XTRAOPTS="-Xms50M -Xmx512M"
              The contents of /opt/open-xchange/etc/groupware/ox-scriptconf.sh is :


              SYSTEMPROPERTIES=/opt/open-xchange/etc/groupware/system.properties
              LOGGINGPROPERTIES=/opt/open-xchange/etc/groupware/file-logging.properties

              JAVA_XTRAOPTS="-Xms50M -Xmx512M -XX:+AggressiveHeap"

              NRFILES="8192"


              I noticed that the "AggressiveHeap" was not in the last build that I did. As an experiment ,I tried removing it... but it did not help.

              Here is more info from open-xchange-admin.log.0

              Jul 21, 2007 7:36:16 PM com.openexchange.admin.daemons.Activator start INFO: Starting Admindaemon... Jul 21, 2007 7:36:16 PM com.openexchange.admin.tools.AdminCache initOXProccess INFO: OX init starting... Jul 21, 2007 7:36:16 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init> SEVERE: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462 Jul 21, 2007 7:36:16 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager <init> SEVERE: Failure, lateral instance will use zombie service java.io.IOException: Socket is null, cannot connect to 127.0.0.1:57462 at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPSender.init(LateralTCPSender.java:141) at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPSender.<init>(LateralTCPSender.java:111) at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService.<init>(LateralTCPService.java:72) at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager.<init>(LateralTCPCacheManager.jav a:167)
              at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheManager.getInstance(LateralTCPCacheManage r.java:108)
              at org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPCacheFactory.createCache(LateralTCPCacheFactor y.java:84)
              at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseAuxiliary(CompositeCacheConfigurator.j ava:554)
              at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseRegion(CompositeCacheConfigurator.java :346)
              at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseRegion(CompositeCacheConfigurator.java :267)
              at org.apache.jcs.engine.control.CompositeCacheConfig urator.parseRegions(CompositeCacheConfigurator.jav a:244)
              at org.apache.jcs.engine.control.CompositeCacheConfig urator.doConfigure(CompositeCacheConfigurator.java :139)
              at org.apache.jcs.engine.control.CompositeCacheManage r.configure(CompositeCacheManager.java:314)
              at org.apache.jcs.engine.control.CompositeCacheManage r.configure(CompositeCacheManager.java:258)
              at com.openexchange.cache.Configuration.configure(Con figuration.java:122)
              at com.openexchange.cache.Configuration.load(Configur ation.java:99)
              at com.openexchange.admin.tools.OXRunner.init(OXRunne r.java:92)
              at com.openexchange.admin.tools.AdminCache.initOXProc cess(AdminCache.java:467)

              at com.openexchange.admin.tools.AdminCache.initCache( AdminCache.java:140)
              at com.openexchange.admin.daemons.AdminDaemon.initCac he(AdminDaemon.java:139)
              at com.openexchange.admin.daemons.Activator.start(Act ivator.java:89) at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(B
              undleContextImpl.java:991) at java.security.AccessController.doPrivileged(Native Method)
              at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
              at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
              at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
              at org.eclipse.osgi.framework.internal.core.AbstractB undle.start(AbstractBundle.java:256)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.st artBundles(EclipseStarter.java:1094)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.lo adBasicBundles(EclipseStarter.java:657)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.st artup(EclipseStarter.java:305)

              at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:173)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.ma in(EclipseStarter.java:150)
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initOXProccess
              INFO: ...OX init done!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initCache
              INFO: Init Cache
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon initCache
              INFO: Cache and Pools initialized!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon$LocalSe rverFactory createServerSocket
              INFO: Admindaemon will listen on localhost!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.rmi.impl.OXUser <init>
              INFO: Class loaded: com.openexchange.admin.rmi.impl.OXUser
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.rmi.impl.OXGroup <init>
              INFO: Class loaded: com.openexchange.admin.rmi.impl.OXGroup
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.rmi.impl.OXResource <init>
              INFO: Class loaded: com.openexchange.admin.rmi.impl.OXResource
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.rmi.impl.OXLogin <init>
              INFO: Class loaded: com.openexchange.admin.rmi.impl.OXLogin
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator start
              INFO: Version: 6.3.0
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator start

              INFO: Name: open-xchange-admin
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator start
              INFO: Build: 0
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator start
              INFO: Admindaemon successfully started.
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
              INFO: open_xchange_admin changed to 2
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
              INFO: open_xchange_admin_plugin_ca_mgmt_simple changed to 2
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initOXProccess
              INFO: OX init starting...
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initOXProccess
              INFO: ...OX init done!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initCache
              INFO: Init Cache
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.PluginStarter initCache
              INFO: Cache and Pools initialized!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.PluginStarter start
              INFO: Context-Light started!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
              INFO: open_xchange_admin_plugin_context_light changed to 2
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator$2 serviceChanged
              INFO: Service: open_xchange_admin_plugin_imap, 1
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator$2 serviceChanged
              INFO: open_xchange_admin_plugin_imap registered service
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleChanged
              INFO: open_xchange_admin_plugin_imap changed to 2
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initOXProccess
              INFO: OX init starting...
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initOXProccess
              INFO: ...OX init done!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.tools.AdminCache initCache
              INFO: Init Cache
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.PluginStarter initCache
              INFO: Cache and Pools initialized!
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator$2 serviceChanged
              INFO: Service: open_xchange_admin_plugin_mailfilter, 1
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.Activator$2 serviceCha
              nged
              INFO: open_xchange_admin_plugin_mailfilter registered service
              Jul 21, 2007 7:36:17 PM com.openexchange.admin.daemons.AdminDaemon$1 bundleCh
              anged
              INFO: open_xchange_admin_plugin_mailfilter changed to 2
              Jul 21, 2007 7:36:36 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTC
              PService <init>
              SEVERE: Could not create sender to [127.0.0.1:57462] -- Socket is null, canno
              t connect to 127.0.0.1:57462
              Jul 21, 2007 7:36:36 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTC
              PCacheManager fixService
              SEVERE: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
              Jul 21, 2007 7:36:36 PM org.apache.jcs.auxiliary.lateral.LateralCacheResto re
              canFix
              SEVERE: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462
              Jul 21, 2007 7:36:36 PM org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTC
              PService <init>

              Comment


              • #8
                Well. i suppose you've got a problem with the groupware, not with the admindaemon. These error messages are about caching, but if the groupware does not start you have more serious problems than caching
                If i were you, i'd try to get the groupware process up and running, this causes the 503 errors on the webinterface. If you try to login, the login data is pulled to a servlet of the groupware daemon, this is nothing the admindaemon does.

                Comment


                • #9
                  In /opt/open-xchange/sbin the file open-xchange-groupware contains the lines:

                  test -f $OXCONFIG && . $OXCONFIG

                  ox_set_JAVA_BIN


                  test -z "$JAVA_XTRAOPTS" && JAVA_XTRAOPTS="-ms50m -mx50m"

                  JAVA_OPTS="${JAVA_XTRAOPTS} \
                  -Djava.awt.headless=true \
                  -Dopenexchange.propfile=$SYSTEMPROPERTIES \
                  -Djava.util.logging.config.file=$LOGGINGPROPERTIES"

                  As an experiment, I added

                  JAVA_XTRAOPTS="-Xms50M -Xmx512M" just below the test -z line...
                  and Groupware now runs!

                  I then commented out the line I added... stopped and restarted OX and got the same failure...uncommented the line... OX works.

                  Mike

                  Comment


                  • #10
                    Ok, nice to know you got it working

                    The default parameter of 50m memory worked so far on any installation i've done but it is very much too low for productive usage. Depending on the system configuration this may even lead to non-functional software (like in your case). I'll add a note to the wiki as a work-around for this problems. Many thanks for the experiment!

                    Comment


                    • #11
                      Hello

                      I have exactly the same Problems then mjfleck2000 on "Neos" VMware Image.
                      There are 2 -3 updates vom cvs without Problems , last from 17. Juli.
                      cvs from 20 > the problem with new E-Mail Windows
                      cvs vom 21 > Error occurred during initialization of VM
                      exact the same logs , messages then mjfleck2000

                      Michael

                      Comment


                      • #12
                        Hi Michael,

                        did you already tried the same things as Mike to fix it?

                        Greetings

                        Comment


                        • #13
                          Hello Daniel

                          I changed the same then mjfleck2000

                          >In /opt/open-xchange/sbin the file open-xchange-groupware contains the >lines:
                          >test -f $OXCONFIG && . $OXCONFIG
                          >ox_set_JAVA_BIN
                          >test -z "$JAVA_XTRAOPTS" && JAVA_XTRAOPTS="-ms50m -mx50m"
                          >JAVA_OPTS="${JAVA_XTRAOPTS} \
                          >-Djava.awt.headless=true \
                          >-Dopenexchange.propfile=$SYSTEMPROPERTIES \
                          >-Djava.util.logging.config.file=$LOGGINGPROPERTIES"
                          >JAVA_XTRAOPTS="-Xms50M -Xmx512M


                          But always the message:
                          Too small initial heap for new size specified and groupware not running

                          Michael

                          Comment


                          • #14
                            try to change it at the ox-scriptconf.sh file

                            Comment


                            • #15
                              Hello Daniel

                              In opt/open-xchange/etc/ox-scriptconf.sh
                              Java_XTRAOPTS="-Xms50M -Xms512M -XX:+AggressiveHeap"
                              NRFILES="8192"

                              Whats changed in cvs between 20 and 21 Juli ?
                              I checked the changelog but dont found changes that makes this problems ?
                              Is there a possibility to debug ?

                              Thanks
                              Michael

                              Comment

                              Working...
                              X