Announcement

Collapse
No announcement yet.

Error while expanding /opt/Funambol/ds-server/modules/ox-connector-6.5.8.s4j

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error while expanding /opt/Funambol/ds-server/modules/ox-connector-6.5.8.s4j

    Hallo !

    Die Installation des oxconnectors entsprechend der Beschreibung auf
    http://www.open-xchange.com/wiki/ind...erion_Funambol
    scheitert bei mir bei dem Punkt

    ./bin/install-modules.sh
    mit folgender Fehlermeldung

    [iterate] Do you want to recreate the database?
    [iterate] (y,n)
    y

    BUILD FAILED
    /opt/Funambol/ds-server/install/install.xml:207: The following error occurred while executing this line:
    /opt/Funambol/ds-server/install/install-modules.xml:94: The following error occurred while executing this line:
    /opt/Funambol/ds-server/install/install-modules.xml:142: The following error occurred while executing this line:
    /opt/Funambol/ds-server/install/install-modules.xml:205: The following error occurred while executing this line:
    /opt/Funambol/ds-server/install/install-modules.xml:249: The following error occurred while executing this line:
    /opt/Funambol/ds-server/install/install-modules.xml:323: java.sql.SQLException: socket creation error
    Wie komme ich weiter ?

    openXchange Build: 6.8.0-6802, 2009-02-16
    funambol-ox-connector-6.5.8.zip
    funambol-6.5.8.bin
    Auf Suse 11.0

    Gruß
    Olaf
    Last edited by olaf123; 04-08-2009, 07:54 AM.

  • #2
    Hi Olaf,

    hast du mal in den Funambol Foren gefragt? Die haben schließlich den ox connector gebaut. Vielleicht ist irgendwas mit dem Download nicht okay gewesen.

    Gruß

    Comment


    • #3
      Hello,

      I tried the same yesterday with the new version of funambol. For me things get solved when I started prior to the modules install the hypersonic database server. It is located in the "bin" directory and has to be started with "bin/hypersonic start". I hope it helps.

      Kind regards
      mmlitz

      Comment


      • #4
        Hallo Martin & mmlitz !

        Originally posted by Martin Braun View Post
        hast du mal in den Funambol Foren gefragt? Die haben schließlich den ox connector gebaut. Vielleicht ist irgendwas mit dem Download nicht okay gewesen.
        Ok, danke für den Tip.
        Werde mal nachher nach dem Link bzw nach den Foren schauen. (ich befüchte .. englisch ;-)

        Originally posted by mmlitz View Post
        I tried the same yesterday with the new version of funambol.
        Martin + mmlitz:
        is this correct, using the _new_ version? I have read here in forum that I have to use an older version. The wiki described with older version, too.

        Originally posted by mmlitz View Post
        For me things get solved when I started prior to the modules install the hypersonic database server. It is located in the "bin" directory and has to be started with "bin/hypersonic start". I hope it helps.
        I will try so, thank you.

        Gruss,
        Olaf

        Comment


        • #5
          Hallo !

          Ich habe jetzt eine neuere Version des oxconnectors gewählt und bin damit zumindest weiter gekommen als vorher, wenn auch inzwischen ziemlich entnervt.

          Es gab diesmal die Fehlermeldung
          "Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-1.6.0-openjdk-1.6.0/lib/tools.jar"
          aber die Installation lief weiter durch.

          Ich habe keine Ahnung, was nun funktioniert oder auch nicht funktioniert, da ich jetzt bei der Konfiguration des funambol ... servers ....? .... connectors... ? ... naja, an den Angaben im Script ./funamboladmin scheitere. Komplett.

          Ich habe über google mehrere Beschreibungen gefunden, halte mich jetzt an die Anleitungen unter
          http://forge.ow2.org/project/showfiles.php?group_id=96
          (selbst damit gab es ja schon oben beschriebenen Fehler bei der Installation).

          Gibt es nicht irgendeine _deutschsprachige_ und _aktuelle_ Beschreibung, wie man was installiert und vor allem konfiguriert ?

          Solche Schwierigkeiten habe ich noch nie bei der Installation eines Scriptes gehabt.

          Gruß
          Olaf

          Comment


          • #6
            Hi Olaf,

            der ox connector und der funambol server wird komplett von Funambol selbst entwickelt und veröffentlicht, da haben wir leider nicht sehr viel Einfluss auf die Installationsroutine. Ich stimme dir zu dass sich diese Komponenten nicht wirklich einfach einrichten lassen.

            Es gibt durchaus schon funktionierende Installationen der freien Version von Funambol zusammen mit OX, jemand arbeitet gerade an einer gut verständlichen Anleitung in Deutsch, vielleicht kannst du hin und wieder mal in unserem irc channel #open-xchange im freenode vorbei schauen. Der Author des Guides hält sich dort auch gelegentlich auf und beantwortet sicherlich gerne deine Fragen.

            Gruß und schöne Ostern

            Comment


            • #7
              Hi,

              wieso benutzt du eine veraltete Version?

              bei mir funktioniert die aktuelle tadellos!

              Comment


              • #8
                Hallo !

                Originally posted by Martin Braun View Post
                jemand arbeitet gerade an einer gut verständlichen Anleitung in Deutsch, vielleicht kannst du hin und wieder mal in unserem irc channel #open-xchange im freenode vorbei schauen. Der Author des Guides hält sich dort auch gelegentlich auf und beantwortet sicherlich gerne deine Fragen.
                Danke für den Hinweis, ich werde mal reinschauen.
                Allerdings fehlt mir die Zeit, um womöglich weitere Wochen zu warten / suchen, da ich mich bereits längst entscheiden wollte zwischen openXchange und egroupware, ich benötige endlich den praktischen Nutzen.

                Ich werde dieses Wochenende nochmal mit dem oxconnector herumprobieren, aber dann sind's langsam wirklich genug investierte Stunden, das ist so leider nicht effektiv.

                Originally posted by Martin Braun View Post
                Gruß und schöne Ostern
                Danke, wünsche ich Dir auch.

                Originally posted by acid View Post
                wieso benutzt du eine veraltete Version?
                Weil das hier im Forum an mehreren Stellen so zu lesen ist: nur die Version 6.irgendwas funktioniere einwandfrei. Mehrere Beiträge, gefunden über die Suchfunktion.

                Originally posted by acid View Post
                bei mir funktioniert die aktuelle tadellos!
                Welche Version hast Du denn nach welcher Anleitung installiert, und wie konfiguriert ?

                Gruß
                Olaf
                Last edited by olaf123; 04-11-2009, 01:05 PM.

                Comment


                • #9
                  Originally posted by olaf123 View Post
                  Hallo !

                  Ich habe jetzt eine neuere Version des oxconnectors gewählt und bin damit zumindest weiter gekommen als vorher, wenn auch inzwischen ziemlich entnervt.

                  Es gab diesmal die Fehlermeldung
                  "Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-1.6.0-openjdk-1.6.0/lib/tools.jar"
                  aber die Installation lief weiter durch.
                  Bist Du damit inzwischen weiter?

                  Ich bekomme die selbe Fehlermeldung (funambol 8.0.0 / ox-listener 7.0.8 / ox-connector 7.0.8)

                  Ciao

                  dirk

                  Comment


                  • #10
                    Hallo Dirk !
                    Originally posted by diwa View Post
                    Bist Du damit inzwischen weiter?
                    Ich bekomme die selbe Fehlermeldung (funambol 8.0.0 / ox-listener 7.0.8 / ox-connector 7.0.8)
                    Nein. Ich habe irgendwann sehr entnervt aufgegeben.
                    Bei funambol scheint kein Interesse an der Behebung zu bestehen, und im irc /#open-xchange kam ich über mehrere Tage nicht weiter, weil dort schlichtweg nichts los war.

                    Da diese Funktionalität in OpenXchange somit nicht gegeben ist, nutze ich seit dem egroupware.
                    Damit bin ich nicht glücklich, aber es funktioniert für mich derzeit besser als OX.
                    Ich warte, bis OX irgendwann richtig synchronisieren kann, und schaue mir das nochmal an.

                    Gruß
                    Olaf

                    Comment


                    • #11
                      Hi Olaf,

                      das ist Schade zu hören. Es wird jedoch schon in kurzer Zeit Support von ActiveSync im Open-Xchange Server geben. Die Beta mit unseren Partnern läuft gerade, mit einem Release wird Ende diesen Monats (September) gerechnet. Damit kannst du die meisten Smartphones (iphone, blackberry, android, nokia s60, windows mobile) synchronisieren - ohne zusätzliche 3rd party serversoftware. Mit Ausnahme von BlackBerry E-Mail werden die nativen Applikationen des Smartphones genutzt, somit muss man auch keine 2 Kalender am Gerät pflegen.

                      Gruß
                      Martin
                      Last edited by Martin Heiland; 09-08-2009, 01:14 AM.

                      Comment

                      Working...
                      X