Announcement

Collapse
No announcement yet.

OX 6.10+funambol-7.1.1+funambol-ox-module-7.0.8

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Error Fixed.
    I installed the OX-Connector 7.1.0

    Comment


    • #17
      Hallo Liebe Community!!

      Ich habe heute open XChange erfolgreich aufgesetzt! Funktioniert auch gut soweit wie ich das beurteilen kann.

      Jetzt zu meinem Problem:
      Ich habe Funambol aufgetzt nach dieser Anleitung:
      http://geizhalsforum.666kb.at/files/2305/funambol.pdf

      Scheint auch zu funktionieren... aber das syncen klappt dennoch nicht...

      Ein Auszug aus der DS_SERVER.LOG
      [2010-09-09 02:15:01,245] [funambol.transport.http] [INFO] [23C7D7618D3F0152860C3D201D3767C5] [fol-WENORVVST1BFOlhjYW50aW9u] [xcantion] [] Request processed.
      [2010-09-09 02:23:11,074] [funambol.transport.http] [INFO] [5741EA2A3E51E6BED15C9895CC8A58FF] [fol-WENORVVST1BFOlhjYW50aW9u] [xcantion] [] Closing session 5741EA2A3E51E6BED15C9895CC8A58FF
      [2010-09-09 02:23:11,074] [funambol.engine] [INFO] [5741EA2A3E51E6BED15C9895CC8A58FF] [fol-WENORVVST1BFOlhjYW50aW9u] [xcantion] [] null: synchronization completed
      Ein Auszug aus der ox-listener.log
      [2010-09-09 01:59:16,713] [funambol.pushlistener.health] [INFO] [PushListener-health-thread-1] [] [] [] [] PushListener status:
      > instance: com.funambol.pushlistener.service.PushListenerHeal thStatus@acdd02
      > RegistryMonitor status:
      > instance: com.funambol.pushlistener.service.registry.Registr yMonitor@1f01a29
      > current number of threads in the pool: 1
      > number of running tasks: 0
      > number of scheduled tasks: 21
      > number of completed tasks: 20
      > number of tasks to execute: 1
      > is shut down: false
      > ScheduledTaskExecutor status:
      > instance: com.funambol.pushlistener.service.taskexecutor.Sch eduledTaskExecutor@131c89c
      > current number of threads in the pool: 0
      > number of running tasks: 0
      > number of scheduled tasks: 0
      > number of completed tasks: 0
      > number of tasks to execute: 0
      > is shut down: false
      [2010-09-09 02:05:54,729] [funambol.pushlistener] [INFO] [Thread-3] [] [] [] [] Shutting down PushListener...
      [2010-09-09 02:05:54,729] [funambol.pushlistener.pluginshandler] [INFO] [Thread-3] [] [] [] [] No plugin to stop
      [2010-09-09 02:05:54,729] [funambol.pushlistener.registrymonitor] [INFO] [Thread-3] [] [] [] [] Shutting down RegistryMonitor [com.funambol.pushlistener.service.registry.Registr yMonitor@1f01a29]...
      [2010-09-09 02:05:54,730] [funambol.pushlistener.registrymonitor] [INFO] [Thread-3] [] [] [] [] RegistryMonitor [com.funambol.pushlistener.service.registry.Registr yMonitor@1f01a29] shut down
      [2010-09-09 02:05:54,730] [funambol.pushlistener.taskexecutor] [INFO] [Thread-3] [] [] [] [] Shutting down ScheduledTaskExecutor [this: com.funambol.pushlistener.service.taskexecutor.Sch eduledTaskExecutor@131c89c]
      [2010-09-09 02:05:54,731] [funambol.pushlistener.taskexecutor] [INFO] [Thread-3] [] [] [] [] ScheduledTaskExecutor shut down [this: com.funambol.pushlistener.service.taskexecutor.Sch eduledTaskExecutor@131c89c]
      [2010-09-09 02:05:54,731] [funambol.pushlistener.health] [INFO] [Thread-3] [] [] [] [] Shutting down HealthThread...
      [2010-09-09 02:05:54,731] [funambol.pushlistener.health] [INFO] [Thread-3] [] [] [] [] HealthThread shut down
      [2010-09-09 02:07:09,184] [funambol.pushlistener] [INFO] [main] [] [] [] [] Creating push listener instance
      [2010-09-09 02:07:09,218] [funambol.pushlistener.config] [WARN] [main] [] [] [] [] The configuration bean doesn't contain the registryEntriesIdSpace...using the default value: pushlistener.id
      [2010-09-09 02:07:09,239] [funambol.pushlistener] [INFO] [main] [] [] [] [] Configuration object: com.funambol.pushlistener.service.co...oxlistener.xml]]
      [2010-09-09 02:07:09,240] [funambol.pushlistener] [INFO] [main] [] [] [] [] Initializing PushListener...
      [2010-09-09 02:07:09,293] [funambol.cluster] [INFO] [main] [] [] [] [] Starting cluster with: com.funambol.framework.cluster.Clust...oxlistener.xml]
      [2010-09-09 02:07:09,968] [funambol.cluster] [INFO] [main] [] [] [] [] Cluster initialization...
      [2010-09-09 02:07:12,053] [funambol.cluster] [INFO] [main] [] [] [] [] Cluster members: [127.0.0.1]
      [2010-09-09 02:07:12,053] [funambol.cluster] [INFO] [main] [] [] [] [] Registering MBean: com.funambol:type=Cluster
      [2010-09-09 02:07:12,093] [funambol.pushlistener.taskexecutor] [INFO] [main] [] [] [] [] Creating a ScheduledTaskExecutor instance with maxThreadPoolSize: 50
      [2010-09-09 02:07:12,097] [funambol.pushlistener.registrymonitor] [INFO] [main] [] [] [] [] Creating a RegistryMonitor instance with polling time: 60000, clusterSize: 1, serverIndex: 0 [this: com.funambol.pushlistener.service.registry.Registr yMonitor@1f01a29]
      [2010-09-09 02:07:12,108] [funambol.pushlistener.health] [INFO] [main] [] [] [] [] Creating HealthThread instance...
      [2010-09-09 02:07:12,110] [funambol.pushlistener.pluginshandler] [INFO] [main] [] [] [] [] Creating a PushListenerPluginsHandler instance
      [2010-09-09 02:07:12,141] [funambol.pushlistener.pluginshandler] [INFO] [main] [] [] [] [] Plugin 'com/funambol/oxlistener/plugin/UDPReaderPlugin.xml' is disabled and it will be ignored
      [2010-09-09 02:07:12,144] [funambol.pushlistener.health] [INFO] [main] [] [] [] [] Starting HealthThread (polling time: 600000 milliseconds)
      [2010-09-09 02:07:12,144] [funambol.pushlistener.registrymonitor] [INFO] [main] [] [] [] [] Starting RegistryMonitor (pollingTime: 60000 milliseconds, clusterSize: 1, serverIndex:0) [this: com.funambol.pushlistener.service.registry.Registr yMonitor@1f01a29]
      [2010-09-09 02:07:12,145] [funambol.pushlistener.pluginshandler] [INFO] [main] [] [] [] [] No plugin to start
      Folgende Einstellungen wurden gestet um zum Server zu Connecten...

      http://domain:8080/funambol/ds -> kein auth error
      http://domain/funambol/ds -> kein auth error
      http://IP:8080/funambol/ds -> kein auth error
      http://IP/ -> Auth aber kein sync

      In der Einstellung von zb Kalender bzw. Kontakte wurde folgendest getestet
      oxcal / oxscal
      und
      oxcard

      Folgende Meldung kam im Funambol Client beim versuch zu syncen:
      03:23:07 GMT +1:00 [INFO] - Outlook Sync Client opened
      03:23:24 GMT +1:00 [INFO] - Outlook session opened successfully! Using: Outlook 2007.
      03:23:24 GMT +1:00 [INFO] -
      ************************** BEGIN of Synchronization session **************************
      03:23:24 GMT +1:00 [INFO] - Preparing synchronization of contact...
      03:23:24 GMT +1:00 [ERROR] - Error processing SyncHdr Status
      03:23:24 GMT +1:00 [ERROR] - Error in preparing sync: Error reading status code of command 'SyncHdr'
      03:23:24 GMT +1:00 [INFO] -
      ================================================== ==========
      ================ SYNCHRONIZATION REPORT ================
      ================================================== ==========

      SYNCHRONIZATION COMPLETED WITH ERRORS
      -------------------------------------
      Last error message = "Error reading status code of command 'SyncHdr'"
      Last error code = 700

      Contacts:
      ---------
      Not synced.


      03:23:24 GMT +1:00 [INFO] - Outlook session closed successfully.
      03:23:24 GMT +1:00 [INFO] - Syncronization process completed with errors (code = 700).
      03:23:24 GMT +1:00 [INFO] - Check on server location for update
      03:23:24 GMT +1:00 [ERROR] - No response from update server
      03:23:24 GMT +1:00 [ERROR] - Client update error - uses the stored parameters
      03:23:24 GMT +1:00 [ERROR] - update check failed
      Also Sprich ein: SyncHdr Fehler

      Installation vorgang:
      1. Sauberes cleanes minimal Debian System Fresh Install
      2. Open XChange Installiert
      3. Funambol + connector Installiert
      4. Context eingerichtet + Server (bassierend auf Postfix + Dovecot (mysql variante))
      5. Sync getestet mit den zuvor angelegten User...

      /opt/Funambol/admin/bin/funamboladmin startet das Admin system .. gelang aber nur auf die WebDemo wo ich nix drin machen kann

      http://domain:8080/funambol/ds
      zeigt folgendes:
      Funambol Data Synchronization Server v.7.1.0

      Man=Funambol
      Mod=DS Server
      SwV=7.1.0
      HwV=-
      FwV=-
      OEM=-
      DevID=funambol
      DevTyp=server
      VerDTD=1.2
      UTC=true
      SupportLargeObjs=true
      SupportNumberOfChanges=true
      Ext=X-funambol-smartslow

      Weiß da zufällig wer rat?

      Comment


      • #18
        Ok ich denke ich hab herausgefunden was mein fehler is...

        Ich soll irgendwo ein Public Server Registrieren und ich soll ein User Anlegen für Funambol etc ... naja und in funambol selbst soll ich auch ein User Anlegen ...

        mein Problem ist an der ganzen sache..

        1. In OX6 habe ich ein User bereits Angelegt ... IMAP & SMTP funken auch ...
        2. Muss ich jetzt noch ein User Anlegen oder reicht es den Existierenden User zu bearbeiten damit die Daten zu den richtigen stellen Verweisen?

        3. Wo genau soll ich ein User in Funambol erstellen? Ich gelange nur auf die Webdemo wo ich nix erstelllen kann ausser exampel Kalender und example Kontakt... und diese auch wieder resetten kann... da is nix mit OX Connector geschweige den was anderes...

        4.Wo genau und wie soll ich die entsprechenden EMail Server einstellungen? Was is hier gemeint? Mein E-Mail Server läuft und die Account Verwaltung läuft über die DB aber nicht von OX6 aus... Oder ist hier die Email Einstellung gemeint wie und wo ich auf den Email Server Zugreife??

        Ist nich wirklich berauschend geschrieben was nun gemeint ist... Sorry für die Verwirrung?!

        Comment


        • #19
          Hi Xcantation,

          ich weiß ja nicht, ob das Thema noch aktuell ist, aber ich hab's folgendermaßen gemacht:

          Originally posted by Xcantion View Post
          Ich soll irgendwo ein Public Server Registrieren und ich soll ein User Anlegen für Funambol etc ... naja und in funambol selbst soll ich auch ein User Anlegen ...
          Genau, auf meinem Server eine OX-Installation angelegt, dafür einen entsprechenden vhost (Apache) angelegt. Den vhost mit einem permanenten redirect auf https://, da ich kein unverschlüsseltes Login ermöglichen will.

          Danach Funambol aufgesetzt und - gaaaaanz wichtig! - den Port für den Tomcat geändert! Da bei mir auf 8080 (tomcat-default) ein squid läuft, bin ich auch 8010 ausgewichen. Dann den Tomcat-Admin-Port von 8009 auf 8008 geändert, da OX den gleichen nutzte ...

          Im DNS einen Eintrag für Funambol und OX erstellt (ox.SERVER.TLD und funambol.SERVER.TLD), in der lokalen /etc/hosts einen Eintrag "127.0.0.1 ox-localhost" angelegt und im lokalen Nameserver einen entsprechenden CNAME generiert.
          Dann einen Apache vhost für ox-localhost erzeugt und die Apache-Konfiguration für OX reinkopiert. Wichtig: Hier kein SSL, dafür aber beschränkt auf die lokale IP! Damit ist ein Login von außen auf diese "Instanz" nicht möglich.

          Funambol mit MySQL konfiguriert, das OX-Plugin installiert, den Listener und Connector konfiguriert (Wichtig: Port für OX-Listener im Startscript ändern, da 3101 bereits belegt!) und in allen (!) Startscripten von Funambol JAVA_HOME bzw. JRE_HOME auf die bundled Version in $FUNAMBOL_HOME/tools/jre-1.6.0/jre gesetzt.

          Die normale Datenbank aus dem $FUNAMBOL_HOME/bin/funambol auskommentiert.
          Im $FUNAMBOL_HOME/bin install-modules aufgerufen und die Datenbank komplett erstellen lassen

          Funambol gestartet
          ox-listener gestartet

          Funambol-Admin gestartet ($FUNAMBOL_HOME/admin/bin/funamboladmin) und den Server mit Port angegeben, dann entsprechend konfiguriert. OX soll sich dann mit
          http://ox-localhost:80
          verbinden.
          Funambol-Admin passwort geändert, die config-Dateien nach "sa" gegrept und das Passwort dort auch manuell auf das neue gesetzt! Danach Funambol komplett neu starten.

          Im Funambol keine Benutzer anlegen!

          Originally posted by Xcantion View Post
          mein Problem ist an der ganzen sache..

          1. In OX6 habe ich ein User bereits Angelegt ... IMAP & SMTP funken auch ...
          2. Muss ich jetzt noch ein User Anlegen oder reicht es den Existierenden User zu bearbeiten damit die Daten zu den richtigen stellen Verweisen?
          Dann den client anwerfen - ich mache es mit Funambol 8.7.2 für WinMobile. Konfiguration:
          http://funambol.SERVER.TLD:PORT/funambol/ds
          Benutzer: OX-User, ggf. mit @contextname
          Passwort: OX-Benutzer

          Einstellung für Sync (Erweitert!):
          E-Mail: mail
          Kalender: oxevent
          Adresse: oxcard
          Aufgabe: oxtask

          Damit wird der Benutzer automatisch in Funambol angelegt, auch das Device! Danach mit Funamboladmin Den Benutzer automatisch erzeugen Benutzer entsprechend angepasst, Mail eingetragen, Mailserver angelegt, Benutzer zum Mailserver hinzugefügt.

          Mail funktioniert der Sync erst nach dem initialen Verbinden mit Funambol und dem danach erfolgten Anpassen im Funamboladmin.

          Originally posted by Xcantion View Post
          3. Wo genau soll ich ein User in Funambol erstellen? Ich gelange nur auf die Webdemo wo ich nix erstelllen kann ausser exampel Kalender und example Kontakt... und diese auch wieder resetten kann... da is nix mit OX Connector geschweige den was anderes...

          4.Wo genau und wie soll ich die entsprechenden EMail Server einstellungen? Was is hier gemeint? Mein E-Mail Server läuft und die Account Verwaltung läuft über die DB aber nicht von OX6 aus... Oder ist hier die Email Einstellung gemeint wie und wo ich auf den Email Server Zugreife??

          Ist nich wirklich berauschend geschrieben was nun gemeint ist... Sorry für die Verwirrung?!
          S. Oben!

          Wenn jetzt noch weitere Fragen aufkommen dann bitte per PN.
          Grüße von der Nordseeküste (da wo andere Leute Urlaub machen)

          sailor

          Und der meint zur EDV:

          "Jede hinreichend fortgeschrittene Technologie ist von Magie nicht zu
          unterscheiden."
          Arthur C. Clarke's (*1917) Drittes Gesetz
          (brit. SciFi-Autor, u. a. "2001-Odyssee im Weltraum" [1968])

          Comment

          Working...
          X