Announcement

Collapse
No announcement yet.

Sieve subfolder rules

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • goad
    replied
    Updated to OX 6.18.1 Rev5 ( 2010-10-18 11:41:38 ) and problem solved by following the solution in this thread:

    http://www.open-xchange.com/forum/sh...olders-problem

    In /etc/dovecot/dovecot.conf:

    namespace private {
    separator = .
    prefix = INBOX.
    inbox = yes
    ...
    Now IMAP clients, Open-XChange and the sieve rules all use "." as the folder separator and all our mobile devices (Samsung Galaxy, iPhone, HTC Desire, Motorola Milestone) sync e-mails including subfolders correctly again.

    Hope this helps some one else.

    --
    Goad

    Leave a comment:


  • goad
    replied
    Some more information for you: after we changed the separator in dovecot from "/" to "." OX6 continued to work correctly as noted above. We also use Thunderbird to access the dovecot server via IMAP directly and Thunderbird also had no problems with "." as separator. However, iPhones and Androids that use ActiveSync with OX6 no longer display the folder hierarchy correctly. I assume that OX6 passes on the separator via ActiveSync to the mail clients on these 'phones but these apps don't like the "." separator.

    In our company it is imperative that iPhones and Androids work correctly with OX6 so it looks like we will have to go back to the "/" separator and edit the sieve rules produced by OX6 by hand if we want subfolders to work.

    It really does look as if OX6 is behaving correctly here but if any one has a better solution than editing the sieve scripts by hand (or updating dovecot) I'd love to hear it.

    --
    Goad

    Leave a comment:


  • goad
    replied
    Thanks, but it looks like this is not an OX6 issue. A similar problem was reported here (for Horde) and dovecot 1.0.x:

    http://www.mail-archive.com/dovecot@.../msg19524.html

    Our Dovecot is using mail directories stored in maildir format with "." as the separator (they used to be part of a courier installation) and the separator for the default namespace was set to "/". It looks like OX6 does indeed read and use this separator when creating sieve scripts.

    We can't update our Dovecot installation easily so we have now changed the advertised separator to "." in the dovecot configuration (and nothing else!) and now OX6 uses "." and the sieve scripts work as expected. So I would suggest closing the bug again since OX6 appears to handle the separator in the only logical way possible by using the advertised value from the sieve server.

    Thanks again for your help.

    --
    Goad

    Leave a comment:


  • Martin Heiland
    replied
    This is now https://bugs.open-xchange.com/show_bug.cgi?id=17233

    Thanks for reporting!

    Leave a comment:


  • Martin Heiland
    replied
    Hi there,

    feel free to open a bug report at bugs.open-xchange.com for this. IIRC we detect the folder separator for IMAP automatically. This setting also needs to be applied for SIEVE scripts.

    Greetings

    Leave a comment:


  • goad
    started a topic Sieve subfolder rules

    Sieve subfolder rules

    Hi,

    We have OX6 SE and dovecot with sieve / ManageSieve running here. In The OX6 GUI we can write filter rules but when we select subfolders the sieve script looks like this:

    Code:
    if header :contains "From" "nagios@mydomain.de"
    {
        fileinto "EDV/nagios" ;
        stop;
    }
    However, our dovecot IMAP server uses "." as the separator between folders and subfolders, so we need to edit the rules by hand to look like this:

    Code:
    if header :contains "From" "nagios@mydomain.de"
    {
        fileinto "EDV.nagios" ;
        stop;
    }
    My question: is there any way to configure the OX6 sieve bundle so that it uses "." instead of "/" as the folder separator when generating the sieve scripts? If not, I would like to request this as feature for forthcoming versions.

    Thanks in advance.

    --
    Goad
Working...
X