Announcement

Collapse
No announcement yet.

Java error while installing OX in Ubuntu 10.04

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    Hi,

    Please find the below output of my java version

    root@sfdlabs:~# java -version
    java version "1.5.0_22"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_22-b03)
    Java HotSpot(TM) Server VM (build 1.5.0_22-b03, mixed mode)

    Leave a comment:


  • Martin Heiland
    replied
    Could you please provide the output auf "java -version"?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    But When I'm trying to install it is giving an error.

    Please somebody help

    Leave a comment:


  • Martin Heiland
    replied
    i just installed an Ubuntu 10.04 Server with OX 6.18 - without any problems.

    Greetings

    Leave a comment:


  • Martin Heiland
    replied
    Gonna check this. Thanks for reporting.

    Leave a comment:


  • Guest's Avatar
    Guest started a topic Java error while installing OX in Ubuntu 10.04

    Java error while installing OX in Ubuntu 10.04

    Hi,

    I'm getting java.lang error while installing OX in my live Ubuntu 10.04 server. Please the error log below.

    root@sfdlabs:~# /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P my_password

    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java :621)
    at java.security.SecureClassLoader.defineClass(Secure ClassLoader.java:124)
    at java.net.URLClassLoader.defineClass(URLClassLoader .java:260)
    at java.net.URLClassLoader.access$100(URLClassLoader. java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java: 195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:3 07)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:2 52)
    at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:320)

    How can I over come with this error.

    Please hlep.

    Thanks,
    Gulab Pasha
Working...
X