Announcement

Collapse
No announcement yet.

Connection refused to host

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Carsten Hoeger
    replied
    The answer is most likely in the logs (/var/opt/open-xchange/open-xchange-admin.log.0)

    Leave a comment:


  • Guest's Avatar
    Guest replied
    RMI authentication is enabled

    Hi friends, i dont speak deutsch,neither english, but this seems quite similar to my case,because i can not register the server, could it be rmi related?

    This is the message:

    com.openexchange.admin.rmi.exceptions.PoolExceptio n: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=383039001-1

    i'm using spanish translation of debian etchand the sun java sdk, becuse i use my pc to make sales presentations of the open source advantage and so on

    this is the history:
    -------------------------------------------------------------
    ccs-adsl-wlandr:~# /opt/open-xchange/sbin/oxinstaller --servername=ccs-adsl-wlandr --configdb-pass=db_password \
    > --master-pass=admin_master_password
    setting up groupware configuration /opt/open-xchange/etc/groupware
    ................................................
    groupware daemon must now be restarted if already running
    setting up admin daemon configuration /opt/open-xchange/etc/admindaemon
    ......................
    *** RMI authentication is enabled
    using oxadminmaster as master account
    admin daemon must now be restarted if already running
    ccs-adsl-wlandr:~# /etc/init.d/open-xchange-admin restart
    Restarting Open-Xchange Admin Daemon: open-xchange-admin.
    ccs-adsl-wlandr:~# /opt/open-xchange/sbin/registerserver -n ccs-adsl-wlandr -A oxadminmaster -P admin_master_password
    server could not be registered:
    Server response:
    com.openexchange.admin.rmi.exceptions.PoolExceptio n: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=383039001-1

    my apologies in advance if this is not the correct thread

    Leave a comment:


  • Guest's Avatar
    Guest replied
    server could not be registered:
    Error: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused
    I allso got alot of these messages, on my CentOS52 system it looks like not all the open-xchange processes are not terminated if I execute the init.d scripts or I just takes time to terminate. then a kill -9 comes handy

    Tronn

    Leave a comment:


  • Carsten Hoeger
    replied
    Originally posted by technomensch View Post
    Code:
    $ sudo /opt/open-xchange/sbin/registerserver -n localhost -A oxadminmaster -P <<pwd removed>>
    server could not be registered: 
    Error: Connection refused to host: localhost; nested exception is: 
    	java.net.ConnectException: Connection refused
    Code:
    $ more /etc/hosts 
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    192.168.1.104 localhost <<hostname removed>>
    
    $ ifconfig
    eth1      Link encap:Ethernet  HWaddr 00:0c:76:9c:42:0f  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:19 Base address:0xc400 
    
    eth2      Link encap:Ethernet  HWaddr 00:12:17:58:fb:b9  
              inet addr:192.168.1.104  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::212:17ff:fe58:fbb9/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:150995 errors:0 dropped:0 overruns:0 frame:0
              TX packets:98794 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:189517709 (180.7 MB)  TX bytes:8199499 (7.8 MB)
              Interrupt:20 Base address:0xc000
    remove localhost from the line starting with your machines ip address in /etc/hosts and add a new line

    Code:
    127.0.0.1       localhost
    to /etc/hosts

    Leave a comment:


  • Guest's Avatar
    Guest replied
    lost in translation

    I have been trying to troubleshoot this same issue, but I'm using the google translation and I think I'm missing something:

    Code:
    #java -version
    java version "1.5.0_16"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
    Java HotSpot(TM) Client VM (build 1.5.0_16-b02, mixed mode, sharing)
    
    #javac -version
    javac 1.5.0_16
    javac: no source files
    
    # update-alternatives --config java
    
    There are 2 alternatives which provide `java'.
    
      Selection    Alternative
    -----------------------------------------------
    *         1    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
    +        2    /usr/lib/jvm/java-6-sun/jre/bin/java
    
    # update-alternatives --config javac
    
    There is only 1 program which provides javac
    (/usr/lib/jvm/java-1.5.0-sun/bin/javac). Nothing to configure.
    Code:
    $ sudo /etc/init.d/open-xchange-admin startStarting Open-Xchange Admin Daemon: open-xchange-admin
    .

    Code:
    $ sudo /opt/open-xchange/sbin/registerserver -n localhost -A oxadminmaster -P <<pwd removed>>
    server could not be registered: 
    Error: Connection refused to host: localhost; nested exception is: 
    	java.net.ConnectException: Connection refused
    Code:
    $ more /etc/hosts 
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    192.168.1.104 localhost <<hostname removed>>
    
    $ ifconfig
    eth1      Link encap:Ethernet  HWaddr 00:0c:76:9c:42:0f  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:19 Base address:0xc400 
    
    eth2      Link encap:Ethernet  HWaddr 00:12:17:58:fb:b9  
              inet addr:192.168.1.104  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::212:17ff:fe58:fbb9/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:150995 errors:0 dropped:0 overruns:0 frame:0
              TX packets:98794 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:189517709 (180.7 MB)  TX bytes:8199499 (7.8 MB)
              Interrupt:20 Base address:0xc000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:6660 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6660 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:768795 (750.7 KB)  TX bytes:768795 (750.7 KB)
    Last edited by technomensch; 08-12-2008, 05:37 AM. Reason: added java alternative options

    Leave a comment:


  • Guest's Avatar
    Guest replied
    ich habe einfach "nur" ein dpkg -i *.deb gemacht.
    das lief so schnell durch, dass mir fehlende pakete einfach nicht aufgefallen sind.

    Leave a comment:


  • Carsten Hoeger
    replied
    Originally posted by admin View Post
    Eigentlich darf das ja nicht funktionieren, es seih denn, die Abhaengigkeiten waeren nicht i.O.

    Code:
    sudo dpkg -i open-xchange_6.4.1-13_all.deb
    Selecting previously deselected package open-xchange.
    (Reading database ... 54883 files and directories currently installed.)
    Unpacking open-xchange (from open-xchange_6.4.1-13_all.deb) ...
    dpkg: dependency problems prevent configuration of open-xchange:
     open-xchange depends on open-xchange-common (>= 6.1.0); however:
      Package open-xchange-common is not installed.
     open-xchange depends on open-xchange-libs (= 6.4.1-13); however:
      Package open-xchange-libs is not installed.
    dpkg: error processing open-xchange (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     open-xchange
    Also mich interessiert jetzt wirklich, was da schiefgelaufen ist.
    Dieser Post sollte nicht als admin passieren und er war von mir.

    Leave a comment:


  • admin
    replied
    Originally posted by onex View Post
    das problem ist gelösst!
    es hatte die ganze zeit ein paket gefehlt ... (ox-libs)
    also wichtig ... immer erst die pakete auf vollständigkeit überprüfen, dann losschreien ;-) ;-) ;-)

    vielen dank an herr kraft für seine hilfe!!!

    Eigentlich darf das ja nicht funktionieren, es seih denn, die Abhaengigkeiten waeren nicht i.O.

    Code:
    sudo dpkg -i open-xchange_6.4.1-13_all.deb
    Selecting previously deselected package open-xchange.
    (Reading database ... 54883 files and directories currently installed.)
    Unpacking open-xchange (from open-xchange_6.4.1-13_all.deb) ...
    dpkg: dependency problems prevent configuration of open-xchange:
     open-xchange depends on open-xchange-common (>= 6.1.0); however:
      Package open-xchange-common is not installed.
     open-xchange depends on open-xchange-libs (= 6.4.1-13); however:
      Package open-xchange-libs is not installed.
    dpkg: error processing open-xchange (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     open-xchange
    Also mich interessiert jetzt wirklich, was da schiefgelaufen ist.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    PROBLEM GELÖSST !!!!

    das problem ist gelösst!
    es hatte die ganze zeit ein paket gefehlt ... (ox-libs)
    also wichtig ... immer erst die pakete auf vollständigkeit überprüfen, dann losschreien ;-) ;-) ;-)

    vielen dank an herr kraft für seine hilfe!!!

    Leave a comment:


  • Guest's Avatar
    Guest replied
    nichts. diese datei ist komplett leer, bzw. 0 byte gross

    Leave a comment:


  • Manuel Kraft
    replied
    Originally posted by onex View Post
    das ist mein vollständiges logfile ... mehr steht da nicht drin.
    wie kann ich denn prüfen, wo die admin-tools hängen, bzw. warum kein "successful started..." kommt.

    ich habe gerade herausgefunden, dass nach einem admin-daemon-start folgender prozess erscheint:
    Code:
    root     13355 17.8  3.4 297420 35664 ?        Sl   21:49   0:02 /usr/bin/java -Djava.net.preferIPv4Stack=true -Xms50M -Xmx50M -Dopenexchange.propfile=/opt/open-xchange/etc/admindaemon/system.properties -Dconfigdir=/opt/open-xchange/etc/admindaemon -Djava.util.logging.config.file=/opt/open-xchange/etc/admindaemon/file-logging.properties -Duser.timezone=GMT -Dlibdir=/opt/open-xchange/lib -jar /opt/open-xchange/lib/org.eclipse.osgi_3.2.2.ox.jar -configuration file:/opt/open-xchange/etc/admindaemon/osgi/
    wenn ich dann z.b. listcontext aufrufe stirbt dieser prozess nach dem connection refused-fehler

    Hi,

    was steht den in folgendem logfile drin:

    /var/log/open-xchange/open-xchange-admin-console.log



    Ciao

    Manuel

    Leave a comment:


  • Guest's Avatar
    Guest replied
    das ist mein vollständiges logfile ... mehr steht da nicht drin.
    wie kann ich denn prüfen, wo die admin-tools hängen, bzw. warum kein "successful started..." kommt.

    ich habe gerade herausgefunden, dass nach einem admin-daemon-start folgender prozess erscheint:
    Code:
    root     13355 17.8  3.4 297420 35664 ?        Sl   21:49   0:02 /usr/bin/java -Djava.net.preferIPv4Stack=true -Xms50M -Xmx50M -Dopenexchange.propfile=/opt/open-xchange/etc/admindaemon/system.properties -Dconfigdir=/opt/open-xchange/etc/admindaemon -Djava.util.logging.config.file=/opt/open-xchange/etc/admindaemon/file-logging.properties -Duser.timezone=GMT -Dlibdir=/opt/open-xchange/lib -jar /opt/open-xchange/lib/org.eclipse.osgi_3.2.2.ox.jar -configuration file:/opt/open-xchange/etc/admindaemon/osgi/
    wenn ich dann z.b. listcontext aufrufe stirbt dieser prozess nach dem connection refused-fehler
    Last edited by onex; 03-03-2008, 10:20 PM.

    Leave a comment:


  • Manuel Kraft
    replied
    Originally posted by onex View Post
    die open-xchange-admin-daemons lassen sich wunderbar starten. im logile steht auch nix "falsches":
    Code:
    03.03.2008 11:35:50 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 11:35:50 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    03.03.2008 19:56:50 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 19:56:51 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    03.03.2008 19:59:22 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 19:59:22 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    03.03.2008 19:59:36 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 19:59:36 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    die fehler kommen bei listcontext und/oder listuser auch, also bei eigentlich fast allen tools. initconfigdb und oxinstaller liefen fehlerfrei durch.

    Wenn der admindaemon neugestartet wird, steht normalerweise im logfile so etwas wie:

    INFO: Admindaemon successfully started!


    Kommt diese Nachricht nach einem Admindaemon neustart? Ausserdem sollte auch die JMX Url im log erscheinen wenn der Daemon erfolgreich neugestartet wurde.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    die open-xchange-admin-daemons lassen sich wunderbar starten. im logile steht auch nix "falsches":
    Code:
    03.03.2008 11:35:50 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 11:35:50 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    03.03.2008 19:56:50 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 19:56:51 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    03.03.2008 19:59:22 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 19:59:22 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    03.03.2008 19:59:36 com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    03.03.2008 19:59:36 com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    die fehler kommen bei listcontext und/oder listuser auch, also bei eigentlich fast allen tools. initconfigdb und oxinstaller liefen fehlerfrei durch.

    Leave a comment:


  • Manuel Kraft
    replied
    Originally posted by onex View Post
    hallo herr kraft,

    sehen sie hier einen fehler? ich kann leider nichts ungewöhnliches feststellen.

    more /etc/hosts
    Code:
    127.0.0.1    localhost
    192.168.200.12    sisko.onex.de sisko
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:0C:29:30:1D:D3  
              inet addr:192.168.200.12  Bcast:192.168.200.255  Mask:255.255.255.0
              inet6 addr: fe80::20c:29ff:fe30:1dd3/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:171807 errors:0 dropped:0 overruns:0 frame:0
              TX packets:106756 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:214855550 (204.9 MB)  TX bytes:8664001 (8.2 MB)
              Base address:0x1070 Memory:ec820000-ec840000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:48 errors:0 dropped:0 overruns:0 frame:0
              TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:2568 (2.5 KB)  TX bytes:2568 (2.5 KB)
    Btw. läuft der admindaemon auch? /etc/init.d/open-xchange-admin start|stop ? Bzw. gibts Fehler im logfile /var/log/open-.xchange-admin.log.0 ?

    Leave a comment:

Working...
X