Announcement

Collapse
No announcement yet.

Unknown IMAP server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unknown IMAP server

    After logging in and clicking on the Email Button, the errormessage

    Unknown IMAP server: * OK [CAPABILITY IMAP4rev1 UIDPLUS
    CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCE
    (ACL-0004,-823369537-305)

    is displayed.

    The IMAP server is running Courier IMAP.

    The following package versions are installed, just in case that matters:

    open-xchange_6.4.1-8_all.deb
    open-xchange-admin_6.4.1-5_all.deb
    open-xchange-admin-client_6.4.1-5_all.deb
    open-xchange-admin-doc_6.4.1-5_all.deb
    open-xchange-admin-plugin-hosting_6.2.0-4_all.deb
    open-xchange-common_6.4.0-1_all.deb
    open-xchange-config-hosting_6.4.1-2_all.deb
    open-xchange-gui_6.4.1-6_all.deb
    open-xchange-libs_6.4.1-8_all.deb
    open-xchange-online-help-de_6.2.0-10_all.deb
    open-xchange-online-help-en_6.2.0-10_all.deb
    open-xchange-online-help-fr_6.2.0-9_all.deb

    Kind regards,

    -Walter Dörr

  • #2
    Originally posted by wdoerr View Post
    After logging in and clicking on the Email Button, the errormessage

    Unknown IMAP server: * OK [CAPABILITY IMAP4rev1 UIDPLUS
    CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCE
    (ACL-0004,-823369537-305)

    is displayed.

    The IMAP server is running Courier IMAP.

    The following package versions are installed, just in case that matters:

    open-xchange_6.4.1-8_all.deb
    open-xchange-admin_6.4.1-5_all.deb
    open-xchange-admin-client_6.4.1-5_all.deb
    open-xchange-admin-doc_6.4.1-5_all.deb
    open-xchange-admin-plugin-hosting_6.2.0-4_all.deb
    open-xchange-common_6.4.0-1_all.deb
    open-xchange-config-hosting_6.4.1-2_all.deb
    open-xchange-gui_6.4.1-6_all.deb
    open-xchange-libs_6.4.1-8_all.deb
    open-xchange-online-help-de_6.2.0-10_all.deb
    open-xchange-online-help-en_6.2.0-10_all.deb
    open-xchange-online-help-fr_6.2.0-9_all.deb

    Kind regards,

    -Walter Dörr
    Hi,

    which version of Courier are you running?

    Comment


    • #3
      I am using courier-imap-4.0.3.

      Comment


      • #4
        Hi,

        can you please post the IMAp Greeting when you connect via telnet on port 143 like:

        cutmasta-xen-srv:~# telnet localhost 143
        Trying 127.0.0.1...
        Connected to localhost.
        Escape character is '^]'.
        * OK Dovecot ready.



        Do an telnet to your imap server with port 143 and post the complete output. Because OX tries to resolv the IMAP Server via the IMAP greeting like
        "* OK Dovecot ready."



        Regards,

        Manuel Kraft

        Comment


        • #5
          Hello,

          this is the IMAP login banner:

          Escape character is '^]'.
          * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc. See COPYING for distribution information.

          (this is just one line)


          Kind regards,

          -Walter Dörr

          Comment


          • #6
            Ok,

            thanks for the report of the greeting. i will forward this problem now to one of our devs to have a deeper look. seems that the mailsystem expects the IMAP Server name before any capabilities.


            Regards,


            Manuel

            Comment


            • #7
              This is an excerpt from open-xchange.log

              19.03.2008 12:29:41 com.openexchange.groupware.settings.RdbSettingStor age readSharedValue
              SCHWERWIEGEND: Problem while reading setting value.
              ACL-0004 Category=8 Message=Unknown IMAP server: * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCE exc
              eptionID=-1759970284-2556
              at com.openexchange.groupware.settings.ConfigTree$17. getValue(ConfigTree.java:663)
              at com.openexchange.groupware.settings.RdbSettingStor age.readSharedValue(RdbSettingStorage.java:219)
              at com.openexchange.groupware.settings.RdbSettingStor age.readValues(RdbSettingStorage.java:178)
              at com.openexchange.groupware.settings.RdbSettingStor age.readSubValues(RdbSettingStorage.java:275)
              at com.openexchange.groupware.settings.RdbSettingStor age.readValues(RdbSettingStorage.java:174)
              at com.openexchange.groupware.settings.RdbSettingStor age.readSubValues(RdbSettingStorage.java:275)
              at com.openexchange.groupware.settings.RdbSettingStor age.readValues(RdbSettingStorage.java:174)
              at com.openexchange.groupware.settings.RdbSettingStor age.readSubValues(RdbSettingStorage.java:275)
              at com.openexchange.groupware.settings.RdbSettingStor age.readValues(RdbSettingStorage.java:174)
              at com.openexchange.ajax.ConfigMenu.doGet(ConfigMenu. java:121)
              at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
              at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:399)
              at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:138)
              at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
              at com.openexchange.tools.ajp13.AJPv13Request.respons e(AJPv13Request.java:92)
              at com.openexchange.tools.ajp13.AJPv13RequestHandler. createResponse(AJPv13RequestHandler.java:357)
              at com.openexchange.tools.ajp13.AJPv13Connection.crea teResponse(AJPv13Connection.java:168)
              at com.openexchange.tools.ajp13.AJPv13Listener.run(AJ Pv13Listener.java:246)
              at java.lang.Thread.run(Thread.java:595)
              Caused by: ACL-0004 Category=8 Message=Unknown IMAP server: * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=RE
              FERENCE exceptionID=-1759970284-2555
              at com.openexchange.api2.MailInterfaceImpl.applySessi onObject(MailInterfaceImpl.java:587)
              at com.openexchange.api2.MailInterfaceImpl.<init>(Mai lInterfaceImpl.java:580)
              at com.openexchange.api2.MailInterfaceImpl.getQueuedM ailInterface(MailInterfaceImpl.java:414)
              at com.openexchange.api2.MailInterfaceImpl.getInstanc e(MailInterfaceImpl.java:676)
              at com.openexchange.api2.MailInterfaceImpl.getInstanc e(MailInterfaceImpl.java:605)
              at com.openexchange.groupware.settings.ConfigTree$17. getValue(ConfigTree.java:660)
              ... 18 more

              Hope this helps.

              To make things more more interesting:
              there is a user in another context that connects to another IMAP server (running the same Courier Version with the same login banner) that doesn't have this problem!

              Let me know if you need further info to track this problem down.

              Regards,

              -Walter Dörr

              Comment


              • #8
                Please post the "greeting" of the other mail server which the user is using.

                Comment


                • #9
                  Please disregard my last statement about another Courier IMAP server not having the problem. The IMAP server that ox-he doesn't have a problem with is in fact a Cyrus IMAP server.

                  Sorry about the mixup.

                  Anyway, I would like to be able to use Courier IMAP with OX-HE.


                  Regards,

                  -Walter Dörr

                  Comment


                  • #10
                    This is getting weirder by the minute.
                    Even though listuser --csv is showing me an IMAP server that is running Cyrus, I see this in the logfile:

                    Feb 27, 2008 4:39:10 PM com.openexchange.imap.user2imap.User2IMAPAutoDetec tor loadUser2IMAPImpl
                    INFO:
                    IMAP server [xxxx.de/x.x.x.x] greeting successfully mapped to: Courier

                    So OX-HE should be able to correctly detect Courier.

                    This is the banner of the Courier Server in question:

                    Escape character is '^]'.
                    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc. See COPYING for distribution information.


                    Please note that I am NOT saying the OX-HE uses the wrong IMAP Server.
                    What I am saying is that OX-HE was able to correctly identify a Courier IMAP server at the end of February.

                    Regards,

                    -Walter Dörr

                    Comment


                    • #11
                      Originally posted by wdoerr View Post
                      This is getting weirder by the minute.
                      Even though listuser --csv is showing me an IMAP server that is running Cyrus, I see this in the logfile:

                      Feb 27, 2008 4:39:10 PM com.openexchange.imap.user2imap.User2IMAPAutoDetec tor loadUser2IMAPImpl
                      INFO:
                      IMAP server [xxxx.de/x.x.x.x] greeting successfully mapped to: Courier

                      So OX-HE should be able to correctly detect Courier.

                      This is the banner of the Courier Server in question:

                      Escape character is '^]'.
                      * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc. See COPYING for distribution information.


                      Please note that I am NOT saying the OX-HE uses the wrong IMAP Server.
                      What I am saying is that OX-HE was able to correctly identify a Courier IMAP server at the end of February.

                      Regards,

                      -Walter Dörr
                      Hi,

                      is the server reachable from the internet so that our devs can test your imap server? Because it seems that this is a bug, when the greeting is too long and the imap server name/version is at the end of the greeting

                      Comment


                      • #12
                        Originally posted by Manuel Kraft View Post
                        Hi,

                        is the server reachable from the internet so that our devs can test your imap server? Because it seems that this is a bug, when the greeting is too long and the imap server name/version is at the end of the greeting
                        Yes, that's what I thought too.
                        Do you need access to the Courier or the OX-HE server?

                        Comment


                        • #13
                          Originally posted by wdoerr View Post
                          Yes, that's what I thought too.
                          Do you need access to the Courier or the OX-HE server?
                          To the Courier Server. Please priv. Msg me. That nobody else can get access to the imap server. I need 1 working IMAP Login. Thx

                          Comment


                          • #14
                            Originally posted by wdoerr View Post
                            Yes, that's what I thought too.
                            Do you need access to the Courier or the OX-HE server?
                            Hi,

                            we successfully tested your imap server with the development version of OX HE. The patch will be available with one of the next releases.

                            Comment

                            Working...
                            X