Announcement

Collapse
No announcement yet.

No transport provider could be found for protocol/URL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    By the way:

    I've actually haven't found a solution for the logging problem. Had not much time in the last weeks for searching. But i still get the error message "Exception reading reply" when i try to send a mail.
    At the moment i'm a little bit "helpless" and without ideas where to continue the search. It's definitive an problem in the communication between my mailserver (postfix with smtps on port 25 & 465 for testing) and open-xchange.

    If anybody has ideas or better :-) a solution, i would be glad to read it here.

    TIA

    Leave a comment:


  • Guest's Avatar
    Guest replied

    Originally posted by badpyhedy
     第一产业 1958年全镇粮食平均亩产130公斤,总产630万公斤;1978年平均亩产2 64公斤,总产1233万公斤。厂房租赁中共十一届三中全会后,全街道实行家庭联产承包责任制,调动了农民生产积极性,同时,提倡科学种田,大幅度 提高了粮食作物的单产量。党的改革开放政策,使中韩街道办事处经济飞速发展,经济收入有
    <snip>
    厂房租赁建国前人均耕地不足半亩,纯收入不过10元左右,不足以自给。1978年人均纯收入135元,年人均粮食4 17公斤。2000年人均纯收入4567元。
    Can't read chinese/korean/japanese signs. Could you repost this coded in latin/utf8?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hi,

    i'm still working on the log4j, but it's secondary for me. As soon as i have a solution for that, i'm posting the steps.


    @skmel28: See my PM

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Originally posted by renegade1178 View Post
    Hi @ll,

    the error messages from my last posting are gone now, but the problem with sending mail (transport provider) is still there. Anybody an idea?

    Other question what do i have to insert for: com.openexchange.mail.defaultTransportProvider

    Should be the URL for my SMTP-Server, right?
    Could you please post what you did to get rifd of the error messages concerning logging ? My open-xchange installation throws the same error messages.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hi all,

    i've found the error. In file transport.properties you have to write an default fallback protocol for your smtp-server. ok, i filled in the protocol of my server, smtps (!!), but the "s", for my ssl connections was the error.

    Replaced it with the standard variable, and: It work's !!!
    Code:
    # My Input
    com.openexchange.mail.defaultTransportProvider = smtps <-- NOT GOOD ;-)
    
    # Default
    com.openexchange.mail.defaultTransportProvider = smtp <-- Better :-)
    Thanks for your help Martin.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hi @ll,

    the error messages from my last posting are gone now, but the problem with sending mail (transport provider) is still there. Anybody an idea?

    Other question what do i have to insert for: com.openexchange.mail.defaultTransportProvider

    Should be the URL for my SMTP-Server, right?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    That's right, full running logging features would be fine
    In file open-xchange-osgi.log i've found this message, it confuses me a little bit:
    Code:
    !ENTRY org.eclipse.osgi 4 0 2008-10-05 01:19:39.991
    !MESSAGE Bundle initial@reference:file:org.apache.commons.logging.log4j.jar/ [29] is not active.
    
    !ENTRY org.eclipse.osgi 4 0 2008-10-05 01:19:39.991
    !MESSAGE Bundle initial@reference:file:org.apache.log4j.configuration-groupware/ [30] is not active.
    !SESSION 2008-10-05 01:29:44.006 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.5.0_14
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86_64, WS=motif, NL=en_GB
    Command-line arguments:  -configuration file:/opt/open-xchange/etc/groupware/osgi
    
    !ENTRY org.eclipse.osgi 4 0 2008-10-05 01:29:45.155
    !MESSAGE Error starting bundle: initial@reference:file:org.apache.commons.logging.log4j.jar/
    !STACK 0
    org.osgi.framework.BundleException: A fragment bundle cannot be started: initial@reference:file:org.apache.commons.logging.log4j.jar/ [29]
            at org.eclipse.osgi.framework.internal.core.BundleFragment.startWorker(BundleFragment.java:224)
            at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.startBundle(EclipseStarter.java:1140)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.startBundles(EclipseStarter.java:1133)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseStarter.java:630)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:303)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:172)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.main(EclipseStarter.java:149)
    
    !ENTRY org.eclipse.osgi 4 0 2008-10-05 01:29:45.156
    !MESSAGE Error starting bundle: initial@reference:file:org.apache.log4j.configuration-groupware/
    !STACK 0
    org.osgi.framework.BundleException: A fragment bundle cannot be started: initial@reference:file:org.apache.log4j.configuration-groupware/ [30]
            at org.eclipse.osgi.framework.internal.core.BundleFragment.startWorker(BundleFragment.java:224)
            at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.startBundle(EclipseStarter.java:1140)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.startBundles(EclipseStarter.java:1133)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseStarter.java:630)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:303)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:172)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.main(EclipseStarter.java:149)
    
    !ENTRY org.eclipse.osgi 4 0 2008-10-05 01:29:48.776
    !MESSAGE Bundle initial@reference:file:org.apache.commons.logging.log4j.jar/ [29] is not active.
    
    !ENTRY org.eclipse.osgi 4 0 2008-10-05 01:29:48.777
    !MESSAGE Bundle initial@reference:file:org.apache.log4j.configuration-groupware/ [30] is not active.
    open-xchange-console-log:
    Code:
    log4j:WARN Continuable parsing error 18 and column 16
    log4j:WARN The content of element type "category" must match "(param*,(priority|level)?,appender-ref*)".
    log4j:WARN Continuable parsing error 19 and column 23
    log4j:WARN The content of element type "log4j:configuration" must match "(renderer*,appender*,(category|logger)*,root?,categoryFactory?)".
    I'm using Java 1.5, output from java -version:

    java version "1.5.0_14"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_14-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_14-b03, mixed mode)

    Leave a comment:


  • Martin Heiland
    replied
    surely the logging may not be the issue, but to find the issue, logging would be valuable

    btw. what java version are you using? (java -version)

    greetings

    Leave a comment:


  • Guest's Avatar
    Guest replied
    I haven't found anything that belongs to open-xchange or to log4j in my syslog. Maybe i have to take a deeper look with other filtering oprions.

    But that shouldn't be the cause for the transport provider problem.

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    log4j is activated if those bundles are resolved just like they are, i think the log is written to /var/log/syslog on debian.

    Greetings

    Leave a comment:


  • Guest's Avatar
    Guest replied
    That's the output of listbundles:

    Code:
    bundlename: org.eclipse.osgi status: ACTIVE
    bundlename: com.openexchange.authentication.database status: ACTIVE
    bundlename: com.openexchange.axis2 status: ACTIVE
    bundlename: com.openexchange.caching status: ACTIVE
    bundlename: com.openexchange.charset status: ACTIVE
    bundlename: com.openexchange.common status: ACTIVE
    bundlename: com.openexchange.configjump.generic status: ACTIVE
    bundlename: com.openexchange.configread status: ACTIVE
    bundlename: com.openexchange.control status: ACTIVE
    bundlename: com.openexchange.data.conversion.ical.ical4j status: ACTIVE
    bundlename: com.openexchange.global status: ACTIVE
    bundlename: com.openexchange.group.managerequest status: ACTIVE
    bundlename: com.openexchange.groupware.settings.extensions status: ACTIVE
    bundlename: com.openexchange.i18n status: ACTIVE
    bundlename: com.openexchange.imap status: ACTIVE
    bundlename: com.openexchange.mail.filter status: ACTIVE
    bundlename: com.openexchange.management status: ACTIVE
    bundlename: com.openexchange.monitoring status: ACTIVE
    bundlename: com.openexchange.passwordchange.database status: ACTIVE
    bundlename: com.openexchange.passwordchange.servlet status: ACTIVE
    bundlename: com.openexchange.push.udp status: ACTIVE
    bundlename: com.openexchange.resource.managerequest status: ACTIVE
    bundlename: com.openexchange.server status: ACTIVE
    bundlename: com.openexchange.sessiond status: ACTIVE
    bundlename: com.openexchange.smtp status: ACTIVE
    bundlename: com.openexchange.spamhandler.spamassassin status: ACTIVE
    bundlename: javax.servlet status: ACTIVE
    bundlename: net.freeutils.jcharset status: ACTIVE
    bundlename: org.apache.commons.logging status: ACTIVE
    bundlename: org.apache.commons.logging.log4j status: RESOLVED
    bundlename: org.apache.log4j.configuration status: RESOLVED
    bundlename: org.apache.log4j status: ACTIVE
    bundlename: org.eclipse.equinox.event status: ACTIVE
    bundlename: org.eclipse.osgi.services status: ACTIVE
    Everything's active except the log4j, but logfiles are written. Just the open-xchange.log.0 is empty.
    What do i need to set log4j active too?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hi Martin,

    yes, i've installed the server following the instructions for debian on the open-xchange site.

    I just decided to delete all users and contexts. maybe it helps. there are only 4 accounts and one context

    Thanks for your reply.

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    did you install the open-xchange-smtp bundle?
    Check via /opt/open-xchange/sbin/listbundles

    Greetings

    Leave a comment:


  • Guest's Avatar
    Guest started a topic No transport provider could be found for protocol/URL

    No transport provider could be found for protocol/URL

    Hi,

    i've installed Open-Xchange 6 Server-Edition on my Rootserver. Everything is doing fine, except sending mails. Each time i try to send a mail the following error message comes up:

    Error code: No transport provider could be found for protocol/URL "smtps://localhost:25" (MSG-0053,-1119162680-24)

    For all Testaccounts i've added the --imapserver / --imaplogin / --smtpserver values into the database and the password is like the mailpassword. I changed the smtpserver to pure smtp, without any effort.
    I've done everything as it's already described in several postings here in the forum. I've checked the imap./javamail./smtp./transport.properties files several times and spent hours for locating this error, but i've found nothing.

    My Mailserver is running fine since over a year. No error messages in the logfiles. Clients like Thunderbird connect without any problem the him.

    Has anybody an idea how to fix this problem? Or just which config i should have a look at?

    Thanks for all hints.
Working...
X