Announcement

Collapse
No announcement yet.

OX6 not updating?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OX6 not updating?

    Hi,

    as a customer installation w/ OX6SE needs the search fix from the 6821 update, I tried running the Zypper command to get the installation updated ... apart from some SLES packages, no updates were downloaded, even though with a manual access through the browser I can see the new files on the server ... am I doing anything wrong here? Even tried a "zypper ref" to ensure that the list of repository files were up to date ...

  • #2
    Originally posted by Garry View Post
    Hi,

    as a customer installation w/ OX6SE needs the search fix from the 6821 update, I tried running the Zypper command to get the installation updated ... apart from some SLES packages, no updates were downloaded, even though with a manual access through the browser I can see the new files on the server ... am I doing anything wrong here? Even tried a "zypper ref" to ensure that the list of repository files were up to date ...
    Please post the output of
    Code:
    zypper sl| grep open-xchange
    .

    Comment


    • #3
      1 | Yes | Yes | YUM | ox | http://software.open-xchange.com/OX6/stable/SLES10/
      3 | Yes | Yes | YUM | OXUPDATES | http://USERNAME@software.open-xchang...pdates/SLES10/
      6 | Yes | Yes | YUM | UNSUPPORTED | http://software.open-xchange.com/OX6...ed/repo/SLES10

      (when 6820 came out, I used the same zypper update command, which worked fine as far as updating the packages goes)
      Last edited by Garry; 06-22-2009, 01:32 PM.

      Comment


      • #4
        Originally posted by Garry View Post
        1 | Yes | Yes | YUM | ox | http://software.open-xchange.com/OX6/stable/SLES10/
        3 | Yes | Yes | YUM | OXUPDATES | http://USERNAME@software.open-xchang...pdates/SLES10/
        6 | Yes | Yes | YUM | UNSUPPORTED | http://software.open-xchange.com/OX6...ed/repo/SLES10

        (when 6820 came out, I used the same zypper update command, which worked fine as far as updating the packages goes)
        Looks good.
        Please check whether you really use the correct command:

        http://www.open-xchange.com/wiki/ind...ackages#SLES10

        Code:
        zypper up -y -t package

        Comment


        • #5
          Same problem with RedHat 5

          Hi,

          I have the same problem with Redhat 5. The update to build 6820 works fine, but I can't update to 6821.

          Thhe following packages are installed:
          Code:
          [root@ox ~]# rpm -qa |grep open-xchange
          open-xchange-management-6.8.1-4.1
          open-xchange-monitoring-6.8.1-4.1
          open-xchange-dataretention-6.8.1-4.1
          open-xchange-online-help-en-6.8.1-4.1
          open-xchange-configjump-generic-6.8.1-4.1
          open-xchange-common-6.8.1-6.1
          open-xchange-contactcollector-6.8.1-4.2
          open-xchange-conversion-servlet-6.8.1-4.2
          open-xchange-6.8.1-11.1
          open-xchange-settings-extensions-6.8.1-4.2
          open-xchange-server-6.8.1-11.1
          open-xchange-admin-client-6.8.1-7.2
          open-xchange-push-udp-6.8.1-4.2
          open-xchange-spamhandler-default-6.8.1-4.2
          open-xchange-configread-6.8.1-4.1
          open-xchange-cache-6.8.1-4.1
          open-xchange-conversion-engine-6.8.1-4.1
          open-xchange-i18n-6.8.1-4.1
          open-xchange-charset-6.8.1-4.1
          open-xchange-online-help-de-6.8.1-4.1
          open-xchange-control-6.8.1-4.1
          open-xchange-gui-6.8.1-4.1
          open-xchange-admin-plugin-hosting-6.8.1-4.2
          open-xchange-authentication-database-6.8.1-4.2
          open-xchange-axis2-6.8.1-4.2
          open-xchange-admin-doc-6.8.1-7.2
          open-xchange-admin-plugin-hosting-doc-6.8.1-4.2
          open-xchange-group-managerequest-6.8.1-4.2
          open-xchange-resource-managerequest-6.8.1-4.2
          open-xchange-mailfilter-6.8.1-4.2
          open-xchange-global-6.8.1-4.1
          open-xchange-conversion-6.8.1-4.1
          open-xchange-sessiond-6.8.1-4.1
          open-xchange-xml-6.8.1-4.1
          open-xchange-jcharset-1.3.0-18.1
          open-xchange-online-help-fr-6.8.1-4.1
          open-xchange-smtp-6.8.1-4.2
          open-xchange-admin-6.8.1-7.2
          open-xchange-imap-6.8.1-4.2
          open-xchange-admin-soap-6.8.1-4.2
          open-xchange-data-conversion-ical4j-6.8.1-4.2
          The version number of these packages are higher then in http://software.open-xchange.com/OX6/updates/RHEL5/src/

          Comment


          • #6
            Code:
            ox6-test:~ # zypper up -y -t package
            Restoring system sources...Parsing metadata for ox...
            Parsing metadata for SLES10-SP2-Pool...
            Parsing metadata for OXUPDATES...
            Parsing metadata for http://download.opensuse.org/reposit...ons/SLE-10-SP2...
            Parsing metadata for SLES10-SP2-Updates...
            Parsing metadata for UNSUPPORTED...
            Parsing metadata for SUSE Linux Enterprise Server 10 SP2...
            Parsing RPM database...
            Summary:
            Nothing to do.
            Even tried the general-purpose Windows-Fix (reboot), still getting 6820 as front- and backend-version as well as "Nothing to do".

            "zypper lu" also doesn't show any updates ...

            Could it be the update is indeed installed, but the "?"/About menu lists the version incorrectly?
            Interestingly, checking the installed versions via YAST, I get output like:

            Version: 6.8.1-10.1 Installiert: 6.8.1-11.1 Größe: 153.6 K Medium Nr.: 0

            Interestingly, most version shown under "Installiert" are higher than the "Version" output in front, AND higher than available at http://software.open-xchange.com/OX6...SLES10/noarch/ ... !?
            Last edited by Garry; 06-22-2009, 03:00 PM.

            Comment


            • #7
              You are right.
              The build numbers are smaller.
              Only effects RPM based packages.

              We're working on this issue. Fixed packages should be available, ASAP, stay tuned.

              Comment


              • #8
                Tnx, glad to hear it's been pinpointed ...

                Comment


                • #9
                  Package versions fixed

                  Package versions fixed

                  The RPM packages now should be installable using the documented commands. Build numbers have been increased.

                  Sorry for the inconvenience.

                  Comment


                  • #10
                    Yup, looking a lot better now

                    Btw., should the GUI be 6821 too? Backend is listed as 6821, frontend remained at 6820 ...
                    Last edited by Garry; 06-22-2009, 08:47 PM.

                    Comment


                    • #11
                      Hi,

                      UI and server don't need to have the same version since the API in between is stable, even older UI releases work against current servers. The cause for the difference may be that some fix has been made for the server that did not caused gui changes, so the server has been built more often than the ui.

                      Greetings

                      Comment


                      • #12
                        Originally posted by Garry View Post
                        Yup, looking a lot better now

                        Btw., should the GUI be 6821 too? Backend is listed as 6821, frontend remained at 6820 ...
                        No, should be 6821. Just tested it. Did you clear your Browser Cache?

                        Code:
                        rpm -q open-xchange-gui
                        open-xchange-gui-6.8.1-6.1
                        Do you have the same output (tested on SLES10)?

                        Comment


                        • #13
                          Weird - it's 6821 now ... yes, I did clear the browser, and I even reloaded the machine ...

                          Oh well ...

                          Comment

                          Working...
                          X